LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-05-2011, 02:47 PM   #1
erj@greco.com.br
LQ Newbie
 
Registered: Dec 2010
Location: São Paulo, Brasil
Distribution: Mandriva MES5
Posts: 11

Rep: Reputation: 0
Netatalk with Mandriva MES5


I installed netatalk service in my server, but I canīt see it from a Mac workstation.
How can I test netatalk to check if it is working? Service is running, but nothing happens at Mac workstation.
At console I typed service netatalk status and I got:

atalkd (pid 7606) is running...
papd is stopped
timelord is stopped
a2boot is stopped
cnid_metad (pid 8212) is running...
afpd (pid 8221) is running...

The only service I need is sharing files.
obs: mac workstation is working perfectly.
Thanks

Last edited by erj@greco.com.br; 02-05-2011 at 02:51 PM.
 
Old 02-10-2011, 09:26 AM   #2
MCD555
Member
 
Registered: May 2009
Location: Milan, Italy
Distribution: Ubuntu, Debian, Fedora, Oracle Linux
Posts: 106

Rep: Reputation: 9
Quote:
Originally Posted by erj@greco.com.br View Post
I installed netatalk service in my server, but I canīt see it from a Mac workstation.
How can I test netatalk to check if it is working? Service is running, but nothing happens at Mac workstation.
At console I typed service netatalk status and I got:

atalkd (pid 7606) is running...
papd is stopped
timelord is stopped
a2boot is stopped
cnid_metad (pid 8212) is running...
afpd (pid 8221) is running...

The only service I need is sharing files.
obs: mac workstation is working perfectly.
Thanks
Take a look at this link:

http://www.cnpbagwell.com/linux/fedo...6-interworking

Also check your firewall rules: you have to open the 548 tcp port on your linux machine.

Mandriva & Fedora are soooo similar...

Remember: Google is your friend!
;-))

Last edited by MCD555; 02-10-2011 at 09:31 AM.
 
Old 02-14-2011, 01:31 PM   #3
erj@greco.com.br
LQ Newbie
 
Registered: Dec 2010
Location: São Paulo, Brasil
Distribution: Mandriva MES5
Posts: 11

Original Poster
Rep: Reputation: 0
Hello
I tryed to type my server IP at finder window and I was able to access its sharings. I can copy/delete/execute files from/to linux server, but (itīs always a but, at mac workstation, at chooser, when I click on appletalk icon nothing happens. I have to click on Server IP address button and type my server IP, which is 192.168.0.123. Its is annoying and time consuming. I have to do this every time I want to access my server.
At previously version, after I click on appletalk icon (at chooser), the server name comes up right away.
Does anyone have any suggestion?
 
Old 02-14-2011, 04:20 PM   #4
peonuser
Member
 
Registered: Mar 2008
Location: Where ever I am.
Distribution: Various
Posts: 173
Blog Entries: 135

Rep: Reputation: 21
I did not think Apple even used that Appletalk protocol any more. Must be some old old macs. If you can get a tcpip client for your Macs, it might be better. Remember that Appletalk, I think is not routeable. Are you going through a switch? The networking equipment has to support the Appletalk protocol also. The clients and the server should be on the same network. It has been so long since I messed with Appletalk. I think I remember something about setting up a seed so the stations have a unique number. When I had our G3's, we just used tcpip without a problem. Nothing I remember really needs Appletalk, but I could be wrong.

I take that back our ltsp server sent out packets to net boot the g3 's into linux after we quit using os/x. We ran the g3's diskless.

Last edited by peonuser; 02-14-2011 at 04:24 PM.
 
Old 02-14-2011, 04:38 PM   #5
Reuti
Senior Member
 
Registered: Dec 2004
Location: Marburg, Germany
Distribution: openSUSE 11.4
Posts: 1,319

Rep: Reputation: 252Reputation: 252Reputation: 252
Quote:
Originally Posted by peonuser View Post
Remember that Appletalk, I think is not routeable.
It is routable. There was a product called "Apple Internet Router" which has in fact nothing to do with the nowadays Internet (maybe originated from plain "inter-net"), which could route AppleTalk by a Mac which has several network cards. Nevertheless there was an add-on for it "AppleTalk/IP Wide Area Extension" to tunnel AppleTalk through TCP/IP. I used this at that time to connect the AppleTalk networks of two branches.

@erj: You don't like to follow the other thread you started on this topic?
 
Old 02-15-2011, 01:47 AM   #6
peonuser
Member
 
Registered: Mar 2008
Location: Where ever I am.
Distribution: Various
Posts: 173
Blog Entries: 135

Rep: Reputation: 21
Quote:
There was a product called "Apple Internet Router
But that is a kludge even at it's best. Unless you have some real legacy hardware, there is no need for Appletalk. Been there done that. Appletalk like Netbeui as well as Ipx are history.

Last edited by peonuser; 02-15-2011 at 01:48 AM.
 
Old 02-15-2011, 07:44 AM   #7
MCD555
Member
 
Registered: May 2009
Location: Milan, Italy
Distribution: Ubuntu, Debian, Fedora, Oracle Linux
Posts: 106

Rep: Reputation: 9
Quote:
Originally Posted by erj@greco.com.br View Post
Hello
I tryed to type my server IP at finder window and I was able to access its sharings. I can copy/delete/execute files from/to linux server, but (itīs always a but, at mac workstation, at chooser, when I click on appletalk icon nothing happens. I have to click on Server IP address button and type my server IP, which is 192.168.0.123. Its is annoying and time consuming. I have to do this every time I want to access my server.
At previously version, after I click on appletalk icon (at chooser), the server name comes up right away.
Does anyone have any suggestion?
If I well understood your needs: you wanna see the icon of the server in your finder windows, don't you?
In that case, you need to create the file:

/etc/avahi/services/afp.service

that must contain the following code:

Code:
<!DOCTYPE service-group SYSTEM "avahi-service.dtd">
<service-group>
<name replace-wildcards="yes">%h</name>
<service>
<type>_afpovertcp._tcp</type>
<port>548</port>
</service>
</service-group>
and restart your avahi daemon (but may this is not necessary...).

On the other hand, if you wanna see automatically the server at your login just add it to your login user items: just add the "connect to server" option.

Hope this helps.....

Last edited by MCD555; 02-15-2011 at 07:53 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Command ./configure Netatalk with Mandriva MES5 erj@greco.com.br Linux - Newbie 5 12-27-2010 05:57 AM
Netatalk connects through IP not Name nutthick Linux - Networking 2 12-15-2004 01:59 AM
Netatalk maelstrom209 Linux - Networking 0 10-10-2004 01:38 PM
Netatalk? penguinz Linux - Networking 1 04-01-2003 02:57 PM
netatalk-atalk willbob Linux - Networking 1 02-11-2001 03:33 PM


All times are GMT -5. The time now is 02:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration