LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Netatalk with Mandriva MES5 (http://www.linuxquestions.org/questions/linux-newbie-8/netatalk-with-mandriva-mes5-860918/)

erj@greco.com.br 02-05-2011 02:47 PM

Netatalk with Mandriva MES5
 
I installed netatalk service in my server, but I canīt see it from a Mac workstation.
How can I test netatalk to check if it is working? Service is running, but nothing happens at Mac workstation.
At console I typed service netatalk status and I got:

atalkd (pid 7606) is running...
papd is stopped
timelord is stopped
a2boot is stopped
cnid_metad (pid 8212) is running...
afpd (pid 8221) is running...

The only service I need is sharing files.
obs: mac workstation is working perfectly.
Thanks

MCD555 02-10-2011 09:26 AM

Quote:

Originally Posted by erj@greco.com.br (Post 4249406)
I installed netatalk service in my server, but I canīt see it from a Mac workstation.
How can I test netatalk to check if it is working? Service is running, but nothing happens at Mac workstation.
At console I typed service netatalk status and I got:

atalkd (pid 7606) is running...
papd is stopped
timelord is stopped
a2boot is stopped
cnid_metad (pid 8212) is running...
afpd (pid 8221) is running...

The only service I need is sharing files.
obs: mac workstation is working perfectly.
Thanks

Take a look at this link:

http://www.cnpbagwell.com/linux/fedo...6-interworking

Also check your firewall rules: you have to open the 548 tcp port on your linux machine.

Mandriva & Fedora are soooo similar...

Remember: Google is your friend!
;-))

erj@greco.com.br 02-14-2011 01:31 PM

Hello
I tryed to type my server IP at finder window and I was able to access its sharings. I can copy/delete/execute files from/to linux server, but (itīs always a but, at mac workstation, at chooser, when I click on appletalk icon nothing happens. I have to click on Server IP address button and type my server IP, which is 192.168.0.123. Its is annoying and time consuming. I have to do this every time I want to access my server.
At previously version, after I click on appletalk icon (at chooser), the server name comes up right away.
Does anyone have any suggestion?

peonuser 02-14-2011 04:20 PM

I did not think Apple even used that Appletalk protocol any more. Must be some old old macs. If you can get a tcpip client for your Macs, it might be better. Remember that Appletalk, I think is not routeable. Are you going through a switch? The networking equipment has to support the Appletalk protocol also. The clients and the server should be on the same network. It has been so long since I messed with Appletalk. I think I remember something about setting up a seed so the stations have a unique number. When I had our G3's, we just used tcpip without a problem. Nothing I remember really needs Appletalk, but I could be wrong.

I take that back our ltsp server sent out packets to net boot the g3 's into linux after we quit using os/x. We ran the g3's diskless.

Reuti 02-14-2011 04:38 PM

Quote:

Originally Posted by peonuser (Post 4258292)
Remember that Appletalk, I think is not routeable.

It is routable. There was a product called "Apple Internet Router" which has in fact nothing to do with the nowadays Internet (maybe originated from plain "inter-net"), which could route AppleTalk by a Mac which has several network cards. Nevertheless there was an add-on for it "AppleTalk/IP Wide Area Extension" to tunnel AppleTalk through TCP/IP. I used this at that time to connect the AppleTalk networks of two branches.

@erj: You don't like to follow the other thread you started on this topic?

peonuser 02-15-2011 01:47 AM

Quote:

There was a product called "Apple Internet Router
But that is a kludge even at it's best. Unless you have some real legacy hardware, there is no need for Appletalk. Been there done that. Appletalk like Netbeui as well as Ipx are history.

MCD555 02-15-2011 07:44 AM

Quote:

Originally Posted by erj@greco.com.br (Post 4258158)
Hello
I tryed to type my server IP at finder window and I was able to access its sharings. I can copy/delete/execute files from/to linux server, but (itīs always a but, at mac workstation, at chooser, when I click on appletalk icon nothing happens. I have to click on Server IP address button and type my server IP, which is 192.168.0.123. Its is annoying and time consuming. I have to do this every time I want to access my server.
At previously version, after I click on appletalk icon (at chooser), the server name comes up right away.
Does anyone have any suggestion?

If I well understood your needs: you wanna see the icon of the server in your finder windows, don't you?
In that case, you need to create the file:

/etc/avahi/services/afp.service

that must contain the following code:

Code:

<!DOCTYPE service-group SYSTEM "avahi-service.dtd">
<service-group>
<name replace-wildcards="yes">%h</name>
<service>
<type>_afpovertcp._tcp</type>
<port>548</port>
</service>
</service-group>

and restart your avahi daemon (but may this is not necessary...).

On the other hand, if you wanna see automatically the server at your login just add it to your login user items: just add the "connect to server" option.

Hope this helps.....


All times are GMT -5. The time now is 05:00 AM.