LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-30-2011, 10:57 PM   #1
Lloyd Ewing
LQ Newbie
 
Registered: Nov 2008
Location: Austin Texas USA
Distribution: Ubuntu 10.04 LTS (Lucid)
Posts: 9

Rep: Reputation: 0
Need to Reset Screen Resolution Out-of-range on Ubuntu 10.04


While trying to get the screen resolution I need, I have set the value to a setting that my monitor will not display. When my Ubuntu 10.04 boots, the screen just displays the out-of-range message and I cannot use it.

I think I found part of the solution on this page
https://wiki.ubuntu.com/X/Config/Resolution
which says to delete a file:
rm ~/.config/monitors.xml

Someone told me that I need to boot from grup into single-user mode, and I found out how to do that here:
http://blog.troyastle.com/2010/06/bo...untu-1004.html

My problem is that I cannot find the monitors.xml file.
The command: ls /home -a
shows only: . ..
I thought it should have a subdirectory containing .config and all of my other files. What do I need to do to access my account home directory so I can delete that file?

I am trying to use a flaky Nvidia driver so I will probably have to go through this process a few times before I get it to work. Thanks for any help,

Lloyd
 
Old 04-30-2011, 11:03 PM   #2
corp769
Guru
 
Registered: Apr 2005
Posts: 5,814

Rep: Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001
Hello,

The ls command you provided is listing the files within the /home directory ONLY, and not the subdirectories. Before we go any further with your issue, perform the ls command under your /home/USER directory, of course replacing USER with your own username.

Cheers,

Josh
 
0 members found this post helpful.
Old 05-01-2011, 12:36 AM   #3
Lloyd Ewing
LQ Newbie
 
Registered: Nov 2008
Location: Austin Texas USA
Distribution: Ubuntu 10.04 LTS (Lucid)
Posts: 9

Original Poster
Rep: Reputation: 0
Josh,
On my system the command: ls -a
shows the subdirectories as well as the hidden files.
When I enter the command ls by itself it shows no files or directories.

Last edited by Lloyd Ewing; 05-01-2011 at 12:42 AM. Reason: Specify that this posting is a response to previous comment
 
Old 05-01-2011, 12:58 AM   #4
corp769
Guru
 
Registered: Apr 2005
Posts: 5,814

Rep: Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001Reputation: 1001
Hold on, what exactly do you mean?
 
0 members found this post helpful.
Old 05-01-2011, 06:55 AM   #5
Lloyd Ewing
LQ Newbie
 
Registered: Nov 2008
Location: Austin Texas USA
Distribution: Ubuntu 10.04 LTS (Lucid)
Posts: 9

Original Poster
Rep: Reputation: 0
Josh,
To say it in other words, the directory /home appears to be empty.
As far as I can see at this point there are no subdirectories or files in it.
I cannot find the home directory for my user account, so I cannot change the file it contains.

If Ubuntu still places the user home directory in /home, then there must be a reason why it is not visible to me at this time. I provided the links to the pages I was working on so you could see how I got to where I am. Have you tried booting from grub as described in that link, and is your user directory available from there on your system?
 
Old 05-01-2011, 08:27 AM   #6
Mr. Bill
Member
 
Registered: Mar 2011
Location: Maryland, USA
Distribution: Xubuntu 14.04 - 64
Posts: 182

Rep: Reputation: 14
Lloyd~

When you enter the Grub menu, select "Recovery Mode" (second entry). This will show a lot of text during system boot, then a menu will appear. Run "xfix". That will reset your faulty config. You can then continue normal boot from there.
 
Old 05-01-2011, 11:37 PM   #7
Lloyd Ewing
LQ Newbie
 
Registered: Nov 2008
Location: Austin Texas USA
Distribution: Ubuntu 10.04 LTS (Lucid)
Posts: 9

Original Poster
Rep: Reputation: 0
Mr. Bill,
That doesn't seem to work. I hit the down-arrow to select recovery mode then hit enter. My version of Ubuntu doesn't show any text or any menu. The monitor shows a blank screen and then it shows the error saying that the signal is out of range.
 
Old 05-02-2011, 10:44 AM   #8
Mr. Bill
Member
 
Registered: Mar 2011
Location: Maryland, USA
Distribution: Xubuntu 14.04 - 64
Posts: 182

Rep: Reputation: 14
Hmmm... That's peculiar. I'm also running 10.04. Just tried "Recovery Mode" to see if it had changed since 8.04, but I still got the low-res text and menu before x starts. However, they did remove the all-powerful XFIX and replaced it with Boot into Failsafe Graphics Mode.

Guess we'll try a different approach: Have you tried accessing your /home directory from a live/rescue CD? That should allow you to edit or remove the offending config file...
 
Old 05-03-2011, 01:09 PM   #9
Lloyd Ewing
LQ Newbie
 
Registered: Nov 2008
Location: Austin Texas USA
Distribution: Ubuntu 10.04 LTS (Lucid)
Posts: 9

Original Poster
Rep: Reputation: 0
Mr.Bill, Thanks for the suggestions. Booting from the live CD lets me look at the file I need to delete but it only gives me read access to my files. I would guess that the differences we see between our two systems are because the miserable Nvidia driver I am trying to use does not support some modes and features.

After having all of this time to think about the problem, I am feeling that it is likely that the problem is that grub does not mount the partition which contains my home directory. When I installed Linux the advice I got was that I should place my /home directory on a separate partition. It might be that mounting my home directory normally occurs in the initialization process after the point where I have access to grub.

The problem is figuring out how to mount this partition from the command line. I have seem the mount command used so I have a general idea of what it does, but when I have searched for information on the mount command in the past all I found was man pages. I also need to know what device is the partition that contains my home directory. I am sure that there are examples and other more friendly explanations of how to use the mount command, so I will keep looking.
 
Old 05-04-2011, 03:20 AM   #10
Lloyd Ewing
LQ Newbie
 
Registered: Nov 2008
Location: Austin Texas USA
Distribution: Ubuntu 10.04 LTS (Lucid)
Posts: 9

Original Poster
Rep: Reputation: 0
Today I went through the whole process of learning how to mount the partition with my home directory. I deleted the file monitors.xml as described in first link above, but the system still comes up with the monitor showing an error message saying the signal is out-of-range.

Apparently this is not the right forum to ask this kind of question. Where can I go to get advice?
 
Old 05-22-2011, 06:05 PM   #11
MrBob22
LQ Newbie
 
Registered: May 2011
Location: Quaint Arlington, bedroom to DC
Distribution: Mainly Ubuntu 11.10, Mint & Puppy
Posts: 9

Rep: Reputation: Disabled
I was getting the out of range error upon booting 11.04 but saw a helpful post about setting the correct values for my monitor in StartUp-Manager. After setting the right Rez, no more out of range errors. Hope this may be useful....
 
Old 05-23-2011, 01:20 AM   #12
Lloyd Ewing
LQ Newbie
 
Registered: Nov 2008
Location: Austin Texas USA
Distribution: Ubuntu 10.04 LTS (Lucid)
Posts: 9

Original Poster
Rep: Reputation: 0
Bob,
Did you make a note of where the post can be found, which values to set, or what they should be set to?

When I first installed the driver from Nvida, I had to manually change the Nvidia setting every time after I booted the system before I could get a usable display. I tried installing Startup-Manager and using it to set what I thought would be reasonable display parameters. As nearly as I can remember it, that is how I got my system in the unusable state that caused me to post my question to this forum. I finally was able to fully boot the system, and the first thing I did was uninstall Startup-Manager! My experience with Startup-Manager leads me to think that it is _dangerous_ and does not have the necessary help info or user documentation. For now I am running the system without the driver from Nvidia and wondering if it is feasible to use the proprietary driver for Ubuntu.

I posted this question to UbuntForums.org and got some more responses here:
http://ubuntuforums.org/showthread.php?t=1753454
 
Old 05-23-2011, 07:08 AM   #13
MrBob22
LQ Newbie
 
Registered: May 2011
Location: Quaint Arlington, bedroom to DC
Distribution: Mainly Ubuntu 11.10, Mint & Puppy
Posts: 9

Rep: Reputation: Disabled
I did not quickly find the post, but the answer is to set the values per your monitor. Mine is max resolution of 1280x1024 so I put in that value in the boot options in display and max color depth 24 bits. it was too low by the default setting. I also set the Advanced tab boot loader menu resolution to 1280x1024. Now the system boots without the error message. It's a pretty simple fix if that is reason for the error message. I am also using the Nvidia drivers but they seem to work ok for me. Good luck.
 
Old 05-23-2011, 07:19 PM   #14
MrBob22
LQ Newbie
 
Registered: May 2011
Location: Quaint Arlington, bedroom to DC
Distribution: Mainly Ubuntu 11.10, Mint & Puppy
Posts: 9

Rep: Reputation: Disabled
out of range

Quote:
Originally Posted by MrBob22 View Post
I did not quickly find the post, but the answer is to set the values per your monitor. Mine is max resolution of 1280x1024 so I put in that value in the boot options in display and max color depth 24 bits. it was too low by the default setting. I also set the Advanced tab boot loader menu resolution to 1280x1024. Now the system boots without the error message. It's a pretty simple fix if that is reason for the error message. I am also using the Nvidia drivers but they seem to work ok for me. Good luck.
Here is the link to the post I mentioned that got me on the right track:
http://ubuntuguide.net/signal-out-of...atty-installed
Props to Ubuntu Sharing!
 
  


Reply

Tags
boot, grub, monitor, screen resolution, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Changed screen resolution and now can't see screen to change it back in Ubuntu lmb6832 Linux - Newbie 1 09-28-2010 11:52 PM
Set wrong resolution in Fedora 10 -- screen black, no automatic reset duffym Linux - Newbie 9 12-01-2009 03:46 PM
Please tell me how to reset my screen-resolution or reinstall Ubuntu via the terminal ahuman Linux - Newbie 2 03-02-2008 07:11 PM
Screen resolution gets reset back to 1600x1200 default Azalar Linux - Newbie 5 09-12-2006 06:42 PM


All times are GMT -5. The time now is 12:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration