LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Need to Reset Screen Resolution Out-of-range on Ubuntu 10.04 (http://www.linuxquestions.org/questions/linux-newbie-8/need-to-reset-screen-resolution-out-of-range-on-ubuntu-10-04-a-878082/)

Lloyd Ewing 04-30-2011 09:57 PM

Need to Reset Screen Resolution Out-of-range on Ubuntu 10.04
 
While trying to get the screen resolution I need, I have set the value to a setting that my monitor will not display. When my Ubuntu 10.04 boots, the screen just displays the out-of-range message and I cannot use it.

I think I found part of the solution on this page
https://wiki.ubuntu.com/X/Config/Resolution
which says to delete a file:
rm ~/.config/monitors.xml

Someone told me that I need to boot from grup into single-user mode, and I found out how to do that here:
http://blog.troyastle.com/2010/06/bo...untu-1004.html

My problem is that I cannot find the monitors.xml file.
The command: ls /home -a
shows only: . ..
I thought it should have a subdirectory containing .config and all of my other files. What do I need to do to access my account home directory so I can delete that file?

I am trying to use a flaky Nvidia driver so I will probably have to go through this process a few times before I get it to work. Thanks for any help,

Lloyd

corp769 04-30-2011 10:03 PM

Hello,

The ls command you provided is listing the files within the /home directory ONLY, and not the subdirectories. Before we go any further with your issue, perform the ls command under your /home/USER directory, of course replacing USER with your own username.

Cheers,

Josh

Lloyd Ewing 04-30-2011 11:36 PM

Josh,
On my system the command: ls -a
shows the subdirectories as well as the hidden files.
When I enter the command ls by itself it shows no files or directories.

corp769 04-30-2011 11:58 PM

Hold on, what exactly do you mean?

Lloyd Ewing 05-01-2011 05:55 AM

Josh,
To say it in other words, the directory /home appears to be empty.
As far as I can see at this point there are no subdirectories or files in it.
I cannot find the home directory for my user account, so I cannot change the file it contains.

If Ubuntu still places the user home directory in /home, then there must be a reason why it is not visible to me at this time. I provided the links to the pages I was working on so you could see how I got to where I am. Have you tried booting from grub as described in that link, and is your user directory available from there on your system?

Mr. Bill 05-01-2011 07:27 AM

Lloyd~

When you enter the Grub menu, select "Recovery Mode" (second entry). This will show a lot of text during system boot, then a menu will appear. Run "xfix". That will reset your faulty config. You can then continue normal boot from there.

Lloyd Ewing 05-01-2011 10:37 PM

Mr. Bill,
That doesn't seem to work. I hit the down-arrow to select recovery mode then hit enter. My version of Ubuntu doesn't show any text or any menu. The monitor shows a blank screen and then it shows the error saying that the signal is out of range.

Mr. Bill 05-02-2011 09:44 AM

Hmmm... That's peculiar. I'm also running 10.04. Just tried "Recovery Mode" to see if it had changed since 8.04, but I still got the low-res text and menu before x starts. :scratch: However, they did remove the all-powerful XFIX and replaced it with Boot into Failsafe Graphics Mode.

Guess we'll try a different approach: Have you tried accessing your /home directory from a live/rescue CD? That should allow you to edit or remove the offending config file...

Lloyd Ewing 05-03-2011 12:09 PM

Mr.Bill, Thanks for the suggestions. Booting from the live CD lets me look at the file I need to delete but it only gives me read access to my files. I would guess that the differences we see between our two systems are because the miserable Nvidia driver I am trying to use does not support some modes and features.

After having all of this time to think about the problem, I am feeling that it is likely that the problem is that grub does not mount the partition which contains my home directory. When I installed Linux the advice I got was that I should place my /home directory on a separate partition. It might be that mounting my home directory normally occurs in the initialization process after the point where I have access to grub.

The problem is figuring out how to mount this partition from the command line. I have seem the mount command used so I have a general idea of what it does, but when I have searched for information on the mount command in the past all I found was man pages. I also need to know what device is the partition that contains my home directory. I am sure that there are examples and other more friendly explanations of how to use the mount command, so I will keep looking.

Lloyd Ewing 05-04-2011 02:20 AM

Today I went through the whole process of learning how to mount the partition with my home directory. I deleted the file monitors.xml as described in first link above, but the system still comes up with the monitor showing an error message saying the signal is out-of-range.

Apparently this is not the right forum to ask this kind of question. Where can I go to get advice?

MrBob22 05-22-2011 05:05 PM

I was getting the out of range error upon booting 11.04 but saw a helpful post about setting the correct values for my monitor in StartUp-Manager. After setting the right Rez, no more out of range errors. Hope this may be useful....

Lloyd Ewing 05-23-2011 12:20 AM

Bob,
Did you make a note of where the post can be found, which values to set, or what they should be set to?

When I first installed the driver from Nvida, I had to manually change the Nvidia setting every time after I booted the system before I could get a usable display. I tried installing Startup-Manager and using it to set what I thought would be reasonable display parameters. As nearly as I can remember it, that is how I got my system in the unusable state that caused me to post my question to this forum. I finally was able to fully boot the system, and the first thing I did was uninstall Startup-Manager! My experience with Startup-Manager leads me to think that it is _dangerous_ and does not have the necessary help info or user documentation. For now I am running the system without the driver from Nvidia and wondering if it is feasible to use the proprietary driver for Ubuntu.

I posted this question to UbuntForums.org and got some more responses here:
http://ubuntuforums.org/showthread.php?t=1753454

MrBob22 05-23-2011 06:08 AM

I did not quickly find the post, but the answer is to set the values per your monitor. Mine is max resolution of 1280x1024 so I put in that value in the boot options in display and max color depth 24 bits. it was too low by the default setting. I also set the Advanced tab boot loader menu resolution to 1280x1024. Now the system boots without the error message. It's a pretty simple fix if that is reason for the error message. I am also using the Nvidia drivers but they seem to work ok for me. Good luck.

MrBob22 05-23-2011 06:19 PM

out of range
 
Quote:

Originally Posted by MrBob22 (Post 4364400)
I did not quickly find the post, but the answer is to set the values per your monitor. Mine is max resolution of 1280x1024 so I put in that value in the boot options in display and max color depth 24 bits. it was too low by the default setting. I also set the Advanced tab boot loader menu resolution to 1280x1024. Now the system boots without the error message. It's a pretty simple fix if that is reason for the error message. I am also using the Nvidia drivers but they seem to work ok for me. Good luck.

Here is the link to the post I mentioned that got me on the right track:
http://ubuntuguide.net/signal-out-of...atty-installed
Props to Ubuntu Sharing!


All times are GMT -5. The time now is 04:18 AM.