LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-19-2006, 04:26 PM   #1
paul85
Member
 
Registered: Jul 2005
Location: New Jersey
Distribution: FC 5, Ubuntu
Posts: 92

Rep: Reputation: 15
need to format hd for M$, now grub 22 prob


How can I low level format a hard drive hda so that I can install M$ on it. The drive is a WD 60G an I've lost the WD utilities?

Thanks

Last edited by paul85; 10-20-2006 at 09:29 PM.
 
Old 10-19-2006, 05:00 PM   #2
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Linux question??????

The Microsoft installer will format the drive. Just put in the CD and re-boot.

If this is going to be dual-boot, be sure not to give Windows the whole disk.
 
Old 10-19-2006, 05:34 PM   #3
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,716

Rep: Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751
No need and it is not recommended to low level format a modern hard drive.
 
Old 10-19-2006, 06:10 PM   #4
paul85
Member
 
Registered: Jul 2005
Location: New Jersey
Distribution: FC 5, Ubuntu
Posts: 92

Original Poster
Rep: Reputation: 15
problem is that the the drive is only being recognized as 2.1g out of 60. I need to see if I can recover the rest of the drive. This drive is separate from the ones i'm currently using for linux. M$ won't recognize my ntfs partition set up by qparted?

I'm currenly running only linux. You don't really expect M$ to be able to address do you???

Last edited by paul85; 10-19-2006 at 06:12 PM.
 
Old 10-19-2006, 06:22 PM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,716

Rep: Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751
Did you change the partition ID to NFTS i.e. 7
Use sfdisk or cfdisk to remove any existing partitions.
post the output of command:
fdisk -l /dev/hdx (must be root, l is a small L) where x is the location of the hard drive i.e. hdb etc
 
Old 10-19-2006, 06:57 PM   #6
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD, Raspbian
Posts: 2,160

Rep: Reputation: 334Reputation: 334Reputation: 334Reputation: 334
Quote:
Originally Posted by paul85
M$ won't recognize my ntfs partition set up by qparted?
Did you format that ntfs partition, or just set it's partition type (id=7)? I don't use qparted. Does it have the ability to format/mkfs?

Quote:
You don't really expect M$ to be able to address do you???
I would seem odd that MS would require Linux to get itself going (although practically, that sometimes appears to be the case!) As far as MS is concerned, it should just be a another disk that needs formatting/installation. I shouldn't matter to MS what was on that disk previously.

As has already been suggested, fdisk -l output might shed some light on your problem.
 
Old 10-19-2006, 07:13 PM   #7
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
shred -n 1 -z /dev/hdb should make it look like a brand new totally blank hard drive (all zeros). Of course, make ABSOLUTELY SURE that /dev/hdb is the right drive!!!
 
Old 10-19-2006, 07:48 PM   #8
paul85
Member
 
Registered: Jul 2005
Location: New Jersey
Distribution: FC 5, Ubuntu
Posts: 92

Original Poster
Rep: Reputation: 15
Quote:
Did you change the partition ID to NFTS i.e. 7
Use sfdisk or cfdisk to remove any existing partitions.
post the output of command:
fdisk -l /dev/hdx (must be root, l is a small L) where x is the location of the hard drive i.e. hdb etc

this the output of my ide drive:

fdisk -l /dev/hda

Disk /dev/hda: 60.0 GB, 60022480896 bytes
255 heads, 63 sectors/track, 7297 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 1 7297 58613121 7 HPFS/NTFS


this is the output of the ntfs partition set up by qparted:
fdisk -l /dev/sdb1

Disk /dev/sdb1: 52.4 GB, 52427902464 bytes
255 heads, 63 sectors/track, 6373 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

This doesn't look like a partition table
Probably you selected the wrong device.

Device Boot Start End Blocks Id System
/dev/sdb1p1 ? 33829 155442 976859833 74 Unknown
Partition 1 does not end on cylinder boundary.
/dev/sdb1p2 ? 120594 169080 389460666 a OS/2 Boot Manager
Partition 2 does not end on cylinder boundary.
/dev/sdb1p3 ? 33755 137276 831535540+ 0 Empty
Partition 3 does not end on cylinder boundary.
/dev/sdb1p4 ? 10498 10498 0 65 Novell Netware 386
Partition 4 does not end on cylinder boundary.

Partition table entries are not in disk order



strange I used qparted on both of these??
 
Old 10-19-2006, 07:51 PM   #9
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,716

Rep: Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751
Quote:
fdisk -l /dev/sdb1
Should be /dev/sdb not /dev/sdb1

i.e.
fdisk -l /dev/sdb
 
Old 10-19-2006, 07:52 PM   #10
paul85
Member
 
Registered: Jul 2005
Location: New Jersey
Distribution: FC 5, Ubuntu
Posts: 92

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by pljvaldez
shred -n 1 -z /dev/hdb should make it look like a brand new totally blank hard drive (all zeros). Of course, make ABSOLUTELY SURE that /dev/hdb is the right drive!!!
don't worry i'll probably use a live cd and unmount/unplug my other drives before i do this
 
Old 10-19-2006, 07:53 PM   #11
paul85
Member
 
Registered: Jul 2005
Location: New Jersey
Distribution: FC 5, Ubuntu
Posts: 92

Original Poster
Rep: Reputation: 15
michaelk

fdisk -l /dev/sdb

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 6374 51199123+ 7 HPFS/NTFS
/dev/sdb2 6375 7649 10241437+ b W95 FAT32
/dev/sdb3 7650 10226 20699752+ 83 Linux
/dev/sdb4 10261 19457 73874902+ 5 Extended
/dev/sdb5 10261 12810 20482812 83 Linux
/dev/sdb6 12811 15360 20482843+ 83 Linux
/dev/sdb7 15361 17971 20972826 83 Linux
/dev/sdb8 17972 19261 10361893+ 83 Linux
/dev/sdb9 19393 19457 522112+ 82 Linux swap / Solaris
 
Old 10-19-2006, 08:17 PM   #12
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,716

Rep: Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751
The partition information seems to be ok with either NTFS partition. The 60GB hard drive is hda1 but mentioned that you used qparted to create sdb1. Which is correct?
 
Old 10-19-2006, 08:28 PM   #13
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD, Raspbian
Posts: 2,160

Rep: Reputation: 334Reputation: 334Reputation: 334Reputation: 334
Quote:
Originally Posted by paul85
problem is that the the drive is only being recognized as 2.1g out of 60.
This would be your hda drive (that's the 60Gb IDE one).

No need to report anything on sdb ... That's a SCSI or SATA drive and you didn't report any problems with that one.

What do you mean "recognized as 2.1g out of 60"? Your fdisk output is showing all 60Gb. WHAT is only recognizing 2.1Gb? Some Windows installer or utility? Is it recognizing a partition of 2.1Gb or the entire disk as 2.1Gb? Are you getting some error message? What specifically are you trying to do with the disk when you note something's only seeing 2.1Gb (partition it? format it? install something on it?)

If Windows doesn't like the disk for some reason, and there's nothing currently on hda you need to keep, you can wipe out it's MBR like this:
Code:
# dd if=/dev/null of=/dev/hda bs=512 count=1
And then give your Window's utilities another shot at it (let Windows partition and format the drive, not Linux).

BTW, when you want to show your fdisk output, you only need do fdisk -l. If you don't add a specific drive to the command line, it will list them all. Which is fine. And you don't end up with the mistake of requesting fdisk of a partition, which makes no sense (and won't work, as you found out!)

And when you post fdisk output, to protect it's format during display, post it with code and slash-code tags surrounding it. Like illustrated below, except with NO spaces around the word "code" within the square brackets (I put the spaces there so you could see the tags displayed):

[ code ]
$ sudo fdisk -l

Disk /dev/hda: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 1 34 273073+ b W95 FAT32
/dev/hda2 35 799 6144862+ 7 HPFS/NTFS
/dev/hda3 2272 24321 177116625 f W95 Ext'd (LBA)
/dev/hda5 2272 22939 166015678+ 8e Linux LVM
/dev/hda6 22940 24214 10241406 8e Linux LVM
/dev/hda7 24215 24278 514048+ 82 Linux swap / Solaris
/dev/hda8 24279 24317 313236 83 Linux
/dev/hda9 * 24318 24321 32098+ 83 Linux
$
[ /code ]

With real code tags (no spaces), that same output looks like this (things line up properly - much easier to read):
Code:
$ sudo fdisk -l

Disk /dev/hda: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1          34      273073+   b  W95 FAT32
/dev/hda2              35         799     6144862+   7  HPFS/NTFS
/dev/hda3            2272       24321   177116625    f  W95 Ext'd (LBA)
/dev/hda5            2272       22939   166015678+  8e  Linux LVM
/dev/hda6           22940       24214    10241406   8e  Linux LVM
/dev/hda7           24215       24278      514048+  82  Linux swap / Solaris
/dev/hda8           24279       24317      313236   83  Linux
/dev/hda9   *       24318       24321       32098+  83  Linux
$
 
Old 10-19-2006, 11:48 PM   #14
paul85
Member
 
Registered: Jul 2005
Location: New Jersey
Distribution: FC 5, Ubuntu
Posts: 92

Original Poster
Rep: Reputation: 15
thanks for the tip on fdisk output. Even though sdb1 shows as ntfs windows doesn't recognize it for some reason. I've even tried switching the cables with no effect.

hda is recognized by qtparted as 60 gb, however bios only sees 2.1g , drive may have gone bad?
 
Old 10-20-2006, 07:34 AM   #15
michaelk
Moderator
 
Registered: Aug 2002
Posts: 15,716

Rep: Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751Reputation: 1751
What type of drive is sdb?
Check the motherboard BIOS settings for hda. Make sure it is set for auto.
Interesting 2.1GB used to be a BIOS limitation. How old is this computer?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
format a hard drive (/dev/hda1) in Reiser fs format Linh Linux - General 7 06-17-2009 06:30 AM
Converting wma format to mp3 format. fakie_flip Linux - General 6 10-02-2005 07:49 PM
replace empty function from the old format to the new format powah Programming 4 07-12-2005 08:07 PM
use vi to convert linux format to windows format intolinux Linux - Software 2 12-10-2003 10:20 PM
Format Problems Saving Star Office Docs in Word Format kkempter Linux - Software 4 08-27-2003 04:23 PM


All times are GMT -5. The time now is 06:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration