LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-06-2004, 09:44 AM   #1
gardenair
Member
 
Registered: Oct 2004
Location: LH
Posts: 610

Rep: Reputation: 31
Lightbulb Need Mandrake Help


I have installed Mandrake Linux9 by Expert mode.Though i did all steps successfully. When i restart my linux system after installation it load it and the prompt automatically goes to text menu. I login it as my user name and then write "KDE" after $ which moved to GUI Mode.
Durning installation linux gives me an option "Bootloader main Options" and i choos
"Lilo with Graphical menu" . The problem which i want to ask is why linux does't automatically moves to GUI (X Windows) directly ?

(ii) When i want to shutdown my system i press K in GUI mode the system logout but does't
shutdown. In text mode I write logout and it succesfuly logout.Plz let me guide that how can i shut down my system via Graphical interface and what is the reson that it does't show me the Interface option button to shutdown.

(iii) what is the command in text base to shutdown or reboot my system.

(iv) What is the difference between Ext3 and Journalised Fs ?

Any recommandation would be greately appreciated .
 
Old 12-06-2004, 09:58 AM   #2
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Rep: Reputation: 30
Well....

to reboot from command line:

reboot

to shutdown:

shutdown now

Okay, now for the shutdown from GUI...

Look in /etc/sysconfig/desktop

There should be a line that starts with:

DISPLAYMANAGER=

if that's already there, make it say

DISPLAYMANAGER="GDM"

and that should give you a different dialog box when you choose K menu -> logout. If it wasn't already there, put it there. Save file.

I can't remember how to make it start X automatically, unless i'ts the inittab entry that's doing it. To check, edit /etc/inittab (as root) and look for this line:

id:3:initdefault:

it may say id:5:initdefault. If it looks like the first example, change the 3 to a 5 so that it looks like the second example. Save and reboot.

If it already said 5, then I don't know what else controls whether or not it boots into GUI automatically. Sorry.

Not sure on the differences between file systems. Sorry.

Hope some of this helps...
 
Old 12-06-2004, 10:16 AM   #3
gardenair
Member
 
Registered: Oct 2004
Location: LH
Posts: 610

Original Poster
Rep: Reputation: 31
Thnaks for your reply .I shall try it . There is another question that durning manual installation there is a option about

(I) CD-Rom labeled "Installation CD2 (x86)"
(ii) CD-Rom labeled "International CD (x86)"

These two have a option buttons and the user have to choouse any one . I choouse the 2nd one but iam unabale to understand it .
 
Old 12-06-2004, 10:23 AM   #4
gardenair
Member
 
Registered: Oct 2004
Location: LH
Posts: 610

Original Poster
Rep: Reputation: 31
one more thing that durning manual installation there is a option in Dial up Networking

Authentication 1-PAP
2-Terminal Based
3-Script Based
4-CHAP
for a home user (for downloading or surffing net ) which option should i choouse .Further will mandrake will ask for my Modem port or it will automatically deduct it .
 
Old 12-06-2004, 10:23 AM   #5
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Rep: Reputation: 30
hmmm, I've never seen that before. I guess I would have chosen the first one, as it is "non-international" and I'm not a very worldy guy ;-)

DOn't know if that matters much either though, so I guess if you chose the second one then it's no biggie...

Let us know if the previous reply did any good...

<edit>
just saw the other post. I have no idea what all that is about. No idea which one to choose either. Why are you getting all these options? Can you do a more automated install?

Cant help there...sorry...

Last edited by jeffreybluml; 12-06-2004 at 10:25 AM.
 
Old 12-06-2004, 10:28 AM   #6
gardenair
Member
 
Registered: Oct 2004
Location: LH
Posts: 610

Original Poster
Rep: Reputation: 31
ok ...i shall do work on it . Actually iam new in Mandrake Linux .
I does't know where i can find

/etc/sysconfig/desktop

is it a text file where i will do changes 3 to 5 in it ?
Plz let me know about it..It is now confusing me .
 
Old 12-06-2004, 10:39 AM   #7
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Rep: Reputation: 30
the /etc/sysconfig/desktop is a file, and in it we will name the display manager to use for logging out. Type the following as root:

nedit /etc/sysconfig/desktop &

or, if that gives you "command not found" try

gedit /etc/sysconfig/desktop &

Once you get it open, make a line that looks like this (copy/paste from here into the file)

DISPLAYMANAGER="GDM"

If there is another line that startw with DISPLAYMANAGER, delete it. Now save the file. Good. Done there. Now, for the system to boot into GUI, type the following as root:

nedit /etc/inittab &

and again, if nedit doesn't work try gedit.

Now look for the line that starts with

id:

and then has a number...3 or 5

Make that number says 5, so the line will look like this:

id:5:initdefault:

now save that file. Reboot and you should be good to go...
 
Old 12-06-2004, 10:45 AM   #8
gardenair
Member
 
Registered: Oct 2004
Location: LH
Posts: 610

Original Poster
Rep: Reputation: 31
Iam extremely thankful for your kind guidence. I shall do work on it later. I hope that i will do it successfully .
 
Old 12-07-2004, 10:14 AM   #9
gardenair
Member
 
Registered: Oct 2004
Location: LH
Posts: 610

Original Poster
Rep: Reputation: 31
To change my run level i enter as
[root@localhost Toney]#edit/etc/inittab
bash:edit Command not found

plz let me know how can i edit it. I can see the file in
File:/etc/inittab
But can't edit here.
Thnaks
 
Old 12-07-2004, 10:52 AM   #10
jeffreybluml
Member
 
Registered: Mar 2004
Location: Minnesota
Distribution: Fedora Core 1, Mandrake 10
Posts: 405

Rep: Reputation: 30
Sorry, I have the command "edit" aliased to "nedit"

Try:

nedit /etc/inittab &

and if that doesn't work,

gedit /etc/inittab &

Note: the & at the end of the command just makes it so the terminal you're typing in isn't locked while the editor is open.

One of those two command should work. If not, let me know and I'll walk you through using the vi editor.

Good luck,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake 9.2b2: Unable to find / launch Mandrake Control Center blafield Mandriva 2 06-12-2009 03:38 AM
dual booting fedora core 2 and mandrake: can't boot mandrake any more mgyamada Fedora 1 10-04-2004 07:39 AM
Completely new to Linux, Downloaded Mandrake 10 and want to run both XP and Mandrake Scandal Mandriva 4 06-28-2004 10:03 PM
Upgrading Mandrake 9.1RC2 to Mandrake 9.2 final Without ISOs johnleemk Mandriva 1 12-27-2003 12:17 AM
Uninstalled Mandrake, Installed Slackware, still getting mandrake boot screen powerismine Slackware 4 11-22-2002 06:51 AM


All times are GMT -5. The time now is 10:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration