LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-13-2009, 12:21 PM   #1
ash_zz_00
Member
 
Registered: Aug 2009
Distribution: Slackware 13.0
Posts: 66

Rep: Reputation: 17
Need help with setting up wireless on HP notebook using Slackware


Hi,

I'm running Slackware 12.2 on HP dv6t notebook. I have configured my wired network to DHCP which was pretty straight forward. Now I'm trying to setup my wireless and not sure and not sure if I'm doing this right.

My understanding after reading some information here on LQ and Slackbook, is that modifying just rc.inet1.conf should suffice (rc.wireless.conf is deprecated). So I modified it and ran rc.inet1.

Code:
# /etc/rc.d/rc.inet1 wlan0_start

# iwconfig  
lo     no wireless extensions 
eth0   no wireless extensions
I'm not even sure if I have the right drivers.

rc.inet1.conf
Code:
# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

## Example config information for wlan0.  Uncomment the lines you need and fill
## in your info.  (You may not need all of these for your wireless network)
IFNAME[4]="wlan0"
IPADDR[4]=""
NETMASK[4]=""
USE_DHCP[4]="yes"
DHCP_HOSTNAME[4]="wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
WLAN_ESSID[4]=ash
WLAN_MODE[4]=Managed
##WLAN_RATE[4]="54M auto"
##WLAN_CHANNEL[4]="auto"
WLAN_KEY[4]="s:6029629891"
##WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"
lspci
Code:
02:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
lsmod
Code:
Module                  Size  Used by
fuse                   54684  2 
snd_seq_dummy           6788  0 
snd_seq_oss            33408  0 
snd_seq_midi_event     10240  1 snd_seq_oss
snd_seq                50928  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         10380  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            40480  0 
snd_mixer_oss          17920  1 snd_pcm_oss
ppdev                  11268  0 
lp                     13572  0 
parport_pc             28196  0 
parport                34796  3 ppdev,lp,parport_pc
snd_hda_intel         367756  0 
intel_agp              29116  1 
agpgart                32584  1 intel_agp
snd_pcm                70788  2 snd_pcm_oss,snd_hda_intel
sg                     30516  0 
snd_timer              23176  2 snd_seq,snd_pcm
i2c_i801               12688  0 
snd_page_alloc         11400  2 snd_hda_intel,snd_pcm
thermal                19484  0 
processor              36648  1 thermal
video                  20624  0 
thermal_sys            15144  3 thermal,processor,video
evdev                  13088  0 
snd_hwdep              10756  1 snd_hda_intel
uvcvideo               57096  0 
r8169                  31236  0 
psmouse                40592  0 
mii                     8448  1 r8169
snd                    51748  9 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_intel,snd_pcm,snd_timer,snd_hwdep
soundcore              10080  1 snd
compat_ioctl32          5120  1 uvcvideo
serio_raw               9220  0 
output                  6656  1 video
battery                14340  0 
wmi                     9768  0 
button                 10128  0 
videodev               36736  1 uvcvideo
v4l1_compat            17924  2 uvcvideo,videodev
ac                      8196  0 
hwmon                   6300  1 thermal_sys
Any help is much appreciated.

Thanks in advance,

Ash.
 
Old 12-13-2009, 12:25 PM   #2
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hello Ash,

Have a look at the Slackbuilds.org site, they have what you need to get up and running:
http://slackbuilds.org/result/?search=BCM43&sv=12.2

That particular NIC causes headaches in more than one distro

Kind regards,

Eric
 
Old 12-13-2009, 09:12 PM   #3
ash_zz_00
Member
 
Registered: Aug 2009
Distribution: Slackware 13.0
Posts: 66

Original Poster
Rep: Reputation: 17
Thanks for the information. I appreciate it. It appears that my wireless card is not supported (or rather in progress) at this time.

Regards,

Ash.
 
Old 12-13-2009, 09:21 PM   #4
trist007
Senior Member
 
Registered: May 2008
Distribution: Slackware
Posts: 1,027

Rep: Reputation: 69
You could look into a ndiswrapper driver.
 
Old 12-14-2009, 07:02 AM   #5
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285Reputation: 1285
Actually, there is a broadcom driver for it, it's just that I've heard not so good things about it:
http://linuxwireless.org/en/users/Drivers/b43
http://wiki.archlinux.org/index.php/Broadcom_BCM4312
 
Old 12-23-2009, 03:43 AM   #6
ash_zz_00
Member
 
Registered: Aug 2009
Distribution: Slackware 13.0
Posts: 66

Original Poster
Rep: Reputation: 17
I got the 802.11 Linux STA driver from Broadcom, built it and did the following.

Code:
# cp /tmp/wl/wl.ko /lib/modules/2.6.27.7-smp/kernel/net/wireless
# depmod -a
# modprobe wl

# iwconfig
eth1      IEEE 802.11bg  ESSID:""  Nickname:""
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Bit Rate:54 Mb/s   Tx-Power:32 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Power Managementmode:All packets received
          Link Quality=5/5  Signal level=0 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

# iwlist eth1 scan 
eth1      Scan completed :
          Cell 01 - Address: 00:1E:40:D7:D6:EC
                    ESSID:"ash"
                    Mode:Managed
                    Frequency:2.462 GHz (Channel 11)
                    Quality:5/5  Signal level:-30 dBm  Noise level:-90 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
So it appears that my wireless is being recognized but it's not connecting.

If you look at my first post with the rc.inet1.conf, I tried to define wlan0 for my wireless. How did it pick up eth1? What do I have to do next to connect to the wireless?

Thanks,

Ash.
 
Old 12-23-2009, 05:21 AM   #7
gregorian
Member
 
Registered: Apr 2006
Posts: 509

Rep: Reputation: 34
Try

iwconfig wlan0 ash
iwconfig wlan0 key KEY_HERE
dhcpcd wlan0
 
Old 12-23-2009, 08:57 AM   #8
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,541
Blog Entries: 23

Rep: Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943
Hi,

My Dell is now using Slackware 13 X86_64, 2.6.30.5 and experimenting with 2.6.32-rc7.

I've spent a lot of time trying the Broadcom propriety drivers. Sometimes the recognition is eth1 for the wireless device. Tried the B43 SlackBuilds too no avail on the Dell Inspiron Laptop with this chipset. It seems to be cursed. I built the firmware for the 2.6.29.6 kernel using the BroadCom driver & patch. It worked but I did need to move to a newer kernel for other reasons, video and I/O. Of course the thing broke and I couldn't get the wireless to work with newer kernels. Frustrated!

I then grabbed the firmware to see if that would work for me. It did for a while but then became unstable. I was about to turn to 'ndiswrapper' but would do anything to not do this since it has caused other problems in the past. I found a Ubuntu firmware for the b43/b43legacy drivers and thought 'what the hell', tried it and it's still working. Why the Slackbuilds or the other drivers wouldn't function is on a 'to-do' list but real low priority for now.

Give it a try.

I'm going to be re-working the Laptops configurations after the new year. It's working for now but the hdd needs are demanding a upgrade to a '72k' at least. Or a newer SSD? So I'm sure that things will be in the works again.

 
Old 12-27-2009, 10:55 AM   #9
ash_zz_00
Member
 
Registered: Aug 2009
Distribution: Slackware 13.0
Posts: 66

Original Poster
Rep: Reputation: 17
Guess I'm confused. Please bear with me if my questions sound silly.

I built the Broadcom drivers and loaded it. iwconfig and iwlist seems to indicate that the wireless card is functional. It's even showing the correct ESSID etc. Is it just picking up this information from one of my conf files? If it's still not connecting, does it mean that the device is actually not working even though iwconfig shows some legitimate looking output?

Based on Onebuck's suggestion, I wanted to try the b43/b43legacy drivers. Where do I get the b43 drivers? Now that I have loaded the Broadcom driver, could someone tell me how to unload that and load the b43 drivers instead?

Thanks,

Ash.
 
Old 12-27-2009, 07:00 PM   #10
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,541
Blog Entries: 23

Rep: Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943
Hi,

'Configuring your network in Slackware'.


The above links and others can be found at 'Slackware-Links'. More than just SlackwareŽ links!
 
Old 12-31-2009, 08:08 AM   #11
ash_zz_00
Member
 
Registered: Aug 2009
Distribution: Slackware 13.0
Posts: 66

Original Poster
Rep: Reputation: 17
The wireless is just not associating with access point.
iwlist eth1 scan finds the access point correctly.
So I tried to to set the essid explicitly with iwconfig eth1 essid "ash". But a subsequent iwconfig still shows the essid as empty.

Any suggestions.

Thanks,

Ash.
 
Old 12-31-2009, 08:18 AM   #12
emrysm
LQ Newbie
 
Registered: Jun 2009
Posts: 9

Rep: Reputation: 1
Ash,
Out of curiosity, are you using any encryption on your wireless network? WEP isn't so hard to connect to, but WPA can be a real beast in linux.

Also, have you tried taking down/back up your wireless network device. It's been a while, but I think:

# ifconfig wlan0 down
# ifconfig wlan0 up

Will do it. I had a similar problem a long time ago and I just had to do the above to get the last bit working.

-Emrys
 
Old 12-31-2009, 08:55 AM   #13
ash_zz_00
Member
 
Registered: Aug 2009
Distribution: Slackware 13.0
Posts: 66

Original Poster
Rep: Reputation: 17
I just tried bringing the wireless down and up but it didn't make a difference.

Yes, my wireless is encrypted. When I see the properties in windows, it shows that it's WEP. Is there any other way to tell? Also is there a way to turn off the encryption so that I can at least see if it associates?

Thanks,

Ash.
 
Old 12-31-2009, 08:57 AM   #14
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,541
Blog Entries: 23

Rep: Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943Reputation: 1943
Hi,

Quote:
Originally Posted by ash_zz_00 View Post
The wireless is just not associating with access point.
iwlist eth1 scan finds the access point correctly.
So I tried to to set the essid explicitly with iwconfig eth1 essid "ash". But a subsequent iwconfig still shows the essid as empty.

Any suggestions.

Thanks,

Ash.
What about the ubuntu driver at the link I provided? You did try it?

'Slackware 13.0 RC2 X86_64 Broadcom bcm4312 problems' & '[SOLVED] Configure wireless driver for Dell Wireless 1397(bcm 4312)' are threads that may help.

 
Old 01-01-2010, 12:56 AM   #15
emrysm
LQ Newbie
 
Registered: Jun 2009
Posts: 9

Rep: Reputation: 1
Turning off the WEP encryption on your wireless network should be easy. Have you ever logged in to your router? In windows, you can go to a command prompt (windows key + r, then CMD, enter) and put in: > ipconfig /all

This should bring up your computer's ip address and gateway. The 'default gateway' will be your router's address. Put that into your router as 'http://192.168.x.x' and you should be able to administer your router from that. This will work with about 90% of routers out there. Anyways, once you're in the router's software, you just need to disable the WEP. Also, while you're in there, you can see if it recognizes your wireless card as having connected before. This is a little more complex and I don't have time to go into it right now, but just suffice it to say that ifconfig can give you the MAC address of your wireless card in linux, and the router _should_ record those somewhere.

It would be good to know if it had _ever_ connected, or at least been recognized by the router as existing.

-Rigor
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
HP G60-237NR Notebook will not see wireless NIC with Slackware 12.2 picketfence Linux - Laptop and Netbook 3 03-23-2009 03:35 PM
HP Notebook, VISTA, wireless DSL. UBUNTU "Unable to resolve host notebook" uncledunc Linux - Laptop and Netbook 7 02-03-2009 01:19 PM
Setting up Broadcom wireless networking under Slackware 11 pappy_mcfae LinuxAnswers Discussion 5 01-14-2009 09:33 PM
setting up wireless network with Slackware languru Linux - Wireless Networking 3 01-09-2005 08:24 PM
Difficulty setting up BT Voyager 2000 Wireless on Slackware 10.0 Apocalypse King Linux - Hardware 0 09-21-2004 01:57 PM


All times are GMT -5. The time now is 12:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration