LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-16-2003, 03:15 PM   #31
disorderly
Member
 
Registered: Sep 2003
Location: NJ
Distribution: RHEL5
Posts: 154

Original Poster
Rep: Reputation: 30

I F#@$!#@$KING SOLVED IT!!#@$!@#$!!#$!

SOMEBODY PLEASE STICKY A SAMBA GUIDE WITH THIS RIGHT IN THE BEGINNING ====> check to make sure that your ethernet card is listed as a TRUSTED DEVICE!!!

like all security paranoid people i had it set on medium to start with... omg if i could kick myself in the nutz i'd do it.


- thanks to all that read this post and i hope this helps those where there seems to be nothing wrong with their smb.conf file...

-disorderly
<off to get reallllly drunk>
 
Old 10-16-2003, 04:00 PM   #32
CraigTFogg
LQ Newbie
 
Registered: Jan 2002
Posts: 3

Rep: Reputation: 0
Thanks but what is the solution? What is a "Trusted Device"? How do you set your ethernet card this way? Please don't leave us hanging.
 
Old 10-16-2003, 04:13 PM   #33
dabicho
LQ Newbie
 
Registered: Aug 2003
Posts: 25

Rep: Reputation: 15
I think he means that he had a firewall on his linux box that was blocking samba connections.
 
Old 10-16-2003, 04:22 PM   #34
disorderly
Member
 
Registered: Sep 2003
Location: NJ
Distribution: RHEL5
Posts: 154

Original Poster
Rep: Reputation: 30
o sry heh if you've already installed linux (i'm using redhat 9here):
system settings ->
security level ->
customize -> check eth0 (or the ethernet card you want) as a trusted device

you can also do this as you are installing linux wnen you come to the security screen/firewall screen i forget what it's called

happy happy, joy joy

- drunk & disorderly
 
Old 10-16-2003, 04:56 PM   #35
Tyir
Member
 
Registered: Sep 2003
Distribution: Slackware 9.1 with fluxbox
Posts: 259

Rep: Reputation: 30
Disorderly!!!!!!!!!

I love you!!!!!!!!!!!!!!!!!!


!!!!!!!!!!
REALLY!!!!!!!!!
this has been plaguing me for days as well!

Now i can stop using Windows, since i host a shared music fodler for my house!!!!!!
My sister won't get mad at me anymore!!!!!!!!!!!!!!!!!!!!

Thank you Thank you!!!!!!!

happy happy joy joy

you would THINK that in ONE of these instruction manuals they would mention this...

Although perhaps this is a redhat9 specific "problem"....

Thank you!
 
Old 10-16-2003, 05:17 PM   #36
jdruin
Member
 
Registered: Jul 2003
Location: Louisville aka Derby City
Distribution: WinXP SP2 and SP3, W2K Server, Ubuntu
Posts: 313

Rep: Reputation: 30
Is the firewall on the Linux Box allowing smb through(ports 137 138 139)? I know you said you pinged from your Win box but even when set on HIGH, iptables allows ping through, but not smb.
 
Old 10-16-2003, 07:14 PM   #37
Tyir
Member
 
Registered: Sep 2003
Distribution: Slackware 9.1 with fluxbox
Posts: 259

Rep: Reputation: 30
Ok it stopped working.......

When i made eth0 trusted, i went ont he windows box and I saw the computer in 'computers near me'. But i didnt od anything, i stopped happy.

But now I dont see it any more...not sure if I had chanegd anything or what..but I really don't think I did.......
 
Old 11-10-2003, 09:52 AM   #38
Dogface1SG
Member
 
Registered: Oct 2003
Posts: 30

Rep: Reputation: 15
Been there, done that

I fought the same or similar situation for a while now. I am using Mandrake 9.1 with samba, security high.

I found my internet connection sharing was working and my Domain network was not. I watched my startup of Linux and seen 2 things that could be preventing it. iptables and Shorewall were both being started at boot. These are both dealing with firewall. I read, and read, and read all the links to both but couldn't come up with a quick answer on how to fix my problems. Finally 2 things worked.

I researched shorewall and used their tutorial shorewall tutorial and configured it using my Mandrake installed shorewall (had to change some references dealing with loc verses masq due to Mandrake as it states in the tutorial) Restarted eveything and still had the same problem. If i stopped iptables, my network worked but my ICS didn't. With iptables running ICS worked, network didn't. I knew my problem was there. Did more research

netfilter-iptables read everthing there. I am a newbie and didn't know how to do half the stuff they talked about.

Did some more searching on these forums and found a link to arno's firewall downloaded, copied and followed the instructions in the readme file and voila, it all works well now.

None of my research was in vain. I learned alot (almost too much to absorb) as time permits I will be tweeking the settings to better suit my situation.

BTW I did try fwbuilder as several post had mentioned. The only problem with a GUI is you don't know what it did or how, ie you didn't learn. I was still having some problems using it, that is when I found the link to arno's

Sorry for being so long winded. Hope this helps or solves your problems.

Thank you to everyone who posts on these forums as they have been a God send to figuring things out. Speacial thanks to those that posted the links I posted here. Sorry I don't remember your names, and I have researched enough this weekend.
 
Old 02-04-2004, 11:04 AM   #39
tux_studio
LQ Newbie
 
Registered: Feb 2004
Distribution: Many
Posts: 3

Rep: Reputation: 0
Smile

I'm a little late getting in on this one.

I found that my firewall (linux RedHat firewall) was blocking the samba traffic.

I'm not very good with firewalls so I just disabled the firewall and everything went to work.
 
Old 02-05-2004, 07:42 AM   #40
jdruin
Member
 
Registered: Jul 2003
Location: Louisville aka Derby City
Distribution: WinXP SP2 and SP3, W2K Server, Ubuntu
Posts: 313

Rep: Reputation: 30
Yeah. The firewall often causes angst. It is fairly easy to poke smb holes in the firewall without turning it off.

Log in as root or su root

Run LOKKIT at the command prompt

If you cant find LOKKIT then do a : "find / -name lokkit" then
type in the full path to run LOKKIT.

In the "OTHER PORTS" area at the bottom, type in the ports you want to
allow beyond the ones with radio buttons (IE-www,ssh,etc)

Type them like this: tcp:137 udp:138 udp:139

NOTE: I cant remember if 137 is supposed to be tcp or udp and the same for 138 and 139 but you could look this up on the samba home page easily. I think those are correct though.

Click OK when done to save. If you mess up , just start over
 
Old 02-05-2004, 08:02 AM   #41
jazernorth
Member
 
Registered: Jan 2004
Location: Green Bay
Distribution: RedHat 8.0, LFS-5.0
Posts: 100

Rep: Reputation: 15
When setting up Samba, there are many things to keep in mind:

First, is your Linux Server the Main Windows Server? If not, you need to you need to set 'local master = no'.

Second, do you require Encrypted Passwords. MOST NT/2000/XP systems are set to use Encrypted Passwords, therefore you will need to set 'encrypt passwords=yes' and verify 'smb password file'. Then use 'smbpasswd' to add users and passwords to the file.

Third, make sure your firewall allows smb connections. Even if you have 2 networks (internal and external), most firewall systems are set up to block internal as well as external. You can set your firewall to accept all traffic from the internal network, while restricting external traffic (see rc.firewall).

Fourth, make sure the user name assigned in smbpasswd matches the COMPUTER name (win95/win98) or username (NT/2000/XP) on your windows machines. If you are trying to use AudioTron, you will need to contact www.turtlebeach.com for help.

Those are the most common hiccups when setting up Samba. Remember, a good programmer (or analyst) only changes one setting at a time. If you change more than one at a time between tests, you will not find the solution. Many settings conflict or require other settings, so it is best to change only one at a time. It takes patience, but will give you results much faster than making many changes at once.

Enjoy the power of Linux.

JN
 
Old 02-05-2004, 12:35 PM   #42
Godsmackfelipe
LQ Newbie
 
Registered: Feb 2004
Location: Brazil
Distribution: Mandrake 8.1
Posts: 17

Rep: Reputation: 0
Brilliant...
Thanks a lot...
Those informations helped me a lot...
Thank you very much...
 
Old 02-21-2004, 09:25 PM   #43
buttmunch
LQ Newbie
 
Registered: Feb 2004
Posts: 9

Rep: Reputation: 0
If trying to connect FROM a PC to Linux, have you disabled the firewall on the linux box?

Also, turn on the SWAT service, then enter your hostname followed by :901 in your browser for a gui SAMBA setup screen which may be helpful in configuration.

Sorry I can't be detailed in my response. I'm still a newbie myself.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba/Cups print sharing problems (/var/spool/samba files) Gates1026 Linux - General 9 06-23-2013 01:33 AM
Samba - Connecting from WinXP Pro to Samba running on Debian critical Linux - Networking 1 02-03-2005 09:36 AM
I need the content from thegoldenear.org/toolbox/unices/samba/samba-setup.html rtg2001 Linux - Networking 1 08-05-2004 05:54 PM
Samba: Authenticate Linux-Clients in Samba Domain & Mount mule Linux - Software 0 12-10-2003 01:21 AM
when i restart SAMBA,it says:stop samba failed,start SAMBA OK! whepin Linux - Networking 3 12-26-2001 05:54 AM


All times are GMT -5. The time now is 01:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration