LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-20-2005, 10:37 AM   #1
zcchen
LQ Newbie
 
Registered: Feb 2005
Posts: 3

Rep: Reputation: 0
Need help with mounting windows partitions in Fedora 3


I have a daul boot system. I installed WindowsXP and Fedora 3 in two difference hard drives. While my WindowsXP is on C:, the first partition of the first primary master, my Fedora is on the secondary master. I install the grub boot loader in the Windows partition, C:\. Since I want to share files between linux and windows, I formatted some of my windows as fat32. Just to be clear, under Linux, my windows hard drive is "hde", and the linux hard drive is "hdf". According to what I learned from the net, I should be able mount the windows fat32 partitions in linux. In fact, I use the command line
mount -v -t vfat /dev/hde5 /home/disk
to mount a fat32 partition when logging in as root(note: hde5 is a fat32 partition). I was able the get an answer that I was able to mount it, since I used the -v parameter. However, I got frozen when I used ls command in the /home/disk directory. When I want to umount the /home/disk, the result I got back is the device is too busy. I was't able to access anything from my fat32 partitions. Does anyone know how to solve this problem?
 
Old 02-20-2005, 10:57 AM   #2
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
If you want to run Windows commands under Linux, you need to install (and configure) something like Wine.

The error message you got is actually quite specific: Whatever you'd tried to do had causes the drive to attempt to access something, and it was waiting for a response from the drive.

What had you tried?
 
Old 02-20-2005, 11:17 AM   #3
brainiac
Member
 
Registered: Jan 2005
Location: middle of a cornfield, IL
Distribution: Kanotix HD Install, Debian Testing, XP Pro,Vista RC1
Posts: 145

Rep: Reputation: 15
Try creating a directory under the / tree. I would mount mine using your example
mount /dev/hde /windows
Using this method I have no problems with full access to my drives. I also get system freeezes trying to call out any extra parameters. Hope this might help.
 
Old 02-20-2005, 12:59 PM   #4
kenji
Member
 
Registered: Sep 2004
Location: Philippines
Distribution: Slackware
Posts: 143

Rep: Reputation: 16
have you tried this editing your /etc/fstab
just insert this hope this will help! 3


/dev/hda1 /mnt/windows vfat auto,umask=0 0 0
 
Old 02-20-2005, 03:35 PM   #5
frostillicus
Member
 
Registered: Jul 2004
Location: Florida
Distribution: Slackware
Posts: 32

Rep: Reputation: 15
sounds like you were in the directory you were trying to unmount, thus it was considered busy. likewise, if you mount the windohs partition

mount -t vfat /dev/hde5 /home/disk

and then open a webpage from /home/disk you will not be able to unmount /dev/hde5 until you close the webpage, otherwise it will give the "device busy" error.

while usefull in debugging, the -v option in mount has no effect, really, it simply means to be verbose in its output.

you don't need wine for this unless you actually want to run windohs applications on linux, only then you would need the Wine Is Not an Emulator package. but it sounds like you just want access to your vfat partitions.

a shortcut command like this:

mount /dev/hde5 /windows

will only work if you have a matching line in the /etc/fstab file. this is the line from the /etc/fstab file

/dev/fd0 /mnt/floppy auto noauto,owner 0 0

that lets you do a shorcut command to mount the floppy:
mount /mnt/floppy
instead of having to do it the long way:
mount -t auto /dev/fd0 /mnt/floppy

it looks like you used the right command to mount it. naturally I am assuming you are doing this all as the root user, if not then you will need to adjust your directory/file permissions accordingly. sounds like either the /dev/hde5 is empty (doubt it) or you have a permission issue (more likely).
 
Old 02-20-2005, 07:54 PM   #6
zcchen
LQ Newbie
 
Registered: Feb 2005
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks all you guys for reply. I basically Itried all of you suggestions. At the end, I tried to put a line " /dev/hde5 /windows/diskD vfat rw,noauto,user,exec,umask=0 0 0" in the fstab file, since I use the noauto parameter, it shouldn't mount the hde5 at boot time. However, as soon as I boot and log-in as root, I use the Disk Management tool to monitor the partitions mounted, the hde5 is already mounted??? And, I could 't unmount it via either terminal or the Disk Management tool. What is even strange is that when I use open the /windows/diskD folder, not only is the window constantly reading the hard drive, all the icons on the disktop is gone, couldn't find them anywhere. The worse thing yet is when tried I log-out and restart the computer, the screen just frozen, I have to reboot it manually.

Last edited by zcchen; 02-20-2005 at 07:59 PM.
 
Old 02-21-2005, 03:04 AM   #7
frostillicus
Member
 
Registered: Jul 2004
Location: Florida
Distribution: Slackware
Posts: 32

Rep: Reputation: 15
missing desktop icons? I dunno, sounds like there are issues larger than just mounting a windohs partition. but not to worry.

the first thing you probably don't need is the umask=0,0,0 option in the line in your /etc/fstab file. this sets the read/write/execute permissions for the device, but you are already doing so with the rw option, which you shouldn't need anyway. try this line instead:

/dev/hde5 /windows/diskD vfat noauto,owner 0 0

after rebooting, log in as root -) and use this command:

mount /windows/diskD

if this works then you can hack the line in /etc/fstab further so that you don't have to be root to mount it. if it doesn't work then we'll try something else. naturally, this is all assuming that the commands:

mount -t vfat /dev/hde5 /windows/diskD
and
umount /windows/diskD

worked for you, and you were able to view/open files in /windows/diskD and it was only then that you put the line in the /etc/fstab file. otherwise, putting unknown/untested mount commands in the fstab file is a dicey affair...

since this is a newbie thread I'll say for the record that logging in as root is a BAD idea. when you see 'log in as root and do this...' it usually implies that you are already logged in as a non-root user and will temporarily assume rootly permissions and duties (via the su commmand) and then relenquish them when the duties are done.
 
Old 02-21-2005, 05:39 PM   #8
zcchen
LQ Newbie
 
Registered: Feb 2005
Posts: 3

Original Poster
Rep: Reputation: 0
The problem is that both mount and umount vommsnf don't for me. At the begining, I didn't put put any mount command in fstab, instead, I used the mount command under terminal, just like you suggested. However, I cant access the mounted partition in terminal, it just frozen. If I tried to access the mounted partition via window, as soon as I click the diskD folder, the icons on the disktop are gone, and I have to reboot the computer manually. Befroe I reboot the computer, if I tried to umount the partition, it just tells me the device is busy.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting Fedora partitions from Debian puppet Debian 4 10-17-2005 03:03 PM
Problems Mounting Windows Partitions sidharth0384 Linux - Newbie 2 04-22-2005 03:22 PM
automatic mounting of windows partitions vijeesh_ep Linux - Networking 1 07-31-2004 02:05 PM
mounting windows partitions shahzadiub Programming 1 04-22-2004 05:49 AM
Mounting windows partitions PhuckFonix Linux - Newbie 13 03-28-2004 12:15 PM


All times are GMT -5. The time now is 05:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration