LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-01-2006, 08:15 PM   #1
manolakis
Member
 
Registered: Nov 2006
Distribution: xubuntu
Posts: 419

Rep: Reputation: 31
Need help with Java


Hey there!!!
I am using BackTrack (Slackware) and i have a problem with Java
I have installed jdk1.5.0.09 but i can not run applets in Mozilla
When i try to run an applet i get an error "Missing Plugins"
Any ideas?

Thanks for your time

PS:I have enabled the Java option in the browser
 
Old 12-01-2006, 10:03 PM   #2
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
whats the output of "echo $JAVA_HOME"? and 'which java'?
also, the jdk is the java development kit. you want the jre, java runtime environment. visit java.sun.com to download the JRE update 10 i think is the latest.

Last edited by nadroj; 12-01-2006 at 10:04 PM.
 
Old 12-02-2006, 12:08 AM   #3
manolakis
Member
 
Registered: Nov 2006
Distribution: xubuntu
Posts: 419

Original Poster
Rep: Reputation: 31
/usr/lib/java
 
Old 12-02-2006, 12:09 AM   #4
manolakis
Member
 
Registered: Nov 2006
Distribution: xubuntu
Posts: 419

Original Poster
Rep: Reputation: 31
Sorry i forgot
'which java' outputs: '/usr/lib/java/bin/java'
 
Old 12-02-2006, 12:32 AM   #5
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
did you follow the instructions on the java site to set it up with the browser?
 
Old 12-02-2006, 02:12 PM   #6
manolakis
Member
 
Registered: Nov 2006
Distribution: xubuntu
Posts: 419

Original Poster
Rep: Reputation: 31
if you mean if i followed the instructions for the JDK installation yes i did.
The only thing that could cause a problem that i can imagine is that i installed the JDK in the Desktop
Is this true?
I downloaded and installed the JRE 10update as you said.
I installed in the Desktop dir as well
To be honest nothing changed
Any ideas?

Thanks really much for your time
I am really obliged
 
Old 12-02-2006, 02:54 PM   #7
xlinuks
Member
 
Registered: Jan 2006
Location: White House
Distribution: Ubuntu 8.10
Posts: 39

Rep: Reputation: 15
This should help:
http://www.java.com/en/download/help/5000010500.xml#14
 
Old 12-02-2006, 09:51 PM   #8
manolakis
Member
 
Registered: Nov 2006
Distribution: xubuntu
Posts: 419

Original Poster
Rep: Reputation: 31
Hey again
Well,i did as you said and everything was preinstalled
The symbolic link existed as well.
Anyway, i replaced everything and restart mozilla as i was told by the instructions.
Nothing unfortunately.
Any other ideas?
I dont know if you have read my previous post but i installed the jre in my Desktop not in /usr/java .Can this cause any problem?

Thanks for your time
 
Old 12-02-2006, 09:57 PM   #9
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
i say remove the desktop one and install it using all defaults and suggested paths and commands.
 
Old 12-03-2006, 10:16 AM   #10
manolakis
Member
 
Registered: Nov 2006
Distribution: xubuntu
Posts: 419

Original Poster
Rep: Reputation: 31
Really sorry about that but i am quite newbie
I would be really obliged if you could give me an example

Many thanks
 
Old 12-03-2006, 11:40 AM   #11
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
just delete the folder in the desktop that you created for it. use the default install and follow the instructions so its installed in a subdirectory in /usr
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Java plugin installed correctly for Firefox but not able to view any java applet tvn Linux - Software 10 04-15-2010 03:13 AM
LXer: Java news met with cautious optimism in free Java community LXer Syndicated Linux News 0 11-14-2006 11:21 PM
Firefox refuses to load Java jnlp files - plugin and java ok Melsync Linux - Software 1 06-25-2006 05:09 PM
Synaptic Package Manager shows 'java-common' and 'java-gcj-compat' as Installed. swiadek Ubuntu 3 02-12-2006 12:54 PM


All times are GMT -5. The time now is 04:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration