LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-20-2007, 04:15 PM   #1
pm010537
LQ Newbie
 
Registered: Aug 2006
Posts: 25

Rep: Reputation: 15
need help with installing rpm for ipv6calc


Hello,

I am trying to install ipv6calc on my centos4.4 box. I tried with latest version (70/61) but it throws GLIBC-2.4 and GNU-HASH dependency errors; I have glibc 2.3.4-2.36 installed which means I need to upgrade glibc which I found out to be more difficult.

So I decided to go with ipv6calc support by the glib that is installed on my centos; I was able to find an rpm for that(48). Now when I try to install using yum i get public key error:

#yum localinstall ipv6calc-0.48-5.i386.rpm

"public key for ipv6calc-0.48-5.i386.rpm is not installed"

Any idea what is going on here? Can someone help me in install this so easy looking package? The fact that I am not able to do it is driving me nuts.

Your helps is greatly appreciated.
 
Old 06-20-2007, 04:58 PM   #2
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 62
You see if the version from here will install. http://rpm.pbone.net/
Maybe the oldest version there will work.
If still in dependency hell then you will need to upgrade the needed rpms.
Maybe the source will install fine. It could be the builder of the rpm based the needed rpms off thier machine.

Brian
 
Old 06-20-2007, 05:27 PM   #3
pm010537
LQ Newbie
 
Registered: Aug 2006
Posts: 25

Original Poster
Rep: Reputation: 15
Brian,

Thanks for the response. I tried from rpm.pbone.net but I am seeing the same result. I don't mind upgrading GLIB but I am curious to know as in why I am getting message like:

#yum install ipv6calc-0.48-5.i386.rpm
!
!
Downloading Packages:
warning: rpmts_HdrFromFdno: V3 DSA signature: NOKEY, key ID 4f2a6fd2


Public key for ipv6calc-0.48-5.i386.rpm is not installed

Any suggestions on the above mentioned error??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing the nvidia driver off the web site and installing rpm in ubuntu? darkhatter Ubuntu 3 02-19-2006 03:44 PM
installing an RPM trempel Linux - Newbie 6 02-25-2005 03:03 AM
Installing from RPM the_imax Red Hat 1 01-10-2005 01:52 PM
installing rpm...... tinaa Linux - Newbie 1 05-24-2003 03:27 AM
Installing RPM-4 ugge Linux - General 5 04-09-2001 01:43 AM


All times are GMT -5. The time now is 10:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration