LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-28-2007, 09:25 AM   #1
PocketSam
LQ Newbie
 
Registered: Jan 2007
Location: Russia - Novosibirsk
Distribution: Slackware 11
Posts: 10

Rep: Reputation: 0
Question Need help with installing driver for VIA VT8233/A/8235/8237 AC97 Audio Controller


I've compiled a new kernel to fit my needs. And now almost everything seems to be perfect but the sound..

I've got the VIA VT8233/A/8235/8237 AC97 Audio Controller (rev 60) and I need to install driver for it and make it work.

I'm using the 2.4.33.3 kernel and it seems to me there is no support "in sources" for my sound card.(If I'm wrong, please, correct me and prompt me what to do.)
I have one precompiled driver in the alsa-driver package (I think snd-via82xx is what I need.) on my CD and it works with precompiled kernel(But of course it wouldn't work with mine.). And there are no sources of this driver. So I couldn't make one for me.

Even if I have the sources of the driver I don't know how to install it. I've tried to find any tutorials, but didn't find anything exact.
Please help me or refer me somewhere to find a solution.

So, I hope you'll help me again!!! :8[

Last edited by PocketSam; 06-28-2007 at 09:43 AM.
 
Old 06-28-2007, 09:55 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,516

Rep: Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501
You should enable
Code:
CONFIG_SOUND_VIA82CXXX=m
in your kernel. If that doesn't work then you can d/l the sources from alsa and compile them following the instructions for your card.

Regards
 
Old 06-28-2007, 10:43 AM   #3
PocketSam
LQ Newbie
 
Registered: Jan 2007
Location: Russia - Novosibirsk
Distribution: Slackware 11
Posts: 10

Original Poster
Rep: Reputation: 0
Thanks! I'll follow your advice!

By the way, I've used this option (CONFIG_SOUND_VIA82CXXX=m) in my configuration, but alsaconf doesn't find appropriate module. When I used previous kernel alsaconf added thit to my modules.conf:

alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-via82xx
alias sound-slot-0 snd-via82xx

But there is no option for via82xx in Sound options. It exists for via82cxxx, but not for via82xx.
 
Old 06-28-2007, 02:33 PM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,516

Rep: Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501Reputation: 1501
Is seems that VIA82CXXX became VIA82XX in newer kernel versions. If you recompile your kernel use "make menuconfig" to set the correct option name for the VIA module. Else, go on and compile the newest alsa-driver.
 
  


Reply

Tags
modules, sound, soundalsa


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problems installing soundcard VT8233/A/8235/8237 AC97 Dihania Linux - Newbie 1 04-11-2007 09:08 PM
VT8233/A/8235/8237 audio problems on fedora 6 rimvydazas Linux - Hardware 6 01-07-2007 04:41 AM
No Sound:Debian Etch with VT8233/A/8235/8237 AC97 Audio Controller tadellos Debian 2 12-21-2006 12:47 AM
"Broken Record" Sound, SUSE 9.1, VT823/A/8235/8237 AC97 Audio Controller... cillm527 Linux - Hardware 1 05-06-2005 04:42 AM
VIA VT8233/A/8235 AC97 Audio Codec problems spank Linux - Newbie 0 02-22-2004 11:51 AM


All times are GMT -5. The time now is 10:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration