LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-25-2006, 04:29 AM   #1
MaX-PaYnE
LQ Newbie
 
Registered: Nov 2006
Posts: 9

Rep: Reputation: 0
need help with httpd start


hello i installed this module for my httpd : http://rpmfind.net/linux/rpm2html/se...od_auth_dbm.so

and when i do "service httpd start"
it says :
Starting httpd:
Apache 1.3 configuration directives found
please read /usr/share/doc/httpd-2.0.40/migration.html
[FAILED]



what i need to do for my httpd work ?

Last edited by MaX-PaYnE; 11-25-2006 at 04:54 AM.
 
Old 11-25-2006, 08:02 AM   #2
zaichik
Member
 
Registered: May 2004
Location: Iowa USA
Distribution: CentOS
Posts: 419

Rep: Reputation: 30
It looks like you installed the wrong RPM. Apparently you have Apache 2.0, and the RPM you installed was for Apache 1.3. Remove the one you installed and download one for the correct distro and Apache 2.0.40.
 
Old 11-25-2006, 08:13 AM   #3
MaX-PaYnE
LQ Newbie
 
Registered: Nov 2006
Posts: 9

Original Poster
Rep: Reputation: 0
can you please give me link for RPM - CentOS apache 2.0 ?
 
Old 11-25-2006, 08:29 AM   #4
zaichik
Member
 
Registered: May 2004
Location: Iowa USA
Distribution: CentOS
Posts: 419

Rep: Reputation: 30
You might want to try here

You might also want to note that if this is a production server, you'll want to backup important things before upgrading; you might also want to get Apache upgraded to the latest version (2.0.59 is out now).
 
Old 11-25-2006, 11:23 AM   #5
MaX-PaYnE
LQ Newbie
 
Registered: Nov 2006
Posts: 9

Original Poster
Rep: Reputation: 0
not working yet , it gives me error :

[root@228 root]# /usr/local/rpanel/bin/apachectl start
Syntax error on line 227 of /usr/local/rpanel/conf/httpd.conf:
Cannot load /etc/httpd/modules/mod_auth_dbm.so into server: /etc/httpd/modules/mod_auth_dbm.so: undefined symbol: apr_password_validate
/usr/local/rpanel/bin/apachectl start: httpd could not be started
 
Old 11-28-2006, 11:25 AM   #6
zaichik
Member
 
Registered: May 2004
Location: Iowa USA
Distribution: CentOS
Posts: 419

Rep: Reputation: 30
Um, what's rpanel?

Looks like you have some other package there that uses a version of Apache or something along those lines. What do you get when you try
Code:
service httpd start
?
 
Old 11-30-2006, 12:48 AM   #7
MaX-PaYnE
LQ Newbie
 
Registered: Nov 2006
Posts: 9

Original Poster
Rep: Reputation: 0
its working : service httpd start

but i got radio panel that installs another apache and its not working

here is the panel : http://212.150.164.31:3000

thx
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
rc.httpd won't start on boot pioniere Slackware 7 06-27-2006 09:39 PM
cant start httpd mag_um Linux - Software 2 05-27-2005 09:20 AM
httpd start error jkmartha Linux - Newbie 3 04-26-2005 04:09 AM
HTTPD won't start with PHP 4.3.4 BarkingBonefish Linux - Software 0 03-03-2004 01:20 PM
httpd will not start :: buddy Linux - General 9 12-31-2002 01:45 PM


All times are GMT -5. The time now is 06:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration