LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-10-2010, 11:25 PM   #1
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,330

Rep: Reputation: 227Reputation: 227Reputation: 227
Need help with (compiling) GTK+!


When i try to run ./configure, i get this:
Code:
checking for GLIB - version >= 2.19.7... 
*** 'pkg-config --modversion glib-2.0' returned 2.19.8, but GLIB (2.16.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.19.7 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/pub/gtk/.
debian:~/gtk+#
Any idea what that means?
 
Old 05-11-2010, 12:34 AM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
have you done what the error recommends ?
Quote:
by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
i run into problems with gimp plugins ( it is installed on a different partition than Arch ( or cent) is installed
and somethings need to know where it is.

so i need to have a few folders listed for PKG_CONFIG_PATH and LD_LIBRARY_PATH

is this Just a new version of gtk
i have problems with cvs gimp needing cvs gtk
and all the dependencies are NEWER than the OS has installed
 
Old 05-11-2010, 01:07 AM   #3
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,330

Original Poster
Rep: Reputation: 227Reputation: 227Reputation: 227
I am still a newbie in linux.
I do not know what is causing this, i tried messing with enviroment variables to no effect.
 
Old 05-11-2010, 01:10 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2016, Slack14.1 Deb Jessie, + 50+ other Linux OS, for test only.
Posts: 16,276

Rep: Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153Reputation: 3153
Quote:
Any idea what that means?
I guess, it means, you have Debian 5 Lenny, and you are
installing some extra versions of glib2 / gtk2 in order
to have two or more versions of each.
The reason to do so is not quite clear, but it may stop
Nautilus + other Gnome / gtk applications from working.

The already installed system versions :
libglib2.0-0_2.16.6 libglib2.0-dev_2.16.6
libgtk2.0-0-dbg_2.12.12 libgtk2.0-dev_2.12.12



The usual approach to have some extra glib2, gtk2 + the
gtk2 dependencies : install it all to a hideaway location.

./configure --prefix=/usr/local/glib2197/

gtk ( and other ) will find it at compile time with :
export PKG_CONFIG_LIBDIR=/usr/local/glib2197/lib/pkgconfig:/usr/lib/pkgconfig/
which puts /usr/local/glib2197 first in the path
instead of "default first" = /usr/lib .
..
 
Old 05-11-2010, 02:24 AM   #5
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,330

Original Poster
Rep: Reputation: 227Reputation: 227Reputation: 227
Different error:
checking for GLIB - version >= 2.19.7... no
*** A new enough version of pkg-config was not found.
*** See http://www.freedesktop.org/software/pkgconfig/
configure: error:
*** GLIB 2.19.7 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/pub/gtk/.
debian:~/gtk+#
 
Old 05-11-2010, 02:54 AM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,818

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
it looks like you are tring to build a version of gtk that REQUIRES a newer version of glib than is installed .
this can be worked around .see: knudfl post above
BUT a word of warning

i do this sometimes for building the development version of gimp .It often needs a newer version of ( glib,gkt,packageconf,...) than is installed on a up-to-date install of fedora or arch

it is VERY VERY easy to make a typo and KILL your OS ( never boot again)

you need to put the NEWER versions in there own folder that is NOT in the system path then pass that folders location on the the next program ... and so on .. up the chain of dependencies


a better description of what you are trying to do might help us help you
 
Old 05-11-2010, 03:20 AM   #7
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,330

Original Poster
Rep: Reputation: 227Reputation: 227Reputation: 227
Basically i am building a custom gtk+ library.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
compiling gtk? @ngelot Linux - Software 1 11-14-2005 11:20 AM
after compiling GTK deepsix Linux - Software 2 04-02-2005 08:12 PM
compiling gaim/ gtk error (two versions of gtk) webazoid Linux - Software 0 07-06-2004 07:05 PM
compiling gtk LinFreak! Slackware 6 07-19-2003 08:48 PM
Compiling GTK+ 2.0.9 Dexter750 Linux - Software 10 04-28-2003 09:28 PM


All times are GMT -5. The time now is 04:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration