LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-29-2004, 10:17 PM   #1
pfaendtner
Member
 
Registered: Nov 2003
Posts: 57

Rep: Reputation: 15
need help w/dependencies


Hi,

I'm trying to install hotwayd rpm:

[root@localhost jill]# rpm -Uvh hotwayd-0.8-1.i386.rpm
error: Failed dependencies:
cyrus-sasl-devel >= 2.0.0 is needed by hotwayd-0.8-1

can anyone tell me how I can install this package and all its required packages using the add/remove programs gui in gnome (package manager).

I can't figure out which packages to install?

thanks!
 
Old 07-29-2004, 10:36 PM   #2
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 48
I don't know anything about doing it in a GUI, but it looks like you were doing things fine in the terminal window, so I'll give directions on how to continue doing it that way.

You had a failed dependency, sp if you correct that issue, the rpm you're trying to install should go in easily. I went to google.com/linux and dumped in cyrus-sasl-devel. It gave me many links to download versions of that, greater than 2.0.0.You should download whichever is the newest for your distro, and download it to your home directory. Since you were using rpm for the install that failed, you can do the same to install cyrus-sasl-devel. You could give the command:

rpm -i cyrus-sasl-devel* if you don't have cyrus-sasl-devel installed at all, or give the same command you gave to install the other package:

rpm -Uvh cyrus-sasl-devel* if you simply need to upgrade.

If you don't know if you have cyrus-sasl-devel installed, the way to check would be to type:

rpm -qa | grep cyrus-sasl-devel

If that turns up anything, you need to upgrade it, if nothing comes up, you can do a clean install.


I would also strongly suggest looking into apt-get, it is an awesome utility to resolve failed dependencies. It would do all of this for you, all from a simple command like:

apt-get install hotwayd

If any problems occur, write back!

Peace,
JimBass
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dependencies Infernal211283 Linux - Newbie 4 02-19-2005 08:08 AM
Dependencies!! xian67 Linux - Distributions 6 08-03-2004 08:44 PM
I recieve a failed dependencies error, but I have all required dependencies Laptop2250 Linux - Software 15 02-03-2004 07:58 PM
dependencies tincat2 Linux - Software 3 06-27-2002 11:16 PM
dependencies vanhalen Linux - Newbie 1 06-12-2002 08:32 AM


All times are GMT -5. The time now is 03:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration