LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-10-2009, 12:41 AM   #1
snowweb
Member
 
Registered: May 2008
Distribution: Ubuntu12, CentOS6
Posts: 61

Rep: Reputation: 0
Question Need help to install network interface on Ubuntu Server


Hi, I have just installed Ubuntu server 9.04 (64bit) and have successfully logged in. It doesn't install a GUI by default and I didn't see an option to install one during the installation either, so being a newbie this won't be easy!

I don't know where to start trying to get the drivers installed for the onboard network card.

The board is an ASRock Prescott 800.

Please can someone tell me what I need to do?

Thanks,

peter
 
Old 09-10-2009, 01:15 AM   #2
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hello,

In my opinion you don't need a GUI to administer a server, it's a lot faster and less consuming cpu and memory wise to use the console. You'll get to know it real fast.

First of all you need to check if your network card is detected by the kernel or not. Check output of:
Code:
dmesg | grep eth
There should be a line like
Code:
[    3.248930] eth0: registered as PCnet/PCI II 79C970A
of course with the name/type of your network card.

If your network card is listed then edit the interfaces file with your preferred editor (vi is handy if you know it, if you don't then try out nano
Code:
nano /etc/network/interfaces
In that file put in the next (it should already list the lo interface):
Code:
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
address youripaddress
netmask yoursubnetmask 
gateway yourgatewayip
dns-nameservers yourdnsnameserver(s)
or for a DHCP configured NIC
Code:
# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp
Then bring up the interface with:
Code:
ifup eth0
Hope that works.

Kind regards,

Eric
 
Old 09-10-2009, 01:26 AM   #3
snowweb
Member
 
Registered: May 2008
Distribution: Ubuntu12, CentOS6
Posts: 61

Original Poster
Rep: Reputation: 0
thanks Eric for your reply.

I'm trying to type the first command you gave, but my keyboard has no pipe symbol on the keyboard. Please can you tell me how to access it?

thanks,

pete
 
Old 09-10-2009, 01:37 AM   #4
snowweb
Member
 
Registered: May 2008
Distribution: Ubuntu12, CentOS6
Posts: 61

Original Poster
Rep: Reputation: 0
I tried using the symbol which looked like two short pipes, on above the other and low and behold I got '|'! Sorry.

I ran the command you gave,

Quote:
dmesg | grep eth
and this is the output,

Quote:
[1.482237] Driver 'sd' needs updating - please ue bus_type methods
[1.482248] Driver 'sr' needs updating - please ue bus_type methods
What should I do now? Thanks again.

pete
 
Old 09-10-2009, 01:42 AM   #5
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Well the command did not show the make of the chip.
Post the output for

lspci
 
Old 09-10-2009, 01:47 AM   #6
snowweb
Member
 
Registered: May 2008
Distribution: Ubuntu12, CentOS6
Posts: 61

Original Poster
Rep: Reputation: 0
Sorry to be such a novice, but I tried lspci and the results scrolled of the top of the screen and the remainder did not show any relevant lines. Is there a way to stop it from scrolling off the top, or to view what has already scrolled?

I tried lspci --help but the result of that also scrolled out of view.

pete
 
Old 09-10-2009, 01:53 AM   #7
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
lspci | less

or

lspci | grep net for specific network entry.
 
Old 09-10-2009, 02:11 AM   #8
snowweb
Member
 
Registered: May 2008
Distribution: Ubuntu12, CentOS6
Posts: 61

Original Poster
Rep: Reputation: 0
I did 'lspci | grep net' but there was no output, so I tried 'lspci | less' but again there was still too much output to fit on the screen and anything relevant must have appeared higher up

Is there anything else I can try please? Thanks.

pete
 
Old 09-10-2009, 02:27 AM   #9
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Pipe it into more so it will show up in 'pages'. You'll have to click on the spacebar to go to the next page or <enter> for the next line.
Code:
lspci | more
Look for any line that has reference to your network card in it and post those lines here.

Kind regards,

Eric
 
Old 09-10-2009, 02:37 AM   #10
snowweb
Member
 
Registered: May 2008
Distribution: Ubuntu12, CentOS6
Posts: 61

Original Poster
Rep: Reputation: 0
Thanks Eric,

I did the lspci | more and it turns out that there was no more! It fills the screen exactly with none missing. However, it still doesn't look there there are any references to any NIC or anything related.

There are references to graphics, pci bus, usb etc, but no network. Is it possible that it just hasn't recognized it? I've not loaded any drivers or anything. Should I need to?

pete
 
Old 09-10-2009, 02:44 AM   #11
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Do you know what NIC is installed in your server? Looks like you'll have to install the driver into the kernel as it seems not to be detecting it.

Kind regards,

Eric
 
Old 09-10-2009, 03:44 AM   #12
snowweb
Member
 
Registered: May 2008
Distribution: Ubuntu12, CentOS6
Posts: 61

Original Poster
Rep: Reputation: 0
Unfortunately I don't know what NIC it has (or how to find out). The motherboard is an 'ASRock Prescott 800'.

I'm doing some research to try to find out what it might have been equipt with, but please don't wait for that if you can think of something else I can try

Thanks agian everyone for your help.

pete
 
Old 09-10-2009, 04:16 AM   #13
snowweb
Member
 
Registered: May 2008
Distribution: Ubuntu12, CentOS6
Posts: 61

Original Poster
Rep: Reputation: 0
Smile

I just installed a replacement NIC and ran lspci | net again. This is the result:

Quote:
01:02.0 Ethernet Controller: 3com Corporation 3c905 100BaseTX [Boomerang]
What now please?

Thanks,

peter
 
Old 09-10-2009, 04:22 AM   #14
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Just go back to my post (#2) and edit the configuration file. If you're lucky after configuration the interface will come up without any problems and you'll have network connectivity.

If you encounter any problems, just let us know.

Kind regards,

Eric
 
Old 09-10-2009, 05:05 AM   #15
snowweb
Member
 
Registered: May 2008
Distribution: Ubuntu12, CentOS6
Posts: 61

Original Poster
Rep: Reputation: 0
Thanks Eric.

I just ran 'dmesg | grep eth' and this was the output,

Quote:
[1.482235] Driver 'sd' needs updating - please use bus_type methods
[1.482246] Driver 'sr' needs updating - please use bus_type methods
Because of that, I was unable to continue following your instructions.

What should I do now please?

pete

Last edited by snowweb; 09-10-2009 at 05:30 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ubuntu - on reboot, interface up, but no network. dutler Linux - Networking 6 02-04-2009 06:45 AM
xubuntu on vmware server - no network interface? bobkoure Linux - Newbie 2 12-11-2008 04:48 PM
LXer: How to Change MTU (Maximum Transmission Unit) of network interface in Ubuntu Li LXer Syndicated Linux News 0 08-16-2008 08:20 AM
interface mapping two IPs on ubuntu 6.06 lts server elgranjefe Linux - Networking 9 11-12-2007 09:09 PM
Unable to add network interface under Ubuntu 5.10 pxumsgdxpcvjm Linux - Wireless Networking 0 01-29-2006 03:32 PM


All times are GMT -5. The time now is 07:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration