LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-19-2003, 09:54 PM   #1
Dave177
LQ Newbie
 
Registered: Dec 2003
Posts: 3

Rep: Reputation: 0
Question Need help setting up SSH on RedHat


I'm trying to connect from my Windows XP machine to my linux box using Putty on my windows machine and OpenSSH on the linux box.

However when I try to connect I get: "Error connection reset by peer"

I am not very knowledgable about Linux so I don't know if I have SSH set up right. I'm using RedHat Linux 7.3. If I type service sshd start in the terminal it says Starting sshd: OK so I'm reasonably sure its running. I can successfully ping the linux machine from my linux computer so I know its there.

Putty Coniguration:
Protocol SSH, port 22.

This is my configuration file (sshd_config):
If I change the configuration file does it update automatically or do I have to restart or something? Thanks for your help!

# $OpenBSD: sshd_config,v 1.59 2002/09/25 11:17:16 markus Exp $

# This is the sshd server system-wide configuration file. See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/local/bin:/bin:/usr/bin

# The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
# possible, but leave them commented. Uncommented options change a
# default value.

#Port 22
#Protocol 2,1
#ListenAddress 0.0.0.0
#ListenAddress ::

# HostKey for protocol version 1
#HostKey /etc/ssh/ssh_host_key
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key

# Lifetime and size of ephemeral version 1 server key
#KeyRegenerationInterval 3600
#ServerKeyBits 768

# Logging
#obsoletes QuietMode and FascistLogging
#SyslogFacility AUTH
SyslogFacility AUTHPRIV
#LogLevel INFO

# Authentication:

#LoginGraceTime 120
PermitRootLogin no
#StrictModes yes

#RSAAuthentication yes
#PubkeyAuthentication yes
#AuthorizedKeysFile .ssh/authorized_keys

# rhosts authentication should not be used
#RhostsAuthentication no
# Don't read the user's ~/.rhosts and ~/.shosts files
#IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
#RhostsRSAAuthentication no
# similar for protocol version 2
#HostbasedAuthentication no
# Change to yes if you don't trust ~/.ssh/known_hosts for
# RhostsRSAAuthentication and HostbasedAuthentication
#IgnoreUserKnownHosts no

# To disable tunneled clear text passwords, change to no here!
PasswordAuthentication yes
#PermitEmptyPasswords no

# Change to no to disable s/key passwords
#ChallengeResponseAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

#AFSTokenPassing no

# Kerberos TGT Passing only works with the AFS kaserver
#KerberosTgtPassing no

# Set this to 'yes' to enable PAM keyboard-interactive authentication
# Warning: enabling this may bypass the setting of 'PasswordAuthentication'
#PAMAuthenticationViaKbdInt no

#X11Forwarding no
X11Forwarding yes
#X11DisplayOffset 10
#X11UseLocalhost yes
#PrintMotd yes
#PrintLastLog yes
#KeepAlive yes
UseLogin yes
#UsePrivilegeSeparation yes
#PermitUserEnvironment no
#Compression yes

#MaxStartups 10
# no default banner path
#Banner /some/path
#VerifyReverseMapping no

# override default of no subsystems
Subsystem sftp /usr/libexec/openssh/sftp-server
 
Old 12-19-2003, 09:59 PM   #2
slackhappy
Member
 
Registered: Dec 2003
Location: Ontario, Canada
Distribution: RH 7.3 - 9, Slackware 9.1
Posts: 43

Rep: Reputation: 15
Make sure your firewall (XP or linux) isn't blocking your ssh port. I had this problem before.
 
Old 12-19-2003, 10:23 PM   #3
Dave177
LQ Newbie
 
Registered: Dec 2003
Posts: 3

Original Poster
Rep: Reputation: 0
I don't think its Windows XP becuase I tried turning of my firewall (Norton Internet Security) and it still didn't work. How do I find out what my SSH port is and how do I configure my linux firewall?
 
Old 12-19-2003, 10:28 PM   #4
Dave177
LQ Newbie
 
Registered: Dec 2003
Posts: 3

Original Poster
Rep: Reputation: 0
Oh nm, I just had to go to Security Level Config. It let me connect after I changed that. Thanks for your help, for something I spend so many hours on turned out to be soo simple
 
Old 12-20-2003, 11:04 AM   #5
slackhappy
Member
 
Registered: Dec 2003
Location: Ontario, Canada
Distribution: RH 7.3 - 9, Slackware 9.1
Posts: 43

Rep: Reputation: 15
Hehe....it always works that way. We tend to overlook the simplest things. Congratulations on getting it working!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up ssh simeandrews Mandriva 8 03-22-2005 06:10 PM
setting up SSH Ryan450 Linux - Security 4 01-27-2005 01:36 AM
Need Help Setting up SSH digsby0007 Linux - Software 2 05-01-2003 03:04 PM
setting up ssh emanners Linux - General 3 07-25-2001 02:55 PM
setting up ssh punt Linux - General 3 06-11-2001 04:38 PM


All times are GMT -5. The time now is 02:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration