LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-30-2003, 02:59 AM   #1
Kethinov
Member
 
Registered: Oct 2003
Location: ESU, Student Teaching 5th Grade
Distribution: Ubuntu
Posts: 118

Rep: Reputation: 15
Need help setting up some hardware in Mandrake


Hi all.
I decided to go with Mandrake and I have a few problems here and there, but first thing's first, I need some help with my hardware.

Mandrake properly detected my PCI audio card as well as my mobo's onboard sound device. When I go to play songs in XMMS, it plays but I hear no sound. I'm assuming this is because XMMS is using the bad onboard sound device, of which no speakers are plugged into. I'd like to disable the onboard device if possible. How can I do that?

Secondly, my graphics drivers aren't very good. Mandrake used a Generic NVIDIA driver for my Geforce4 MX 440. As a result, many effects can be laggier than they should be. I'd like to install the proper graphics driver, but I don't know where to get one or how to install it.

Any advice is appreciated.
 
Old 10-30-2003, 03:07 AM   #2
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
for your video, this nvidia thread should help you out.

http://www.linuxquestions.org/questi...threadid=71711

for xmms, first off, check if your kde sound server is up and running when you start. it's somewhere in your kde control center. you can run the command, kcontrol, from the shell terminal. kde uses the arts sound server. now go into xmms and right click on the title bar and choose Options > Preferences. in output plugin make sure arts is choosen.
 
Old 10-30-2003, 03:14 AM   #3
Kethinov
Member
 
Registered: Oct 2003
Location: ESU, Student Teaching 5th Grade
Distribution: Ubuntu
Posts: 118

Original Poster
Rep: Reputation: 15
Thank you, but that's not the problem. According to the options, the kde sound center arts thingie is on and set to load on startup.

I think this is simply a matter of XMMS playing sound with the wrong item of hardware. How does one fix that?
 
Old 10-30-2003, 03:17 AM   #4
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
Quote:
Originally posted by Kethinov
Thank you, but that's not the problem. According to the options, the kde sound center arts thingie is on and set to load on startup.

I think this is simply a matter of XMMS playing sound with the wrong item of hardware. How does one fix that?
did you check xmms to make sure it's using the arts plugin for output? if you're in kde and arts is set to use an output plugin that's not arts, it will not play. actually it will play with the oss output plugin if you turn off the arts sound server. but if arts is on at login, check xmms to see if it's using arts.
 
Old 10-30-2003, 05:55 AM   #5
stv_t
Member
 
Registered: Oct 2003
Location: Gatwick, UK
Distribution: Mandrake 9.1, Mandrake 9.2, Redhat 9.0
Posts: 47

Rep: Reputation: 15
Hi,

You don't say what sound card you are using or if you get any sound when you first login on the kde startup screen.
Don't know if this helps but I have sound blaster 5.1 card which after a reboot ALWAYS comes up as muted. However just unmuting from 'kmix' or the taskbar does not fix the problem. I also have to go into 'kmix' and change the levels on the speaker and the PCM or WAVE input lines before any sound is output. Saving these levels as the defaults does not seem to do any good so I have to go through this procedure after every boot/login
Also don't be fooled by just looking at the levels and thinking they are at the maximum you HAVE to change each of them before they take effect.

stv T
 
Old 10-30-2003, 12:30 PM   #6
Kethinov
Member
 
Registered: Oct 2003
Location: ESU, Student Teaching 5th Grade
Distribution: Ubuntu
Posts: 118

Original Poster
Rep: Reputation: 15
I have a CMedia motherboard-integrated card and a Soundblaster Audigy PCI soundcard. The arts driver is selected in XMMS, but it still plays using the CMedia card instead of the Audigy. Kmix doesn't have anything (except record) muted.
 
Old 10-30-2003, 01:10 PM   #7
stv_t
Member
 
Registered: Oct 2003
Location: Gatwick, UK
Distribution: Mandrake 9.1, Mandrake 9.2, Redhat 9.0
Posts: 47

Rep: Reputation: 15
Hi,

Have you turned off the motherboard sound chip from the bios setup screen ?
It will not use the PCI card until it is. Once your've done this it should use the PCI card.

I believe that my above post will still apply as I think the Audigy and the Soundblaster Live 5.1 use the same sound chip.

stv T
 
Old 10-30-2003, 01:16 PM   #8
musrum
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 112

Rep: Reputation: 15
Something that often helps...

If you have alsactl and alsamixer on your box, run alsamixer. Set the default levels you want, and unmute whatever channels you want to be unmuted by default.

Exit alsamixer, and run 'alsactl store'.

Edit you're .profile and add a line

alsactl restore

Now each time you log in, your default levels will be restored.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
setting the hardware clock.. kurrupt Linux - Hardware 1 08-26-2004 12:00 AM
asus mandrake hardware chil326 Linux - Hardware 2 07-28-2004 10:08 PM
Setting unusual networking setting in Mandrake zamri Linux - Networking 1 05-28-2004 07:43 AM
Mandrake and my Hardware Air Linux - Hardware 3 06-12-2003 03:49 AM
Setting up a Dual Boot with hardware RAID (HPT372) Kashra Linux - Hardware 15 11-17-2002 04:50 PM


All times are GMT -5. The time now is 06:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration