LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-10-2010, 05:28 AM   #1
ravibhure
Member
 
Registered: May 2007
Posts: 75

Rep: Reputation: 15
Need help on virtual interface eth0:1 disable at boot time


Hi,
I have set 'ONBOOT=no' in interface script '/etc/sysconfig/network-scripts/ifcfg-eth0:2' but my interface bring up at boot time, what is the problem , I have checked it 3 or 4 diff os/machine but the same issue. Can anyone please help me to disable virtual IP's at boot time that network script make it up every boot time.
 
Old 02-10-2010, 08:19 AM   #2
backtolinux
LQ Newbie
 
Registered: Nov 2009
Posts: 20
Blog Entries: 1

Rep: Reputation: 2
not beautyfull :
disable it in the rc.local init file ifdown eth0:2
 
Old 02-10-2010, 11:38 AM   #3
ravibhure
Member
 
Registered: May 2007
Posts: 75

Original Poster
Rep: Reputation: 15
Not the way to resolve I need to make it possible through the network-script or set into the interface config (ifcfg-eth0:2)
 
Old 02-10-2010, 12:06 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Which distribution(s) versions did you try this with?

For aliased sub-interfaces ONBOOT is the wrong option,
anyway, it should say ONPARENT.
 
Old 02-11-2010, 04:12 AM   #5
backtolinux
LQ Newbie
 
Registered: Nov 2009
Posts: 20
Blog Entries: 1

Rep: Reputation: 2
verify in /etc/modprobe* or /etc/modules if there is a reference for your card. delete them if exist
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable dhcpcd for eth0 on boot thomasw92 Linux - Newbie 2 04-10-2006 02:49 AM
Can't bring up eth0 Interface at boot robertmenezes Linux - Networking 8 02-21-2005 02:13 AM
Virtual PC 2004 and VWware Workstation - "interface eth0 [failed]" abijahboaz Linux - Newbie 8 10-16-2004 08:53 PM
howto disable eth0 at boot time rydogg Linux - Newbie 2 06-16-2003 10:33 AM
virtual interface eth0:0 irfanasim Linux - General 2 10-11-2002 12:58 PM


All times are GMT -5. The time now is 12:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration