LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-17-2003, 08:51 PM   #1
jsbush
LQ Newbie
 
Registered: Oct 2003
Posts: 22

Rep: Reputation: 15
need help installing php with apache


I get the following error when I try to install php.

error: Failed dependencies:
httpd-mmn = 20020903 is needed by php-4.3.3-6

Any idea's?
Thanks
 
Old 11-17-2003, 08:55 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
That dependency is usually provided by apache...
 
Old 11-17-2003, 09:02 PM   #3
jsbush
LQ Newbie
 
Registered: Oct 2003
Posts: 22

Original Poster
Rep: Reputation: 15
I have apache installed already.

I'm runing RedHat 9.
 
Old 11-17-2003, 10:06 PM   #4
Mikhail_16
Member
 
Registered: Oct 2003
Distribution: Gentoo rules them all
Posts: 279

Rep: Reputation: 31
welcome, my friend to rpm-hell. after a month of trying i was not able to install php and apache on my box (properly). (btw, that was about 1 year ago, i am MUCH better now).
I believe its about time you switched to gentoo. 'Why?' you ask. Simple: this is how you install php on gentoo:
emerge php (wait a bit)
emerge apache mod_php (wait a bit)
/etc/init.d/apache start (you have a running apache with php)



Ps. about your problem, though, go to php.net (php home page) and there are fairly good instructions on installing php there, even for RH. Do not forget mod_php module for apache or it will not work.

Last edited by Mikhail_16; 11-17-2003 at 10:08 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing PHP onto Apache LinuxStart Linux - Software 2 07-10-2005 02:39 PM
apache problems after installing PHP madBASHer Programming 1 05-20-2005 04:55 PM
Installing Apache, MySQL and PHP foo_mulan Linux - Newbie 1 07-16-2004 07:28 AM
Problems installing Apache 2.0.49, PHP 4.3.6, and GD 2.0.22 Thorin98 Linux - Newbie 1 04-20-2004 03:13 AM
Installing Apache 2, PHP 4.3.4 and MySQL 4.0.17 drews Slackware 12 02-15-2004 07:52 PM


All times are GMT -5. The time now is 05:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration