LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-09-2008, 07:15 PM   #1
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Rep: Reputation: 37
Need help fixing Xorg


Hey guys,

Running Ubuntu 8.10 Intrepid Ibex.

I had fglrx driver and compiz working at 1280x768 resolution and decided to try the r128 driver.

So I edited xorg.conf and changed the driver from fglrx to r128 and then restarted X.

I was then confronted with a rather reduced resolution (800 x 600).

I changed the driver setting in the xorg.conf file back to fglrx and restarted X once again but now I cannot set the resolution above 800 x 600 and I cannot enable Compiz.

I tried doing dpkg-reconfigure -phigh xserver-xorg but that did not fix either.

What else do I need to edit to fix this?
 
Old 12-09-2008, 07:21 PM   #2
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Is fglrx really loaded? Have you tried a reboot or inserting the module?

If all else fails, just remove and reinstall the fglrx module.
 
Old 12-09-2008, 07:34 PM   #3
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Original Poster
Rep: Reputation: 37
Thanks Jay,

Phew, that was a close call! I rebooted and then I was able to choose a higher resolution 1366 x 768 and also I was able to restart compiz.

The only other strange thing was the little applets that live in the Gnome Panel at the top of the screen changed position, so I had to unlock them and move them around again.

I lost the separators on the panel also, and I cannot add a new one.

Other than that, everything seems to have returned to normal.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Medion MIM 2310 powersoff without Xorg...when Xorg installed does not power off. gluesniffmonkey Linux - Laptop and Netbook 6 12-04-2007 07:28 PM
Sid Users - Beware of Xorg 7.3 (xserver-xorg-input-evdev) bug rickh Debian 4 10-24-2007 03:30 AM
Removing custom built Xorg to install Etch's Xorg kushalkoolwal Debian 4 05-30-2007 01:50 AM
fixing xorg.conf SVwander Ubuntu 4 02-20-2007 09:57 PM
recent dist-upgrade of xorg has killed my mouse (and thusly, xorg). Lokathor Debian 4 06-10-2006 04:52 AM


All times are GMT -5. The time now is 10:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration