LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-15-2011, 10:38 AM   #1
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: LinuxMint 17.3 Rosa 64 bit
Posts: 585

Rep: Reputation: 49
Need Drupal 7.8 installation help - FTP required for updates - how to enable it?


Hello:

I just did a fresh install of Drupal 7.8 on my Slackware 13.37 system but I get the following error msgs - please see attachments because I don't know how to insert them in this text.

It seems that the module 'Block' cannot be updated because there is no access to FTP.

I do not know what to do, and worse, how to do it.

I posted to the Drupal forum a couple of days ago but did not receive any help - probably because it is way too newbie-ish.

I really do not wish to proceed with Drupal until I find out how to fix this, or, an experienced Drupal user tells me that it doesn't matter.

Any guidance would be greatly appreciated.

Thanks,
Attached Thumbnails
Click image for larger version

Name:	snapshot1.png
Views:	9
Size:	8.6 KB
ID:	7986   Click image for larger version

Name:	snapshot2.png
Views:	14
Size:	19.6 KB
ID:	7987   Click image for larger version

Name:	snapshot3.png
Views:	13
Size:	4.9 KB
ID:	7988  
 
Old 09-16-2011, 03:03 AM   #2
Timothy.u
Member
 
Registered: Aug 2011
Location: Lithuania
Distribution: Slackware, Debian, Archlinux
Posts: 44

Rep: Reputation: Disabled
Do you have ftp server on your slackware?
 
1 members found this post helpful.
Old 09-16-2011, 05:23 AM   #3
resolv_25
Member
 
Registered: Aug 2011
Location: Croatia
Distribution: Debian 7/Ubuntu 14.04
Posts: 57

Rep: Reputation: 9
It's not very clear, is your Drupal installed on local machine ?
In that case, ftp doesn't matter.
Just extract Block module within modules/ directory. (take care about permission over directory)
After login on Drupal site, go to Admin->Modules
Enable the module Block.
 
Old 09-16-2011, 05:28 AM   #4
resolv_25
Member
 
Registered: Aug 2011
Location: Croatia
Distribution: Debian 7/Ubuntu 14.04
Posts: 57

Rep: Reputation: 9
I see now, most probably you installed Drupal 7 and module tries to install dependencies via ftp.
You can try to install FTP server on your machine, but more simple would be to install all dependencies manually.
Go to site from this module and find out about required dependencies.
 
Old 09-16-2011, 09:38 AM   #5
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: LinuxMint 17.3 Rosa 64 bit
Posts: 585

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by Timothy.u View Post
Do you have ftp server on your slackware?
Hi Timothy:

I really don't know anything about FTP for certain.

I did a complete install of Slackware 13.37.

If I type ftp in the terminal, I get:
Code:
bash-4.1$ ftp
ftp>
I guess it is installed, right?

Thanks,
 
Old 09-16-2011, 09:46 AM   #6
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: LinuxMint 17.3 Rosa 64 bit
Posts: 585

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by resolv_25 View Post
It's not very clear, is your Drupal installed on local machine ?
In that case, ftp doesn't matter.
Just extract Block module within modules/ directory. (take care about permission over directory)
After login on Drupal site, go to Admin->Modules
Enable the module Block.
Hi Resolv:

Yes, Drupal 7.8 is installed on my local machine. I have not yet altered, in any way, the default install.

The 'Block' module is enable by default during the install. It is 'Enabled'.

Does this help?

Thanks,
 
Old 09-16-2011, 01:29 PM   #7
tux-junkie
Member
 
Registered: Jan 2005
Location: Atlanta, GA
Distribution: Debian, Fedora
Posts: 35

Rep: Reputation: 0
Did you set the permissions correctly for the upload folder and enable FTP access during the installation?
 
Old 09-16-2011, 03:25 PM   #8
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: LinuxMint 17.3 Rosa 64 bit
Posts: 585

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by tux-junkie View Post
Did you set the permissions correctly for the upload folder and enable FTP access during the installation?
Hi tux-junkie:

I really don't know. I did a default install of both Slackware 13.37 and Drupal 7.8.

My directory tree is:
root-->var-->www-->htdocs-->vacations-->(etc)

vacations is my website directory. All the drupal stuff is under it. (i.e. I access my site in my browser by using this address: localhost/vacations/

Drupal never asked me to enable FTP.

What sort of permissions do you suggest?

Edit: all the directories, from vacations downward, can be modified by the owner, which is root, I think. When I am in Drupal, I sign in as root.

Thanks,

Last edited by Robert.Thompson; 09-16-2011 at 03:32 PM.
 
Old 09-19-2011, 01:11 AM   #9
Timothy.u
Member
 
Registered: Aug 2011
Location: Lithuania
Distribution: Slackware, Debian, Archlinux
Posts: 44

Rep: Reputation: Disabled
Quote:
Originally Posted by Robert.Thompson View Post
Hi Timothy:

I really don't know anything about FTP for certain.

I did a complete install of Slackware 13.37.

If I type ftp in the terminal, I get:
Code:
bash-4.1$ ftp
ftp>
I guess it is installed, right?

Thanks,
Hey, the thing you wrote and poped-out, is ftp client, if u're testing cms (Drupal) on your local machine, at any case, u need to give it permision to access via ftp, so to be exact, u need ftp-server. U can try installing proftpd or first to check don't u have any intalled ftp servers run: slackpkg search ftp. in case U have one, google how to configure it properly, than in drupal, provide that information (In case u're not sure about have u one or no, post outcome from that command here). And by the way, while u were installing drupal, did u provide root login/pass at some point? In that case it won't work for sure, U need to create specific user, and group for cms use. If I recall correctly, there is even more problems with joomla, even if u have proper access via ftp, some folders always popup without proper permisions... So be carefull.

Last edited by Timothy.u; 09-19-2011 at 01:18 AM.
 
Old 09-19-2011, 08:22 AM   #10
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: LinuxMint 17.3 Rosa 64 bit
Posts: 585

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by Timothy.u View Post
Hey, the thing you wrote and poped-out, is ftp client, if u're testing cms (Drupal) on your local machine, at any case, u need to give it permision to access via ftp, so to be exact, u need ftp-server. U can try installing proftpd or first to check don't u have any intalled ftp servers run: slackpkg search ftp. in case U have one, google how to configure it properly, than in drupal, provide that information (In case u're not sure about have u one or no, post outcome from that command here). And by the way, while u were installing drupal, did u provide root login/pass at some point? In that case it won't work for sure, U need to create specific user, and group for cms use. If I recall correctly, there is even more problems with joomla, even if u have proper access via ftp, some folders always popup without proper permisions... So be carefull.
Hi Timothy:

Here is my output:
Code:
bash-4.1# slackpkg search ftp

Looking for ftp in package list. Please wait... DONE

The list below shows all packages with name matching "ftp".

[ installed ] - lftp-4.2.2-i486-1
[ installed ] - ncftp-3.2.5-i486-1
[ installed ] - netkit-ftp-0.17-i486-1
[ installed ] - obexftp-0.23-i486-5
[ installed ] - proftpd-1.3.3e-i486-1
[ installed ] - tftp-hpa-0.49-i486-1
[ installed ] - vsftpd-2.3.4-i486-1
[ installed ] - gftp-2.0.19-i486-1

You can search specific files using "slackpkg file-search file".


bash-4.1#
Yes, I did set up Drupal with 'root' as the user and the my root password.

Does this mean that I should unistall drupal and start over?

Thanks,
 
Old 09-19-2011, 08:43 AM   #11
resolv_25
Member
 
Registered: Aug 2011
Location: Croatia
Distribution: Debian 7/Ubuntu 14.04
Posts: 57

Rep: Reputation: 9
Why don't you install module with dependencies manually ? It is far simpler than install and configure ftp server only for Drupal.
Find details about module on drupal site.
Here is list of many modules: http://drupal.org/project/modules/categories
or you can use their search.
- Than put all dependencies in your /var/www/htdocs/vacations/modules
- For those extracted modules put proper permission as readable and executable by web server user.
- Enable all modules within administration module of Drupal.

That's it.
 
Old 09-19-2011, 09:10 AM   #12
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: LinuxMint 17.3 Rosa 64 bit
Posts: 585

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by resolv_25 View Post
Why don't you install module with dependencies manually ? It is far simpler than install and configure ftp server only for Drupal.
Find details about module on drupal site.
Here is list of many modules: http://drupal.org/project/modules/categories
or you can use their search.
- Than put all dependencies in your /var/www/htdocs/vacations/modules
- For those extracted modules put proper permission as readable and executable by web server user.
- Enable all modules within administration module of Drupal.

That's it.
Hi Resolv_25:

The Drupal UI automatic update gives me the error while it tries to update the 'Block' module.(It is a 'core' module) The Status Report tells me that I need to update.

I cannot find the 'Block' module on the Drupal site.

I could be confused but shouldn't the Drupal UI be able to update the core modules?

Thanks,
 
Old 09-20-2011, 01:05 AM   #13
Timothy.u
Member
 
Registered: Aug 2011
Location: Lithuania
Distribution: Slackware, Debian, Archlinux
Posts: 44

Rep: Reputation: Disabled
Hey again, U have installed vsftpd ftp server, so try google how to configure it, than make local user on your machine for drupal use, and yes, start over your instalation, if i recall correctly it doesn't take more than 5 minutes to reinstall it...
 
Old 09-20-2011, 02:39 AM   #14
resolv_25
Member
 
Registered: Aug 2011
Location: Croatia
Distribution: Debian 7/Ubuntu 14.04
Posts: 57

Rep: Reputation: 9
Quote:
Originally Posted by Robert.Thompson View Post
Hi Resolv_25:

The Drupal UI automatic update gives me the error while it tries to update the 'Block' module.(It is a 'core' module) The Status Report tells me that I need to update.

I cannot find the 'Block' module on the Drupal site.

I could be confused but shouldn't the Drupal UI be able to update the core modules?

Thanks,
I see, I'm actually using Drupal 6 and all this is unnecessary. Obviously, new version of Drupal is more intended for use in a production environment.
In that case, you must install ftp server, vsftpd is a good option.
After installation, it is not difficult to configure it. Configuration file shall be /etc/vsftpd.conf
I think the following lines shall be changed:

Code:
anonymous_enable=YES

local_enable=YES

write_enable=YES
Next, if you are behind the router, you must configure port forwarding on your router.
Router must forward TCP port 21 from router to your PC. (FTP is using that port)
Good help for port forwarding: http://portforward.com/english/route...outerindex.htm
Plenty routers with excellent help for configuration.

After that, Drupal shall be able to do updates via ftp.

Last edited by resolv_25; 09-20-2011 at 03:29 AM.
 
Old 09-20-2011, 10:56 AM   #15
Robert.Thompson
Member
 
Registered: Nov 2009
Location: Montreal, Quebec, Canada
Distribution: LinuxMint 17.3 Rosa 64 bit
Posts: 585

Original Poster
Rep: Reputation: 49
Hi Timothy,Resolv_25 and tux-junkie:

First, I want to thank you guys for all your help.

Between my last post and your posts about vsftpd, I:
  1. Re-installed Slackware 13.37 from my clonezilla back-up of my 'Pre Drupal' installation - God only knows what changes Drupal and I made to the config files etc!
  2. Removed Apache, MySql and php from the Slackware 13.37 install.
  3. Downloaded and, this time, successfully installed and configured XAMPP.
  4. Re-installed Drupal 7.8

This time, Drupal seems to work without throwing the FTP error msgs etc at me.

XAMPP installs, it seems, to the 'opt' directory, not the 'var' directory. I don't know the significance of this; I hope that this is OK.

Would I be better off to trash everything again and then try to manually install and configure LAMP and vsftpd and then try to install Drupal 7.8, or, does it matter?

Anyway, thanks again for all your time and help,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
drupal installation issue on fedora 14 monag Linux - Software 2 06-08-2011 10:17 PM
LXer: Installation of Drupal and Ubercart 2.x LXer Syndicated Linux News 0 03-19-2010 09:20 AM
SLED 10 Software Failed Required Updates linbvd Linux - Software 0 04-24-2007 11:22 PM
Existing java updates required to remain on computer? colinstu General 1 02-20-2007 12:44 AM
Alternate Apt mirror for gnome updates required timko Fedora 1 02-20-2004 12:24 PM


All times are GMT -5. The time now is 12:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration