LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-03-2004, 07:57 PM   #1
vettebro1
LQ Newbie
 
Registered: Mar 2002
Posts: 5

Rep: Reputation: 0
need drive write permissions with regular user


Thanks to everyone for helping me.... I installed a new maxtor harddrive to an existing install of Red Hat 9. I mounted the drive in fstab with

dev/hdb1 /mnt/maxtor vfat auto,unmask=000 0 0

I have write permissions with root but not as a regular user. I changed permissions of the mnt and maxtor folders to chmod 777 and I added the regular user to root as the primary group. I even changed hdb1 file in the dev folder to chmod 777
(the user account is just for me and I used 777 becuase I couldnt get it to work)

Thanks again...
 
Old 03-03-2004, 08:14 PM   #2
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
Hi Vettebro,

Probably need to add the <rw> option to your /etc/fstab file. In other words...

dev/hdb1 /mnt/maxtor vfat auto,rw

Then remount the drive. Also, on my system the option <unmask> is actually <umask>, i.e. the permissions for non-specified processes (see man pages for fstab and mount).

Cheers, M.

Last edited by mjrich; 03-03-2004 at 08:16 PM.
 
Old 03-04-2004, 01:28 PM   #3
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 542

Rep: Reputation: 32
You need a line like this in your /etc/fstab
dev/hdb1 /mnt/maxtor vfat noauto,user,rw 0 0
This avoid /dev/hdb1 to be mounted with root permissions at boot
Ciao
 
Old 03-04-2004, 09:16 PM   #4
vettebro1
LQ Newbie
 
Registered: Mar 2002
Posts: 5

Original Poster
Rep: Reputation: 0
Yep that was it!!!! Thanks guys....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
User write permissions on ext3 partition darin3200 Linux - General 4 05-30-2005 08:27 AM
My user account has no write permissions guitarfella Slackware 2 12-15-2004 12:08 AM
write to windows fat partition as regular user feetyouwell Linux - Software 2 09-11-2004 03:07 AM
Sharing a directory with a regular user (with write permission) Ironica Linux - Newbie 6 05-31-2004 11:27 AM
write permissions for a storage drive Riichard Linux - General 7 12-31-2003 02:30 AM


All times are GMT -5. The time now is 02:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration