LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-08-2004, 07:36 PM   #1
ruddigger
LQ Newbie
 
Registered: Sep 2004
Distribution: Debian Sarge
Posts: 13

Rep: Reputation: 0
Need a X Guru's help!!!


First of all I'm a real newbie, so I need all help I can get.
I have been using Mandrake 9.1 fairly good, until i changed to 10.0.
It installed sweetly until the part where I had to configure the X server, so right now I have linux without GUI. I don't know what to do to get i to work!
Apparently there's a problem with some display. It seems that I don't have the environmental variable set (don't know why) so I tried settin (export DISPLAY=etc) it to everything imaginable, with no results. Tried using some of the xapps, like xhost and allways get the same message "unable to open display x"
Whenever I run startx or xinit, as user or root I get two error messages:
1 ATI(0): Virtual size (800x600) (pitch 800) exceeds video memory [I used with 1024]
2 Screen(s) found, but none have a usable configuration.
Fatal server error:
no screens found
later I get this:
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.
xdm error log gives me the following: IO errror in XOpenDisplay
Server for display :0 terminated unexpectedly
Display :0 cannot be oppened
Display :0 is being disabled.
Basically I don't know what else to do. I'm running out of ideas here.
I'm using an ATI Graphics pro turbo and nothing too fancy or extraordinary, everything was working perfectly
If you need them I have any logs or error messages you can probably think of
Will appreciate any help you can give me. Thanks
 
Old 09-08-2004, 07:59 PM   #2
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
well...i think you just gotto run ' xorgconfig '; answer the questions
and ' startx ' will get you going..

egag..
 
Old 09-08-2004, 09:21 PM   #3
fphillips
Member
 
Registered: Sep 2004
Location: KS
Distribution: Slack 10-current
Posts: 87

Rep: Reputation: 15
Quote:
(export DISPLAY=etc) it to everything imaginable, with no results. Tried using some of the xapps, like xhost and allways get the same message "unable to open display x"
You need to get X running before you can run x apps.

Quote:
2 Screen(s) found, but none have a usable configuration.
Fatal server error:
no screens found
This means your /etc/X11/xorg.conf needs some editing. xorgconfig like egag said may get you going. If not, let's see your "Monitor" "Device" and "Screen" sections from that file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
need help from Linux guru's please lvieira Linux - General 2 06-15-2004 10:02 AM
One for the CLI Guru's! R4z0r Linux - General 2 05-01-2004 07:37 AM
Guru's help need for security netguy2000 Linux - Networking 2 02-05-2004 12:46 PM
Guru's help need for security netguy2000 Linux - Security 2 02-05-2004 11:49 AM
Just want to say thanks to all of you guru's terek Linux - Newbie 12 04-02-2003 05:37 PM


All times are GMT -5. The time now is 08:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration