LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-28-2008, 11:33 PM   #1
kwebbel
LQ Newbie
 
Registered: Nov 2008
Posts: 15

Rep: Reputation: 0
ndiswrapper won't install driver for wireless adaptor.


Hey guys,

I've been looking around this forum for a few days, and I know a lot of people ask questions about how to get their wireless adaptors working with ndiswrapper, but so far everything I've looked at hasn't helped, so I hope no one minds if I start a new topic.

Basically, I have a D-Link DWA-130 Wireless USB adaptor, and I'm trying to get ndiswrapper to install the drivers. I know ndiswrapper can handle the drivers, because I saw it listed on the archive site which has the list of all the drivers it can install.

I've tried following this tutorial to install the correct driver, and everything goes fine until step 11. Whenever I type

Code:
 ndiswrapper -i drivername.inf
I don't receive the message I'm supposed to receive, which should say

Code:
Forcing parameter IBSSGMode|0 to IBSSGMode|2
And so the driver doesn't end up being installed. I've been at this for 5 days, can someone help me out?

Also, I'm using Fedora 10 on a Compaq Presario V6000. And my architecture is i686...I'm not entirely sure what that means, but I think it's important, haha!
 
Old 11-29-2008, 12:28 AM   #2
sydney-troz
Member
 
Registered: Feb 2007
Distribution: Kubuntu, it's obese barely-usable sibling, Ubuntu
Posts: 142

Rep: Reputation: 15
First off, I would like to thank you on behalf of everyone here for an exceptional post. If everyone posted like you, well, they'd get alot more help. But anyway, thank you for posting so nicely at this hour

Now, to your question, the command didn't show the expected message the first time either? What does ndiswrapper -l give?
 
Old 11-29-2008, 12:56 AM   #3
kwebbel
LQ Newbie
 
Registered: Nov 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Well, thanks for your kind post! I tried really hard to include all the relevant info, so I'm glad it worked!

Anyway, I tried ndiswrapper -l like you suggested, and I got the following message:

Code:
 # ndiswrapper -l
netr28u : driver installed
So, it says it's installed, but when I proceed with the rest of the tutorial that I linked to in my first post, I can't go any further!

Oh, here's something interesting. When I have the adaptor plugged into my computer, I get a message that says:

Code:
 # ndiswrapper -l
WARNING: /etc/modprobe.conf line 1: ignoring bad line starting with 'install/manage'
WARNING: /etc/modprobe.conf line 3: ignoring bad line starting with 'usage:'
WARNING: /etc/modprobe.conf line 4: ignoring bad line starting with '-i'
WARNING: /etc/modprobe.conf line 5: ignoring bad line starting with '-a'
WARNING: /etc/modprobe.conf line 6: ignoring bad line starting with '-r'
WARNING: /etc/modprobe.conf line 7: ignoring bad line starting with '-l'
WARNING: /etc/modprobe.conf line 8: ignoring bad line starting with '-m'
WARNING: /etc/modprobe.conf line 9: ignoring bad line starting with '-ma'
WARNING: /etc/modprobe.conf line 10: ignoring bad line starting with '-mi'
WARNING: /etc/modprobe.conf line 11: ignoring bad line starting with '-v'
WARNING: /etc/modprobe.conf line 13: ignoring bad line starting with 'where'
WARNING: /etc/modprobe.conf line 14: ignoring bad line starting with 'as'
netr28u : driver installed
	device (07D1:3C13) present
I get the same list of warnings when I type in
Code:
 modprobe ndiswrapper
and when I type
Code:
 dmesg | grep wlan0
nothing happens at all.

What should I do? What should I do?
 
Old 11-29-2008, 01:12 AM   #4
sydney-troz
Member
 
Registered: Feb 2007
Distribution: Kubuntu, it's obese barely-usable sibling, Ubuntu
Posts: 142

Rep: Reputation: 15
Post the contents of /etc/modprobe.conf
 
Old 11-29-2008, 01:15 AM   #5
kwebbel
LQ Newbie
 
Registered: Nov 2008
Posts: 15

Original Poster
Rep: Reputation: 0
It says:

Code:
bash: /etc/modprobe.conf: Permission denied
How do I access it?
 
Old 11-29-2008, 01:42 AM   #6
baig
Member
 
Registered: Nov 2008
Location: وادی ھنزہ
Distribution: Solaris 5.10, Debian Server 5.2, CentOS 5.6
Posts: 226
Blog Entries: 3

Rep: Reputation: 38
you don't have sufficient rights over it.. try viewing it being root.


su -l

cat /etc/xya.conf
 
Old 11-29-2008, 05:24 PM   #7
kwebbel
LQ Newbie
 
Registered: Nov 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Alright, I tried viewing the modprobe.conf file as a superuser, and I got this:

Code:
# cat /etc/modprobe.conf
install/manage Windows drivers for ndiswrapper

usage: ndiswrapper OPTION
-i inffile       install driver described by 'inffile'
-a devid driver  use installed 'driver' for 'devid' (dangerous)
-r driver        remove 'driver'
-l               list installed drivers
-m               write configuration for modprobe
-ma              write module alias configuration for all devices
-mi              write module install configuration for all devices
-v               report version information

where 'devid' is either PCIID or USBID of the form XXXX:XXXX,
as reported by 'lspci -n' or 'lsusb' for the card
Should I use the devid thing to try to use the installed driver for my USB adaptor? I know what the XXXX:XXXX is, I wrote it down.

Incidentally, when I tried accessing xya.conf, I got a message saying it didn't exist...

Code:
# cat /etc/xya.conf
cat: /etc/xya.conf: No such file or directory
 
Old 11-29-2008, 05:29 PM   #8
sydney-troz
Member
 
Registered: Feb 2007
Distribution: Kubuntu, it's obese barely-usable sibling, Ubuntu
Posts: 142

Rep: Reputation: 15
I think "xya.conf" is supposed to be "xyz.conf" (the z and a being so close together), which is meant as a placeholder.

As for modprobe.conf, before you change anything, the reason you were getting errors before is because the text lines ("install/manage Windows drivers for ndiswrapper", etc.) are supposed to be commented out. Put a # before each of them, so the part of the file you posted should look like

Code:
#install/manage Windows drivers for ndiswrapper

#usage: ndiswrapper OPTION
#-i inffile       install driver described by 'inffile'
#-a devid driver  use installed 'driver' for 'devid' (dangerous)
#-r driver        remove 'driver'
#-l               list installed drivers
#-m               write configuration for modprobe
#-ma              write module alias configuration for all devices
#-mi              write module install configuration for all devices
#-v               report version information

#where 'devid' is either PCIID or USBID of the form XXXX:XXXX,
#as reported by 'lspci -n' or 'lsusb' for the card
Try making these changes and running

Code:
modprobe ndiswrapper
again.
 
Old 11-29-2008, 08:49 PM   #9
bapigoo9
Member
 
Registered: Aug 2008
Posts: 107

Rep: Reputation: 16
Quote:
the reason you were getting errors before is because the text lines ("install/manage Windows drivers for ndiswrapper", etc.) are supposed to be commented out.
Exactly! Good idea to make a backup copy of modprobe.conf before editing it next time too!
 
Old 11-30-2008, 12:12 AM   #10
kwebbel
LQ Newbie
 
Registered: Nov 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Hey, I gave it a go and changed the modprobe.conf file. Now I get the following output:

Code:
# cat /etc/modprobe.conf
#install/manage Windows drivers for ndiswrapper

#usage: ndiswrapper OPTION
#-i inffile       install driver described by 'inffile'
#-a devid driver  use installed 'driver' for 'devid' (dangerous)
#-r driver        remove 'driver'
#-l               list installed drivers
#-m               write configuration for modprobe
#-ma              write module alias configuration for all devices
#-mi              write module install configuration for all devices
#-v               report version information

#where 'devid' is either PCIID or USBID of the form XXXX:XXXX,
#as reported by 'lspci -n' or 'lsusb' for the card
But then when I tried

Code:
 modprobe ndiswrapper
again, nothing happened (just like it did in my first post. What should I try now?

And I'll make a backup of the modprobe.conf file, too

Thanks for all your help!
 
Old 12-02-2008, 02:09 AM   #11
kwebbel
LQ Newbie
 
Registered: Nov 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Anyone have an idea?
 
Old 12-02-2008, 09:35 AM   #12
sydney-troz
Member
 
Registered: Feb 2007
Distribution: Kubuntu, it's obese barely-usable sibling, Ubuntu
Posts: 142

Rep: Reputation: 15
Run
Code:
lsmod | grep ndis
Does that give anything? If so, ndiswrapper is already loaded. Then, run
Code:
ndiswrapper -l
 
Old 12-03-2008, 11:18 PM   #13
kwebbel
LQ Newbie
 
Registered: Nov 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Hey,

Sorry it's taken me a while, but I went ahead and tried that, and this is what I got.

Code:
# lsmod | grep ndis
ndiswrapper           154772  0
So, with everything in order, I continued with
Code:
 ndiswrapper -l
And I got the same message I got before:

Code:
ndiswrapper -l
netr28u : driver installed
	device (07D1:3C13) present
So I continued with the steps in the tutorial I linked to in my first post, and tried

Code:
modprobe ndiswrapper
And again, nothing happened. What should I try now?
 
Old 12-03-2008, 11:37 PM   #14
sydney-troz
Member
 
Registered: Feb 2007
Distribution: Kubuntu, it's obese barely-usable sibling, Ubuntu
Posts: 142

Rep: Reputation: 15
It looks like everything should be ready to connect -- does your network manager not see any networks? Stupid question, but are you sure you're in the range of a network and that the SSID isn't hidden (stealth mode)?
 
Old 12-04-2008, 09:40 PM   #15
kwebbel
LQ Newbie
 
Registered: Nov 2008
Posts: 15

Original Poster
Rep: Reputation: 0
My network manager doesn't give me anything. I know for sure that I'm within range (the router is 20 feet away, and it's on, and my iPod can connect to the network no problem).

Any ideas? Has anyone had a similar problem with ndiswrapper?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"Linux supported wireless card driver for Linksys wireless-g adaptor? northcoastrat Linux - Desktop 4 07-18-2008 07:33 PM
Best wireless pci adaptor without ndiswrapper? joost2000 Linux - Wireless Networking 4 01-09-2007 04:53 PM
NDISWrapper Installation Issues with Belkin F5D6050 Wireless Adaptor and Fedora 5 Welsh Pablo Linux - Wireless Networking 1 09-10-2006 04:00 PM
NDISWrapper Installation Issues with Belkin F5D6050 Wireless Adaptor and Fedora 5 Welsh Pablo Linux - Wireless Networking 3 09-10-2006 02:23 PM
Driver for wireless adaptor Robin2 SUSE / openSUSE 2 02-24-2005 03:41 PM


All times are GMT -5. The time now is 06:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration