LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-08-2005, 01:09 AM   #1
joel b
Member
 
Registered: May 2004
Posts: 64

Rep: Reputation: 15
NAT error - how do I know what ports to use?


I have Suse 9.3 - I installed Azureus - and I get a NAT error for the default port - I think it is 6881.

Can someone tell me how I find out which port to use for my equipment? I really don't understand this concept, I have a cale modem D-Link DCM-202 if that means anything.
 
Old 05-08-2005, 01:31 AM   #2
Tino27
Member
 
Registered: Aug 2003
Location: Akron, OH
Distribution: SuSE 8.2, Slackware current, OpenBSD 3.5-3.8, Fedora Core 2
Posts: 400

Rep: Reputation: 30
This link may help you set up the configuration.

http://www.portforward.com/cportsnot.../azureus22.htm

As for a firewall, if you are running a firewall on your computer (iptables), then whichever port you use for Azureus, you will need to make sure you open up for traffic. Not being familiar with the D-Link modem in question, I don't know if it also provides for port forwarding between the outside world (the Internet) and the inside world.
 
Old 05-12-2005, 09:44 PM   #3
slacker9876
Member
 
Registered: Apr 2004
Location: Colorado
Distribution: Ubuntu 6.10, SLED 10
Posts: 119

Rep: Reputation: 15
Quote:
Originally posted by Tino27
This link may help you set up the configuration.

http://www.portforward.com/cportsnot.../azureus22.htm

As for a firewall, if you are running a firewall on your computer (iptables), then whichever port you use for Azureus, you will need to make sure you open up for traffic. Not being familiar with the D-Link modem in question, I don't know if it also provides for port forwarding between the outside world (the Internet) and the inside world.
I have a netgear router and added 6881, 6969 & 7000 to forward to may local PC. I still cannot get bittorrent running using Azures. So i am thinking I need to open the Suse firewall to these ports. I used yast and I get squat lol ... am I able to edit iptables directly to allow for this?
 
Old 05-12-2005, 09:52 PM   #4
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
yast->security&users->firewall->allowed services->external zone->advanced->additional allowed ports. 6881 in the tcp and udp boxes?

Last edited by rshaw; 05-12-2005 at 09:54 PM.
 
Old 05-12-2005, 10:01 PM   #5
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
set the incoming listen port in azureus 'options' to 6881 and bind it to the local ip?
 
Old 05-13-2005, 08:33 AM   #6
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Rep: Reputation: 45
I have this problem too, i set my crappy SMC barricade router into DMC and still get a NAT error in azureus, i use guarddog which is a GUI firewal lthat deals with IPtables and things, blocking by application, i've disabled it but stil lgot a NAT error, not sure if it's fudged something, haven't tried binding to local IP.

Even with Nat errors i still get connections tp other peers/seeds

Howevere it's a moot point as Azureus now doesn't start and spits out errors (there'll be a new post to get some help with this :P)
 
Old 05-14-2005, 09:09 AM   #7
slacker9876
Member
 
Registered: Apr 2004
Location: Colorado
Distribution: Ubuntu 6.10, SLED 10
Posts: 119

Rep: Reputation: 15
Quote:
Originally posted by rshaw
yast->security&users->firewall->allowed services->external zone->advanced->additional allowed ports. 6881 in the tcp and udp boxes?
That did the trick, I did not have anything list in the UDP ports, only under TCP.The question now is what do I use as a separation character if I want to add more ports under there? Thanks!
 
Old 05-14-2005, 09:30 AM   #8
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
single ports are just space separated,(6881 6882, etc) ranges don't seem to work from the firewall setup screen, try yast->system->sysconfig_editor->network->firewall->susefirewall->FW_SERVICES_EXT_TCP. and enter ranges with the ' : ' eg. 6881:6889 , etc.



Last edited by rshaw; 05-14-2005 at 09:43 AM.
 
Old 05-30-2005, 12:12 PM   #9
Alessandro
Member
 
Registered: Dec 2003
Location: Italy
Distribution: Debian, Slackware
Posts: 116

Rep: Reputation: 15
Quote:
Originally posted by rshaw
single ports are just space separated,(6881 6882, etc) ranges don't seem to work from the firewall setup screen, try yast->system->sysconfig_editor->network->firewall->susefirewall->FW_SERVICES_EXT_TCP. and enter ranges with the ' : ' eg. 6881:6889 , etc.
That syntax doesn't seem to work with SUSE 9.3
It had always worked until 9.2.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Testing port 6881....NAT Error - error in Azureus dr_zayus69 Linux - Security 20 05-26-2006 02:52 PM
Azureus and NAT error :( Peleus Linux - Software 1 11-08-2005 08:53 AM
Azureus NAT Error... deac0ncho Mandriva 5 10-02-2005 05:11 AM
Nat error - azureus ceborame Linux - Newbie 1 09-03-2005 11:24 AM
NAT forwarding FTP ports Ossar Linux - Networking 4 03-14-2005 01:07 PM


All times are GMT -5. The time now is 08:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration