LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-29-2006, 02:55 AM   #1
a2vr6
Member
 
Registered: Aug 2006
Posts: 46

Rep: Reputation: 15
named service won't start?


For some reason named service will not start for me. I had a look at the logs and found the following

named[5604]: loading configuration from '/etc/named.conf'
named[5604]: no IPv6 interfaces found
named[5604]: listening on IPv4 interface lo, 127.0.0.1#53
named[5604]: listening on IPv4 interface bond0, 66.203.200.153#53
named[5604]: listening on IPv4 interface eth1, 10.5.45.192#53
named[5604]: listening on IPv4 interface eth2, 10.5.32.67#53
named[5604]: command channel listening on 127.0.0.1#953
named[5604]: logging channel 'default_debug' file 'named.run': permission denied
named[5604]: couldn't open pid file 'named.pid': Permission denied
named[5604]: isc_log_open 'named.run' failed: permission denied
named[5604]: exiting (due to early fatal error)
named: named startup succeeded

Although it says that it succeeded, the service does not run. I confirmed that named has w/r/x on the folder in /var/run/named. This issue occured after a reboot of the server. Any ideas? Thanks.
 
Old 08-29-2006, 07:51 AM   #2
olaola
Member
 
Registered: Aug 2006
Location: Italy
Distribution: Fedora
Posts: 41

Rep: Reputation: 15
checkout permissions of the 'named.run' file
 
Old 08-29-2006, 07:58 AM   #3
a2vr6
Member
 
Registered: Aug 2006
Posts: 46

Original Poster
Rep: Reputation: 15
Here they are. Should I change them?

-rw-r--r-- 1 root root 2104 Apr 27 02:16 /root/named.run


-rw-r--r-- 1 root root 668239 Aug 29 07:18 /etc/named.data/named.run
 
Old 08-29-2006, 08:11 AM   #4
olaola
Member
 
Registered: Aug 2006
Location: Italy
Distribution: Fedora
Posts: 41

Rep: Reputation: 15
probably they have to be executables

Code:
chmod u+x named.run
as root..

what about 'named.pid'. Which are his permessions?
 
Old 08-29-2006, 09:00 AM   #5
a2vr6
Member
 
Registered: Aug 2006
Posts: 46

Original Poster
Rep: Reputation: 15
Here is the info for named.pid


-rw-r--r-- 1 root root 6 Aug 29 07:18 /etc/named.data/named.pid
 
Old 08-29-2006, 09:03 AM   #6
olaola
Member
 
Registered: Aug 2006
Location: Italy
Distribution: Fedora
Posts: 41

Rep: Reputation: 15
but, are you running this as root?
 
Old 08-29-2006, 09:06 AM   #7
a2vr6
Member
 
Registered: Aug 2006
Posts: 46

Original Poster
Rep: Reputation: 15
Yes it is run as root.
 
Old 08-29-2006, 09:11 AM   #8
olaola
Member
 
Registered: Aug 2006
Location: Italy
Distribution: Fedora
Posts: 41

Rep: Reputation: 15
have you made 'named.run' executable?
 
Old 09-03-2006, 11:00 PM   #9
a2vr6
Member
 
Registered: Aug 2006
Posts: 46

Original Poster
Rep: Reputation: 15
I make the file executable but it did not work so I changed group to named and restarted the service again. I ended up getting the exact same messages in the log file but the service started anyway? Any idea what the heck happened?lol
 
Old 09-04-2006, 12:31 AM   #10
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Curious ... what distro are you using, is the install a package of the distro
or did you install manually?


Cheers,
Tink
 
Old 09-04-2006, 04:20 AM   #11
broadcast
LQ Newbie
 
Registered: Aug 2006
Posts: 11

Rep: Reputation: 0
a2vr6,
this may be caused by the Linux enhanced security
if you are running RedHat or Fedora core issue the following command and try to strat named
Code:
# setenforce 0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NAMED Service Not Stopping dsschanze Linux - Networking 3 08-06-2007 05:03 AM
service named stop does not work sailu_mvn Linux - Software 3 12-29-2005 12:09 AM
Named service won't start DanielTan Fedora - Installation 2 09-28-2005 12:54 PM
named service pazvant Linux - Networking 2 10-28-2003 11:45 AM
service named can't stop... TAAN Linux - Networking 1 09-11-2003 03:43 AM


All times are GMT -5. The time now is 03:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration