LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-23-2006, 03:08 PM   #1
TruthSeeker
LQ Newbie
 
Registered: Oct 2005
Location: Cartaxo, Portugal
Distribution: Red Hat Enterprise 4 Mostly
Posts: 25

Rep: Reputation: 15
named / BIND won't start


i'm not sure why, named (bind) won't start in anyway, already even tried to reset the .conf more or less to default. it's probably some more advanced problem since everything was fine in server till last night and it simply stopped without no one touching it, can't restart in ssh bash, cpanel won't restart it either

i've just posted this here cause im a bit newb and i dont know how to debug this, like startup logs / error messages etc.

where can i find this info? :/

details:

apache is up and runnin, can access ftp and http (ip only) i tried up2date named but up2date won't work either.

-----

root@scorpion [~]# up2date -l
Error communicating with server. The message was:
Temporary failure in name resolution
root@scorpion [~]# dig linuxquestions.org

; <<>> DiG 9.2.4 <<>> linuxquestions.org
;; global options: printcmd
;; connection timed out; no servers could be reached

-----

The server is rde i believe
 
Old 07-23-2006, 03:29 PM   #2
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
Take a look at /var/log/messages. If BIND won't start, it usually explains why in the log. If you are running SELinux, make sure your policy (heck, your whole system)is up to date.
 
Old 07-23-2006, 03:46 PM   #3
TruthSeeker
LQ Newbie
 
Registered: Oct 2005
Location: Cartaxo, Portugal
Distribution: Red Hat Enterprise 4 Mostly
Posts: 25

Original Poster
Rep: Reputation: 15
Jul 23 21:43:58 scorpion named[3834]: starting BIND 9.2.4 -u named
Jul 23 21:43:58 scorpion named[3834]: using 1 CPU
Jul 23 21:43:58 scorpion named[3834]: loading configuration: failure
Jul 23 21:43:58 scorpion named[3834]: exiting (due to fatal error)
Jul 23 21:43:58 scorpion named: named startup failed

ok now i know,
/etc/named.conf ?
in there a named.conf.default ?

tanx in advance ^^

ps: got cpanel on machine (i heard cpanel is mean to the system sometimes)
 
Old 07-23-2006, 04:04 PM   #4
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
Try it with 'setenforce 0' (as root) to temporarily disable SELinux. If that works, then you can re-enable SELinux with 'setenforce 1', and update your policy with:

yum -y update selinux-policy-targeted

Otherwise, post your /etc/named.conf (which should be the same as your /var/named/chroot/etc/named.conf).
 
Old 07-23-2006, 04:41 PM   #5
TruthSeeker
LQ Newbie
 
Registered: Oct 2005
Location: Cartaxo, Portugal
Distribution: Red Hat Enterprise 4 Mostly
Posts: 25

Original Poster
Rep: Reputation: 15
please elaborate 'setenforce 0' where do i set it?
a bash command? no.
a setting somewhere? a var?
im sorry, kinda newb in bash/linux commands / properties
i really still only use windows like linux and some
real basic commands, so on ssh to server, im still a baby ^^

ps: yum is not installed :/ , tough i could install it (try) oO
 
Old 07-24-2006, 08:40 AM   #6
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
The setenforce command is a root command on Fedora. It is issued at the command line in a root terminal. To get a root terminal, open a terminal window and issue the command:

su - root

The space-dash-space is an important option that causes the root session to use the proper environment, including the path to the system commands, like setenforce.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
bind and named Red Squirrel Linux - Software 3 04-25-2004 09:49 PM
BIND problem... named will not even start. SniperDevil Linux - Networking 4 01-13-2004 04:43 PM
BIND / named r3ekon Linux - Newbie 6 10-16-2003 05:33 PM
Bind / named 80s Linux - Networking 3 03-20-2003 07:47 AM
How to Start Named - DNS Bind on boot-up. 360 Linux - Networking 0 05-26-2002 08:52 PM


All times are GMT -5. The time now is 01:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration