LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-27-2013, 06:41 PM   #1
tvball
LQ Newbie
 
Registered: Nov 2013
Posts: 2

Rep: Reputation: Disabled
nagios3 core on ubuntu


I have configured a nagios3 core server on Ubuntu. have it running, monitoring and sending alerts correctly. I am using Spiceworks as my helpdesk software. when my nagios server sends an alert about a device problem it has detected, it sends the email to my helpdesk@domain.com and Spiceworks sees it just fine and the helpdesk ticket is created. here is the problem. the email is coming from nagios@localhost and Spiceworks sends a reply with helpdesk ticket information to this address. this is not a valid email address in my domain so it bounces. how do I set the reply to email address in nagios on the Ubuntu server. I want the reply email address to be another admin email address I use to capture these kind of emails. nothing on nagios seems to address this issue. is this a Linux setting? any help would be appreciated.

Last edited by tvball; 11-27-2013 at 06:42 PM.
 
Old 11-28-2013, 12:48 AM   #2
kapilbajpai88
Member
 
Registered: Jul 2008
Location: Bangalore, India
Distribution: RHEL
Posts: 235

Rep: Reputation: 41
Hi,

The configuration file we have in our installation of Nagios3 is /etc/nagios3/conf.d/contacts_nagios2.cfg. The email parameter in this file is responsible for email alerts.
Check this info and let us know if this solves the purpose.
 
Old 11-28-2013, 10:46 AM   #3
tvball
LQ Newbie
 
Registered: Nov 2013
Posts: 2

Original Poster
Rep: Reputation: Disabled
I figured it out. Indeed the contacts config in the conf.d folder is for configuring the to email address. All that is working. However sendmail sends that email with the nagios@domain as the reply address. I went into the commands.cfg file in /etc/nagios3 and had to add this to end of line for the printf commands; -- -f emailadress
turns out this is a sendmail option that can be used to specify the reply to email address. the -- specifies additional sendmail options and from what I can find, the -f stands for from email address, not sure what the -f really stands for, maybe one of our Linux Guru's on here knows the correct term. What I also found is that nagios does not seem to have an instant check feature. Once you make the change, restart nagios3 daemon, you have to give nagios time process the alerts and send the emails. now it comes from nagios@domain, but the reply email address is my normal admin email address I use to capture these kind of emails.

Thanks for the post!
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Nagios3 / Ubuntu Server 11 - Another no email thread catchacold Linux - Server 7 11-05-2011 11:33 AM
Nagios3 Ubuntu1104 wmd12string Ubuntu 2 08-11-2011 08:42 AM
Map problem in Nagios3.2.0 shan_nathan Linux - Software 2 02-16-2010 02:36 AM
Nagios3 package incomplete in Lenny? Akhran Debian 4 02-11-2010 04:38 PM
[Nagios3] Check-SNMP not defined Akhran Debian 1 07-01-2008 03:23 AM


All times are GMT -5. The time now is 02:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration