LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-25-2011, 09:10 AM   #16
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295

Hi,

If there's a nagios.conf file in /etc/httpd/conf.d, then my next question would be: Did you restart Apache (httpd) after installing and configuring Nagios? Post the contents of the nagios.conf file too please.

Kind regards,

Eric
 
Old 05-25-2011, 09:14 AM   #17
Shahnawaz Uqaili
Member
 
Registered: May 2011
Location: Karachi, Sindh Pakistan
Distribution: RHEL, CentOS, Debian/Ubuntu, Microsoft Windows
Posts: 46

Original Poster
Rep: Reputation: Disabled
Dear Eric
I restarted apache. and these are contents of /etc/httpd/conf.d

ScriptAlias /nagios/cgi-bin "/usr/lib/nagios/cgi"

<Directory "/usr/lib/nagios/cgi">
# SSLRequireSSL
Options ExecCGI
AllowOverride None
Order allow,deny
Allow from all
# Order deny,allow
# Deny from all
# Allow from 127.0.0.1
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /etc/nagios/htpasswd.users
Require valid-user
</Directory>

Alias /nagios "/usr/share/nagios"

<Directory "/usr/share/nagios">
# SSLRequireSSL
Options None
AllowOverride None
Order allow,deny
Allow from all
# Order deny,allow
# Deny from all
# Allow from 127.0.0.1
AuthName "Nagios Access"
AuthType Basic
AuthUserFile /etc/nagios/htpasswd.users
Require valid-user
</Directory>
 
Old 05-25-2011, 09:22 AM   #18
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

Are those directories pointing to the ones you installed Nagios into? Check if Nagios is installed in those directories. If not, then change the nagios.conf file to reflect the correct path(s).

Kind regards,

Eric
 
Old 05-25-2011, 09:27 AM   #19
Shahnawaz Uqaili
Member
 
Registered: May 2011
Location: Karachi, Sindh Pakistan
Distribution: RHEL, CentOS, Debian/Ubuntu, Microsoft Windows
Posts: 46

Original Poster
Rep: Reputation: Disabled
Dear Eric
These Directives are pointed to the Nagios by default, I didn't make any change in them and these directives have Nagios installed. But still i'm getting same error. please check if there is any other thing i'm missing.
Regards
Shahnawaz
 
Old 05-25-2011, 09:32 AM   #20
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

Did you create the htpasswd file with the username and password in the directory indicated in the nagios.conf file and with the same name?

Kind regards,

Eric
 
Old 05-25-2011, 09:36 AM   #21
Shahnawaz Uqaili
Member
 
Registered: May 2011
Location: Karachi, Sindh Pakistan
Distribution: RHEL, CentOS, Debian/Ubuntu, Microsoft Windows
Posts: 46

Original Poster
Rep: Reputation: Disabled
I made that command by this
htpasswd -c /etc/nagios/htpasswd.users nagiosadmin
 
Old 05-25-2011, 09:58 AM   #22
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi,

Apparently you've set everything up correct. Since you get a popup asking you for username and password your webserver is running and not blocked by IPTABLES. Are you sure about the username and password you give to access Nagios, typos, capital letters and so on?

Kind regards,

Eric

Last edited by EricTRA; 05-25-2011 at 10:01 AM.
 
Old 05-25-2011, 10:27 AM   #23
Shahnawaz Uqaili
Member
 
Registered: May 2011
Location: Karachi, Sindh Pakistan
Distribution: RHEL, CentOS, Debian/Ubuntu, Microsoft Windows
Posts: 46

Original Poster
Rep: Reputation: Disabled
yes user name and password were correct. Someone told me that you don't have DocumentRoot set for Nagios or how am i telling browser to open nagios, www.myserver.com/nagios.
I'm totally confused and my mind is now blocked in all this. please help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Nagios Error!!! anishkumarv Linux - Server 3 04-19-2011 05:45 AM
nagios error Rahul Kolan Linux - Software 1 11-13-2009 04:08 AM
Error when access Nagios! son_th02 Linux - Newbie 12 03-04-2009 05:21 AM
Nagios Login Error sbhupati Linux - Software 8 06-01-2006 07:21 PM
nagios error messages kenji1903 Linux - Networking 9 08-21-2004 06:07 AM


All times are GMT -5. The time now is 05:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration