LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-18-2004, 04:07 PM   #1
Jek
LQ Newbie
 
Registered: Feb 2004
Posts: 18

Rep: Reputation: 0
n00b apachi question


Hi guy's,

I have just setup my first webserver using Fedora core2, Love it.

It's all working perfectly on the out side.. My problem is I have a Netgear DG834 router/firewall and when I access my redirected subdomain from home (internal IP) I always get the router admin login screen. Does anyone have any idea how I could get around this ?
 
Old 11-18-2004, 04:19 PM   #2
linux_terror
Member
 
Registered: Aug 2004
Location: Northbrook, Illinois
Distribution: CentOS-5
Posts: 311

Rep: Reputation: 30
If its possible in your router, switch the port that the admin interface is served up on.....right now its 80, switch it to 81 or whatever. Then you would have to go to http://192.168.1.1:81 to access your routers configuration assuming that your routers ip is192.168.1.1, and your websites would serve up fine from the interior network.
Hope this helps,
linux_terror
 
Old 11-18-2004, 04:27 PM   #3
Jek
LQ Newbie
 
Registered: Feb 2004
Posts: 18

Original Poster
Rep: Reputation: 0
Thank's for the fast reply.. I though of this first up, but can't seem to find an option to change the admin port anywhere in the router.
 
Old 11-18-2004, 05:44 PM   #4
linux_terror
Member
 
Registered: Aug 2004
Location: Northbrook, Illinois
Distribution: CentOS-5
Posts: 311

Rep: Reputation: 30
Configuring Remote Management
1.
Log in to the router at its default LAN address of http://192.168.0.1 with its default User Name
of admin, default password of password, or using whatever User Name, Password and LAN
address you have chosen for the router.
2.
From the Advanced section of the main menu, select the Remote Management link.
3.
Select the Turn Remote Management On check box.
4.
Specify what external addresses will be allowed to access the routerís remote management.
For security, restrict access to as few external IP addresses as practical.
a.
To allow access from any IP address on the Internet, select Everyone.
b.
To allow access from a range of IP addresses on the Internet, select IP address range.
Enter a beginning and ending IP address to define the allowed range.
c.
To allow access from a single IP address on the Internet, select Only this Computer.
Enter the IP address that will be allowed access.
5.
Specify the Port Number that will be used for accessing the management interface.
Web browser access normally uses the standard HTTP service port 80. For greater security,
you can change the remote management Web interface to a custom port by entering that
number in the box provided. Choose a number between 1024 and 65535, but do not use the
number of any common service port. The default is 8080, which is a common alternate for
HTTP.
6.
Click Apply to have your changes take effect.
When accessing your router from the Internet, you will type your router's WAN IP address in
your browser's Address (in IE) or Location (in Netscape) box, followed by a colon ( and the
custom port number. For example, if your external address is 134.177.0.123 and you use port
number 8080, enter in your browser:
http://134.177.0.123:8080
Note: In this case, the http:// must be included in the address

taken from http://64.233.167.104/search?q=cache...+port&hl=en#73

I googled it a bunch for ya, this is the best option I could find, not sure if this will still make it pop up on the intranet though, A cheesy workaround would be to use a proxy outside of your lan and in effect loop back to it, There is a huge list of free proxies at http://samair.ru/proxy

Hope this helps, what a pain in the @$$ lol
linux_terror

Last edited by linux_terror; 11-18-2004 at 05:45 PM.
 
Old 11-19-2004, 01:47 AM   #5
Jek
LQ Newbie
 
Registered: Feb 2004
Posts: 18

Original Poster
Rep: Reputation: 0
WOW.. Thanks for that I hope you didn't go to the trouble of typing it all.. Just so you know I'm not a complete n00b, I'm in tech support for a living.. Just new to Linux.

I have configured my routers remote access to an obscure port and it works perfectly on the WAN. problem is when I am @ home my router doesn't see me as an external body.. There for sends me directly to the router admin (This seems to be hard coded to :80).. Could I setup a 2nd 'Virtual web server' and bind a DNS name to an internal 192.168.0.0 IP ?!?!?

The external proxy works.. But DAAAAAAAAAMMMNNN It's hella slow.

Last edited by Jek; 11-19-2004 at 02:11 AM.
 
Old 11-19-2004, 03:20 AM   #6
linux_terror
Member
 
Registered: Aug 2004
Location: Northbrook, Illinois
Distribution: CentOS-5
Posts: 311

Rep: Reputation: 30
You'll probably end up hitting your router still, what happens if you go to your WAN ip address? Like http://74.21.58.123 or whatever(thats a fictitional addy but you know what i mean), and what happens when you go to the local LAN addy ie- http://192.168.0.4 do you still get your routers admin both ways? If so then I might suggest running a local proxy, most linux distros come with squid, and if you surf through the local proxy it 'should' work as the proxy will already be on the server and will just serve the site to you. Another option if you can get past the router using the WAN ip is to just run a local named(bind or whichever you like), and point your computer at the local nameserver for dns(obviously you would have to make a dns record for the domain with either the LAN or WAN ip, whichever works). I have a router that also has the admin on port 80 but i dont have your problem probably because I host my own DNS which really, you should do anyway. This post is kind of convoluded but just decide what avenue you want to take and post again, if you need any clarification or help, post again, I'll check back.

Hope this helps.
linux_terror

p.s.---I copied and pasted the tutuorial in my last post, so no typing was necessary cusoon

Last edited by linux_terror; 11-19-2004 at 03:22 AM.
 
Old 11-19-2004, 03:45 AM   #7
Jek
LQ Newbie
 
Registered: Feb 2004
Posts: 18

Original Poster
Rep: Reputation: 0
Again thanks for your time.

I have a domain name of my own www.jeknet.com and I am running a subdomain to my WAN IP http://home.jeknet.com. So, to answer your question - Yes, I still get the router login whe I got to my WAN IP (or home.jeknet.com) from my internal PC.

I think I might look into hosting my own DNS on my fedora box if it will help. (If I can work it out)
 
Old 11-19-2004, 03:52 AM   #8
linux_terror
Member
 
Registered: Aug 2004
Location: Northbrook, Illinois
Distribution: CentOS-5
Posts: 311

Rep: Reputation: 30
what do u get on the local ip?

nice default mambo site btw... :P
 
Old 11-19-2004, 03:57 AM   #9
Jek
LQ Newbie
 
Registered: Feb 2004
Posts: 18

Original Poster
Rep: Reputation: 0
On the internal IP and on the server name I get the page as it should be. and as it is on the WAN. The problem I have with this though is I'm setting up a MAMBO CMS for my 'other half' and I get no images displayed when viewing the site @ http://192.168.0.200..

The fedora server is on 0.200 the router is 0.1.

Last edited by Jek; 11-19-2004 at 03:59 AM.
 
Old 11-19-2004, 04:03 AM   #10
linux_terror
Member
 
Registered: Aug 2004
Location: Northbrook, Illinois
Distribution: CentOS-5
Posts: 311

Rep: Reputation: 30
the reason you see no images is because of the $MOS_CONFIG_LIVE_SITE variable in mambo, its set to the dns name, if you can see the site on the local ip I would suggest setting up a local nameserver that has a dns record pointing the domain to the local ip, and setting the local named as first in your dns search order on the workstation, this way http://home.jeknet.com/ will resolve to the local ip as a name and it 'should' solve the $MOS_CONFIG_LIVE_SITE issue as well.

linux_terror
 
Old 11-19-2004, 04:06 AM   #11
Jek
LQ Newbie
 
Registered: Feb 2004
Posts: 18

Original Poster
Rep: Reputation: 0
Awesome... Will get it setup ASAP. Thanks again for your time, much apreciated.
 
Old 11-19-2004, 04:12 AM   #12
linux_terror
Member
 
Registered: Aug 2004
Location: Northbrook, Illinois
Distribution: CentOS-5
Posts: 311

Rep: Reputation: 30
No problem, if you have questions on setting up named post again and I can help you out. Good luck to ya.

linux_terror
 
Old 11-19-2004, 04:24 AM   #13
Jek
LQ Newbie
 
Registered: Feb 2004
Posts: 18

Original Poster
Rep: Reputation: 0
You read my mind.. I was just about to ask if you knew of a good guide to setting up a fedora DNS server.
 
Old 11-19-2004, 05:06 AM   #14
linux_terror
Member
 
Registered: Aug 2004
Location: Northbrook, Illinois
Distribution: CentOS-5
Posts: 311

Rep: Reputation: 30
It should be fairly simple, I don't run fedora. Install the Bind package. open /etc/named.conf if this is where fedora keeps it, if its not there do

updatedb
locate named.conf

add something like
Code:
zone "home.jeknet.com" {
        type master;
        file "/var/named/home.jeknet.com.hosts";
        };
this points it to a record called /var/named/home.jeknet.com.hosts

then
Code:
cd /var/named/
touch home.jeknet.com.hosts
open the file home.jeknet.com.hosts in a text editor and add
Code:
$ttl 38400
home.jeknet.com.      IN      SOA     ns.home.jeknet.com. webmaster.jeknet.com. (
                        1092506603
                        3700
                        3600
                        604800
                        38400 )
home.jeknet.com.      IN      NS      ns.home.jeknet.com.
home.jeknet.com.      IN      A       192.168.0.200
ns.home.jeknet.com.   IN      A       192.168.0.200
save the file,

start named
Code:
/etc/init.d/named start
if it complains that named is already running
Code:
/etc/init.d/named reload
If you are running a firewall on the server open port 53 udp
on the workstation set 192.168.0.200 as your primary nameserver

chabling chablam chaboom it should all work now. If it doesn't try clearing the cache on your browser.

If by some chance it still doesnt work it might be because bind is chrooted, its an ez fix, the paths specified in the config just need to be relative to the chroot. Post if you can't figure it out.


linux_terror

Last edited by linux_terror; 11-19-2004 at 05:09 AM.
 
Old 11-19-2004, 05:53 AM   #15
Jek
LQ Newbie
 
Registered: Feb 2004
Posts: 18

Original Poster
Rep: Reputation: 0
WOW.. Thanks man.

Questions.org ROCKS!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
n00b question FD_Doc Linux - Newbie 5 11-20-2005 06:09 PM
N00b question Bendert_katier Linux - Software 7 11-01-2004 02:06 AM
ok n00b question of all time The_Drifter Linux - Newbie 10 05-03-2004 03:46 PM
just another n00b question BriceM LinuxQuestions.org Member Intro 2 08-23-2003 10:00 PM
n00b Question sandy_obrien Linux - General 6 08-18-2003 01:19 PM


All times are GMT -5. The time now is 10:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration