LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   MySQL: Un/Install? Status of current installation unknown (http://www.linuxquestions.org/questions/linux-newbie-8/mysql-un-install-status-of-current-installation-unknown-428152/)

Jalalabee 03-24-2006 05:11 PM

MySQL: Un/Install? Status of current installation unknown
 
I am running slackware 10.2 with kernel version 2.6.16.

I have installed XAMPP installed.

PHP and I thought MySQL are/were also installed.

When running ./configure I recieve the messege:


root@luffy:~/temp/mysql-standard-5.0.19-linux-i686-glibc23# Starting mysqld daemon with databases from /root/temp/mysql-standard-5.0.19-linux-i686-glibc23/data

STOPPING server from pid file /root/temp/mysql-standard-5.0.19-linux-i686-glibc23/data/luffy.pid
060324 06:53:44 mysqld ended

Any questions or ideas?

RobertP 03-24-2006 06:33 PM

Why are you running ./configure?

If you installed XAMPP, you should be good. Did you follow the XAMPP instructions?

http://www.apachefriends.org/en/xampp-linux.html#377

Jalalabee 03-25-2006 02:03 PM

Because MySQL has to be installed, doesn't it?

Does XAMPP contain it's own copies of these programs?

Jalalabee 03-25-2006 02:05 PM

How do I check if MySQL is running correctly?

RobertP 03-25-2006 06:09 PM

ps aux|grep mysql

will show processes.
nmap localhost
will check ports

mysql -u root -p mysql
will let you attempt to login t othe mysql server.

Jalalabee 03-25-2006 06:18 PM

Quote:

root@luffy:~/temp ps aux|grep mysql
root 3661 0.0 0.2 2476 1332 ? S 03:47 0:00 /bin/sh /opt/lampp/bin/mysqld_safe --datadir=/opt/lampp/var/mysql --pid-file=/opt/lampp/var/mysql/luffy.pid
nobody 3696 0.0 1.0 26264 5208 ? Sl 03:47 0:00 /opt/lampp/sbin/mysqld --basedir=/opt/lampp --datadir=/opt/lampp/var/mysql --user=nobody --pid-file=/opt/lampp/var/mysql/luffy.pid --skip-locking --port=3306 --socket=/opt/lampp/var/mysql/mysql.sock
root 7058 0.0 0.1 1764 584 pts/0 R+ 07:55 0:00 grep mysql
root@luffy:~/temp nmap localhost

Starting nmap 3.93 ( http://www.insecure.org/nmap/ ) at 2006-03-25 07:56 PST
Interesting ports on localhost (127.0.0.1):
(The 1655 ports scanned but not shown below are in state: closed)
PORT STATE SERVICE
21/tcp open ftp
22/tcp open ssh
25/tcp open smtp
37/tcp open time
53/tcp open domain
80/tcp open http
111/tcp open rpcbind
113/tcp open auth
139/tcp open netbios-ssn
445/tcp open microsoft-ds
587/tcp open submission
953/tcp open rndc
3306/tcp open mysql

Nmap finished: 1 IP address (1 host up) scanned in 0.470 seconds
root@luffy:~/temp mysql -u root -p mysql
bash: mysql: command not found
Was it correct to just type mysql -u root -p mysql?

I have mysql-standard-5.0.19-linux-i686-glibc23.

Does that mean it might not be correctly installed?


All times are GMT -5. The time now is 07:35 PM.