LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-18-2005, 09:44 PM   #1
khuti2005
LQ Newbie
 
Registered: Oct 2005
Distribution: Fedora Core 2 - Gnome
Posts: 9

Rep: Reputation: 0
mysql-php-apache problems..


hi, ok heres the thing, i installed fedora 2 as webserver with the extra bits for mysql php and apache.. anywho i did it the other day n forgot to add mysql.. but i started the service httpd and typed in localhost on a browser, which worked.. then tested it out with a basic php page. which also worked.. but now.. ive re-installed it with the xtras for mysql.. when i type localhost the default page comes up ok like before.. but as soon as i put in an index page of my own i get, FORBIDDEN you do not have permission etc..

so can anybody help me sort this? im not understandin as for 1.. im signed is as root user! 2 ive set up my basic account to have the user groups of apache. and still neither work. i would really appreciate sum help gettin this set up as i would like to get to work with my coding. so far ive wasted 32 hours approx tryin to set it all up, n im started to lose my cool. so if any1 came help me id reaaaaaaaally appreciate it.

thanks..

khuti
 
Old 10-19-2005, 10:08 AM   #2
socrates71
LQ Newbie
 
Registered: Aug 2005
Location: Deux Sevres, France
Distribution: Ubuntu, Gentoo, Solaris
Posts: 11

Rep: Reputation: 0
Sounds like you are uploading a new default with incorrect permissions, probably permission for root. Try changing the owner to apache or nobody, or if that fails try chmod 777 index.html. This should rule out any permission probs...

also, ls -al in the web-root folder and check owners and groups are accessible...
 
Old 10-19-2005, 01:33 PM   #3
khuti2005
LQ Newbie
 
Registered: Oct 2005
Distribution: Fedora Core 2 - Gnome
Posts: 9

Original Poster
Rep: Reputation: 0
hey thanks, it works now

but i have another problem lol.. i did a test page with the phpinfo() function which works fine..and mysql has been installed with it properly. ive set up a database n table with data for a test, but when i create the .php page it doesnt show anything. it doesnt come up with a weird error either. do u no what this could b n how i could solve it?.. once i get these to workin together ill b a happy bunny!

khuti
 
Old 10-20-2005, 08:33 AM   #4
socrates71
LQ Newbie
 
Registered: Aug 2005
Location: Deux Sevres, France
Distribution: Ubuntu, Gentoo, Solaris
Posts: 11

Rep: Reputation: 0
in your php.ini enable all the error functions and try the page again. this should hopefully print out an error message if there is actually an error. alternatively, once you get your blank page, try viewing the source and see what is there, that may help narrow things down a bit.

also have you set the options for apache to process a php page as per php install instructions. also you will need to restart the apache service after making mods to either php.ini or httpd.conf (service httpd restart)

can you post your code here btw?

hth
 
Old 10-20-2005, 03:28 PM   #5
khuti2005
LQ Newbie
 
Registered: Oct 2005
Distribution: Fedora Core 2 - Gnome
Posts: 9

Original Poster
Rep: Reputation: 0
its ok. ive got it all sorted now.. thanks tho. really do appreciate it. just got sum networking things to solve now

lol bit at a time! but i am well chuffed anywho at least i can get coding again! thanks to all that posted.

khuti
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MySQL, PHP with Apache saudoi Solaris / OpenSolaris 12 11-19-2005 12:47 PM
Apache/PHP/MySQL Problems! Ryand833 Linux - Software 1 04-13-2004 09:37 PM
Apache Mysql Php: mysql with php doesn't work breakerfall Linux - Networking 6 12-27-2003 08:59 PM
apache php-mysql configuration problems ugol Linux - Software 1 11-08-2003 09:13 PM
php-nuke with apache php mysql c0c0deuz Linux - Software 0 03-30-2003 06:23 AM


All times are GMT -5. The time now is 11:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration