LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-23-2009, 10:54 AM   #1
r_s
Member
 
Registered: May 2009
Distribution: slackware, fedora, ubuntu
Posts: 98

Rep: Reputation: 21
MySQL Error


I was trying to install torrent in my ubunty 9.04 when it started configuring MySQL Database it shows an error

configuring MySQL database
An error seems to have occured while installing the database if it's of any help,
this was the error encountered
ERROR 2002(HY000) can't connect to local MySQL Server through socket '/var/run/mysqld/mysqld.sock' (2)

I cannot understand what the problem is ??
now when I run my updates it says configuring torrentflux and then aborts giving the same error.
please help
 
Old 09-23-2009, 11:11 AM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 18,985

Rep: Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313
Quote:
Originally Posted by r_s View Post
I was trying to install torrent in my ubunty 9.04 when it started configuring MySQL Database it shows an error

configuring MySQL database
An error seems to have occured while installing the database if it's of any help,
this was the error encountered
ERROR 2002(HY000) can't connect to local MySQL Server through socket '/var/run/mysqld/mysqld.sock' (2)

I cannot understand what the problem is ??
now when I run my updates it says configuring torrentflux and then aborts giving the same error.
please help
MySQL isn't running on your system. Start it.

As root, type in "/etc/init.d/mysql start". If you can't, you may not have it installed. You can install it via the package manager, by searching for "mysql-server".
 
Old 09-24-2009, 06:25 AM   #3
r_s
Member
 
Registered: May 2009
Distribution: slackware, fedora, ubuntu
Posts: 98

Original Poster
Rep: Reputation: 21
I tried it but it returns "[fails]"
 
Old 09-24-2009, 06:28 AM   #4
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Can you post the output of what you tried and what was the exact output ?
If it failed then as suggested it may not have been installed by default and you may need to install it.
Use synaptic package manager to install it.
 
Old 09-25-2009, 09:36 AM   #5
r_s
Member
 
Registered: May 2009
Distribution: slackware, fedora, ubuntu
Posts: 98

Original Poster
Rep: Reputation: 21
rohit@rohit-laptop:~$ sudo /etc/init.d/mysql start
* Starting MySQL database server mysqld [fail]

When I try installing mysql-server from synaptic package manager it also returns an error.

E: /var/cache/apt/archives/mysql-server-5.0_5.1.30really5.0.75-0ubuntu10.2_i386.deb: subprocess pre-installation script returned error exit status 1
 
Old 09-25-2009, 11:39 AM   #6
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 18,985

Rep: Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313
Quote:
Originally Posted by r_s View Post
rohit@rohit-laptop:~$ sudo /etc/init.d/mysql start
* Starting MySQL database server mysqld [fail]

When I try installing mysql-server from synaptic package manager it also returns an error.

E: /var/cache/apt/archives/mysql-server-5.0_5.1.30really5.0.75-0ubuntu10.2_i386.deb: subprocess pre-installation script returned error exit status 1
Do you have it installed already, and are you trying to run the install command as root?
 
Old 09-26-2009, 05:42 AM   #7
r_s
Member
 
Registered: May 2009
Distribution: slackware, fedora, ubuntu
Posts: 98

Original Poster
Rep: Reputation: 21
Yes I installed it earlier but it installed as a broken packet, so when I run my update manager it shows mysql-server-5.0 as recommend updates but shows this error message when trying to apply the new changes
E: /var/cache/apt/archives/mysql-server-5.0_5.1.30really5.0.75-0ubuntu10.2_i386.deb: subprocess pre-installation script returned error exit status 1.
 
Old 09-26-2009, 07:44 AM   #8
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 18,985

Rep: Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313Reputation: 4313
Quote:
Originally Posted by r_s View Post
Yes I installed it earlier but it installed as a broken packet, so when I run my update manager it shows mysql-server-5.0 as recommend updates but shows this error message when trying to apply the new changes
E: /var/cache/apt/archives/mysql-server-5.0_5.1.30really5.0.75-0ubuntu10.2_i386.deb: subprocess pre-installation script returned error exit status 1.
Ok...then remove the broken package, and do a fresh install.
 
Old 09-27-2009, 04:40 AM   #9
r_s
Member
 
Registered: May 2009
Distribution: slackware, fedora, ubuntu
Posts: 98

Original Poster
Rep: Reputation: 21
I tried it but after removing the package and then reinstalling it the same error message is displayed and it fails to install even as a broken package.
 
Old 09-29-2009, 12:18 AM   #10
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
If you use Synaptic, there is an option to fix the broken packages.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
MySQL 5.0.67: Unable to install & run. Error /var/lib/mysql/mysql.sock' (2) peteyperson Linux - Server 2 03-04-2009 01:16 PM
ERROR 2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql. suziecorbett Linux - Software 8 10-09-2008 01:52 AM
mysql error Can't connect to local MySQL server through socket '/var/lib/mysql/mysql. SpellChainz Linux - Newbie 1 06-23-2007 03:35 PM
mysql error Can't connect to local MySQL server through socket '/var/lib/mysql/mysql. Dannux Linux - Software 3 03-24-2006 08:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration