LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 10-29-2006, 09:45 PM   #1
danscrima
LQ Newbie
 
Registered: Oct 2006
Posts: 3

Rep: Reputation: 0
Unhappy mysql dependency/conflict problem...


I have made a mess of my mysql installation and need to start fresh...

I downloaded the rpm:
MySQL-server-standard-5.0.27-0.rhel3.i386.rpm

..but when i run this:
rpm -ivh MySQL-server-standard-5.0.27-0.rhel3.i386.rpm

..I get this error:
warning: MySQL-server-standard-5.0.27-0.rhel3.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
error: Failed dependencies:
MySQL conflicts with mysql-4.1.20-1.RHEL4.1.i386


Does anyone know how to fix this, with maybe a complete uninstall and complete reinstall... I'm a newbie so this is a little foreign still..
 
Old 10-29-2006, 10:34 PM   #2
PatrickNew
Senior Member
 
Registered: Jan 2006
Location: Charleston, SC, USA
Distribution: Debian, Gentoo, Ubuntu, RHEL
Posts: 1,148
Blog Entries: 1

Rep: Reputation: 48
sounds like you have mysql version 4.1.20-1 installed, so try removing it first with

rpm -e mysql-4.1.20-1.RHEL4.1.i386

then try insalling again with

rpm -ivh MySQL-server-standard-5.0.27-0.rhel3.i386.rpm

but before you try that second command, what distro are you using? Most have some tool to make installing things easier. Fedora has yum, Debian has apt, etc.
 
Old 10-30-2006, 07:38 AM   #3
danscrima
LQ Newbie
 
Registered: Oct 2006
Posts: 3

Original Poster
Rep: Reputation: 0
T tried the rpm -e command, but it did not work. I got this error:
error: package mysql-4.1.20-1.RHEL4.1.i386.rpm is not installed

So I thought that had deleted it, then excuted:
rpm -ivh MySQL-server-standard-5.0.27-0.rhel3.i386.rpm

but still got the error:
warning: MySQL-server-standard-5.0.27-0.rhel3.i386.rpm: V3 DSA signature: NOKEY, key ID 5072e1f5
error: Failed dependencies:
MySQL conflicts with mysql-4.1.20-1.RHEL4.1.i386

I am using CentOS.
 
Old 10-30-2006, 09:26 AM   #4
PatrickNew
Senior Member
 
Registered: Jan 2006
Location: Charleston, SC, USA
Distribution: Debian, Gentoo, Ubuntu, RHEL
Posts: 1,148
Blog Entries: 1

Rep: Reputation: 48
google leads me to believe that centos has yum. Try
yum install mysql-server

if that fails, try
yum update mysql-server

if that fails, try
yum remove mysql-server

then

yum install mysql-server
 
Old 10-30-2006, 06:13 PM   #5
danscrima
LQ Newbie
 
Registered: Oct 2006
Posts: 3

Original Poster
Rep: Reputation: 0
thanks! the yum program seemed to install it, hopefully i can set the master password and get it up and running.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
installing mysql and php4 results in a conflict bshearer *BSD 3 04-29-2005 02:36 PM
Quantum GIS Dependency conflict on Suse 9.2 suse2166 Linux - Software 6 03-20-2005 02:53 PM
Dependency conflict Corrado Linux - Software 1 03-13-2005 11:54 PM
MySQL dependency troubles colabus Linux - Newbie 2 01-19-2005 05:08 AM
Gentoo 1.4 dependency conflict in emerge system Rounan Linux - Distributions 9 03-05-2004 11:59 AM


All times are GMT -5. The time now is 07:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration