LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   MySQL and archive Storage Engine (http://www.linuxquestions.org/questions/linux-newbie-8/mysql-and-archive-storage-engine-4175415715/)

varunb 07-09-2012 11:06 AM

MySQL and archive Storage Engine
 
Hi,

using opensue 11.3 distro.

I have configured and install mysql on my pc. by following the below link
http://unixuptime.com/forum/?p=58

But mysql service is not running.

Code:

linux-twjc:/usr/local/src/mysql-5.0.51b # rcmysql start
Starting MySQL/usr/bin/rcmysql: line 159: kill: (5895) - No such process
                                                                                                                                  failed

linux-twjc:/usr/local/src/mysql-5.0.51b # rcmysql restart
MySQL manager or server PID file could not be found!                                                                              failed
Starting MySQL/usr/bin/rcmysql: line 159: kill: (5999) - No such process

Please some body help

lithos 07-09-2012 02:52 PM

Hi,

probably you didn't install "MySQL" properly, like this example
Code:

yast2 -i mysql mysql-community-server mysql-client perl-DBD-mysql perl-DBI perl-Data-ShowTable
chkconfig --add mysql        <--- this command is used if you want to start MySQL at boot
/etc/init.d/mysql start            <---- this command starts MySQL manually

good luck

varunb 07-10-2012 12:12 AM

Quote:

Originally Posted by lithos (Post 4723199)
Hi,

probably you didn't install "MySQL" properly, like this example
Code:

yast2 -i mysql mysql-community-server mysql-client perl-DBD-mysql perl-DBI perl-Data-ShowTable
chkconfig --add mysql        <--- this command is used if you want to start MySQL at boot
/etc/init.d/mysql start            <---- this command starts MySQL manually

good luck

Hi,

Through yast if i install MySQL is working all fine!!! But there is no option to enable archive storage engine or may be i don't know how to enable it???

Code:

linux-twjc:/usr/local/src/mysql-5.0.51b # mysql
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 5
Server version: 5.1.57-log SUSE MySQL RPM

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> show engines;
+------------+---------+------------------------------------------------------------+--------------+------+------------+
| Engine    | Support | Comment                                                    | Transactions | XA  | Savepoints |
+------------+---------+------------------------------------------------------------+--------------+------+------------+
| ndbcluster | NO      | Clustered, fault-tolerant tables                          | NULL        | NULL | NULL      |
| MRG_MYISAM | YES    | Collection of identical MyISAM tables                      | NO          | NO  | NO        |
| CSV        | YES    | CSV storage engine                                        | NO          | NO  | NO        |
| MyISAM    | DEFAULT | Default engine as of MySQL 3.23 with great performance    | NO          | NO  | NO        |
| InnoDB    | YES    | Supports transactions, row-level locking, and foreign keys | YES          | YES  | YES        |
| MEMORY    | YES    | Hash based, stored in memory, useful for temporary tables  | NO          | NO  | NO        |
+------------+---------+------------------------------------------------------------+--------------+------+------------+
6 rows in set (0.00 sec)

mysql>


need to enable archive storage engine, i googled it, i din't get any info about how to enable it???
some forums says we have to compile it again from the beginning(i mean removing the installed package MySQL) so i am compiling it through source(mysql-5.0.51b) package giving below commands.

Code:

#./configure –with-mysqld-user=mysql –with-archive-storage-engine –datadir=/var/lib/mysql/

 #make && make install

But mysql is not starting!!! bad luck!!!!

lithos 07-10-2012 01:43 AM

Why I don't understand how it's not, because I read here that you select "engine" in "my.cnf" (that is MySQL config)
and that "storage engine is included in MySQL binary distributions"
Now I don't see why you couldn't use it.

varunb 07-10-2012 03:30 AM

this is the my.conf file

Code:


linux-twjc:~ # cat /etc/my.cnf
# Example MySQL config file for medium systems.
#
# This is for a system with little memory (32M - 64M) where MySQL plays
# an important part, or systems up to 128M where MySQL is used together with
# other programs (such as a web server)
#
# You can copy this file to
# /etc/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is /usr/local/mysql/var) or
# ~/.my.cnf to set user-specific options.
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client]
#password      = your_password
port            = 3306
socket          = /tmp/mysql.sock

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
user = mysql
port            = 3306
socket          = /tmp/mysql.sock
skip-locking
key_buffer = 16M
max_allowed_packet = 1M
table_cache = 64
sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 8M

# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
#
#skip-networking

# Replication Master Server (default)
# binary logging is required for replication
log-bin=mysql-bin

# required unique id between 1 and 2^32 - 1
# defaults to 1 if master-host is not set
# but will not function as a master if omitted
server-id      = 1

# Replication Slave (comment out master section to use this)
#
# To configure this host as a replication slave, you can choose between
# two methods :
#
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
#    the syntax is:
#
#    CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
#    MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
#
#    where you replace <host>, <user>, <password> by quoted strings and
#    <port> by the master's port number (3306 by default).
#
#    Example:
#
#    CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
#    MASTER_USER='joe', MASTER_PASSWORD='secret';
#
# OR
#
# 2) Set the variables below. However, in case you choose this method, then
#    start replication for the first time (even unsuccessfully, for example
#    if you mistyped the password in master-password and the slave fails to
#    connect), the slave will create a master.info file, and any later
#    change in this file to the variables' values below will be ignored and
#    overridden by the content of the master.info file, unless you shutdown
#    the slave server, delete master.info and restart the slaver server.
#    For that reason, you may want to leave the lines below untouched
#    (commented) and instead use CHANGE MASTER TO (see above)
#
# required unique id between 2 and 2^32 - 1
# (and different from the master)
# defaults to 2 if master-host is set
# but will not function as a slave if omitted
#server-id      = 2
#
# The replication master for this slave - required
#master-host    =  <hostname>
#
# The username the slave will use for authentication when connecting
# to the master - required
#master-user    =  <username>
#
# The password the slave will authenticate with when connecting to
# the master - required
#master-password =  <password>
#
# The port the master is listening on.
# optional - defaults to 3306
#master-port    =  <port>
#
# binary logging - not required for slaves, but recommended
#log-bin=mysql-bin

# Point the following paths to different dedicated disks
#tmpdir        = /tmp/
#log-update    = /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#bdb_cache_size = 4M
#bdb_max_lock = 10000

# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = /usr/local/mysql/var/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = /usr/local/mysql/var/
#innodb_log_arch_dir = /usr/local/mysql/var/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#innodb_buffer_pool_size = 16M
#innodb_additional_mem_pool_size = 2M
# Set .._log_file_size to 25 % of buffer pool size
#innodb_log_file_size = 5M
#innodb_log_buffer_size = 8M
#innodb_flush_log_at_trx_commit = 1
#innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout



All times are GMT -5. The time now is 12:26 AM.