LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-11-2003, 05:26 PM   #1
rezzer
LQ Newbie
 
Registered: Oct 2003
Posts: 4

Rep: Reputation: 0
my Xserve wont start


after 5 hours straight of trying to install an ati driver (that still isnt installed)
the last thing the guy on rage3d told me to do ,screwed something up cuz i get the error Xserve failed to start..etc ,then it ask me to fix the problem i click OK ,then nothing .

the entire system hangs and my monitor is left in sleep mode.

the last thing he told me to do was loging as root and run the fglrxconfig ,to setup the driver. well after i did that and rebooted thats when i got the error.

if something like this happened in windows on me its and easy fix to restore last known good config.. but in linux i dont know how to go about fixing this ? so any help would be appreciated.
 
Old 10-11-2003, 06:56 PM   #2
rezzer
LQ Newbie
 
Registered: Oct 2003
Posts: 4

Original Poster
Rep: Reputation: 0
is there a way to boot to the command prompt before the xserve tried to load?
 
Old 10-12-2003, 12:33 PM   #3
nirvanix
Member
 
Registered: May 2003
Location: Calgary, Canada
Distribution: Arch Linux
Posts: 194

Rep: Reputation: 30
Usually your 'run level' is set in the file /etc/inittab. It looks something like:

# Default runlevel. (Do not set to 0 or 6)
id:4:initdefault:

Depending on your distribution, you might have a 4 or 5 in there that signals to start x. If you can change this to a 3, save and reboot you will not start up x. If you can't edit this file, but are stuck in some hung x mode, try using the keystroke combination:
<CTL><ALT>F2, or <CTL><ALT>F3....up to <CTL><ALT>F7. This may bring up a console session in which you can log in and edit /etc/inittab or /etc/X11/XF86Config.
 
Old 10-12-2003, 11:22 PM   #4
teknomage1
LQ Newbie
 
Registered: Aug 2003
Posts: 17

Rep: Reputation: 0
I've had this problem especially with my radeon 7500. In the end the only way to make the server run was to edit the XF86Config-4 file and to turn on the option noAccel. To get to the command line to do this try booting to fail safe mode
 
Old 10-15-2003, 05:33 PM   #5
rezzer
LQ Newbie
 
Registered: Oct 2003
Posts: 4

Original Poster
Rep: Reputation: 0
thanks for the help gyus i got it going somehow..dont even know what i did..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't mount XServe RAID FC4 wjstarck Linux - Hardware 3 10-18-2005 04:04 PM
smbmount on Xserve izerec Linux - Networking 1 04-05-2005 08:18 AM
Linux on dual processor Apple xserve G5? yano Linux - Hardware 2 12-22-2004 10:14 AM
X Wont Start Avatar33 Linux - General 3 10-09-2003 05:15 PM
X wont start ..help dilbert Linux - Software 4 03-18-2002 11:02 PM


All times are GMT -5. The time now is 05:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration