LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-03-2009, 01:27 PM   #16
ikon1
LQ Newbie
 
Registered: Oct 2009
Posts: 10

Original Poster
Rep: Reputation: 0

When I first started this thread the headphones were not appearing in lsusb. But then after the dmesg suggested by somedude they started appearing:

lsusb:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 0d8c:0001 C-Media Electronics, Inc. Audio Device
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Yes I did alsa restart. In sound>preferences I've tried setting everything to alsa and also setting everything to C-media usb audio but unfortunately still no joy. I don't have pulse audio. The headphones were a cheap pair bought from Maplins, Yoga EM-178. They are 'call-centre' style with a mic as well. The headset is a standard pair with a jack, which you then plug through a usb dongle.

Thanks for your ongoing help with this.

Last edited by ikon1; 10-03-2009 at 01:30 PM.
 
Old 10-03-2009, 02:59 PM   #17
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
The following things puzzle me:

1] When you modified alsa.conf to use your USB device instead of the 0 [NVidia ]: HDA-Intel - HDA NVidia0 [NVidia ]: HDA-Intel - HDA NVidia and restarted alsa, nothing should have come out of your speakers (which are connected to your on-board sound device), only your headphones. Maybe you need to double-check this all again?

2] There's little on the www about your device: Bus 002 Device 002: ID 0d8c:0001 C-Media Electronics, Inc. Audio Device, which either means it "just works" or there aren't many people using it.

3] Do your headphones work with anything else (eg any music player) ?

4] I hope you don't still have my script (even modified) running from rc.local, because if that is failing somehow it may be restoring your original setup for sound device 0 at the next boot.

So, trim things back to the bare minimum, and change one thing at a time. Test. Re-test.

HTH
 
Old 10-06-2009, 05:23 PM   #18
ikon1
LQ Newbie
 
Registered: Oct 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Thanks to everyone who helped with this. I am now pleased to report that this problem is now solved! This link in an ubuntu forum helped:

http://ubuntuforums.org/showthread.php?t=1130384



Basically I wasn't using PulseAudio properly and was missing a few essential plugins.
 
Old 10-06-2009, 05:36 PM   #19
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
Basically I wasn't using PulseAudio properly and was missing a few essential plugins.
Ah!

I did ask in post #15 if you were using PulseAudio. In post #16 you said "I don't have pulse".

But now it's Yes. Please make up your mind before you post in future.

Anyway - Problem solved. Well done.
 
Old 10-07-2009, 04:27 AM   #20
ikon1
LQ Newbie
 
Registered: Oct 2009
Posts: 10

Original Poster
Rep: Reputation: 0
Well I didn't have pulse audio when I wrote that, or at least it wasn't installed properly with all the plugins. Only yesterday had the pulseaudio shortcut appeared in the tool bar.

Your posts did help: over the weekend I managed to get the testing 'beep' through the headphones for the first time after re-typing the codes in terminal, then after a bit more tweaking I got them to work with media players. But I still had a problem with Flash sound. Then I saw the post I linked above, installed all the plugins he recommended, and managed to get pulseaudio to switch to the usb.
 
Old 10-31-2012, 08:38 PM   #21
SF1979
LQ Newbie
 
Registered: Oct 2012
Posts: 4

Rep: Reputation: Disabled
Bump!

Hello, I would like to ask whether anyone can think of a similar approach for a more recent Yoga 5.1 USB Audio Connector.

As with the last person, it also seems to be a C-Media card. I am running standard 64 12.04 Ubuntu.

Code:
cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7600000 irq 53
 1 [Device         ]: USB-Audio - USB Sound Device
                      C-Media INC. USB Sound Device at usb-0000:00:1a.0-1.2, full speed
The last person said that it eventually started to work for him. I am not sure how that happened, but it has not worked for me, and there seems to be a few differences to alsa but I really do not know enough to act upon that.

Added on edit: I can go into alsamixer and switch between devices from and to my USB device. Here the USB device only has two control bars: "PCM" and "Loudness". I can change "PCM", but "Loudness" is locked on 0. I don't know if that's relevant (I am afraid I don't really understand alsa) but a zero hanging over "Loudness" seemed worth mentioning.

Also, referring to a comment to the previous poster, I still get volume through speakers despite having switched to 1 on conf file and despite alsamixer opening onto the USB mixer on default - so the music still plays through the speakers and changing PCM has no effect upon that either way.

Further edit: Referring to edit above, I can stop the speakers by altering: defaults.pcm.device to 1. But this does not make the USB play.

If anyone has any help I would be very grateful.

Thank you very much in advance.

Last edited by SF1979; 10-31-2012 at 09:11 PM.
 
Old 11-01-2012, 03:33 PM   #22
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Hello SF1979,

I don't spend as much time here on LQ as I used to, and I was about to recommend that you start a new thread rather than resurrect this old one (long threads don't tend to get read by people who have not subscribed to them).

I did a quick search (ubuntu c-media electronics inc. audio adapter) and would suggest that you try the suggestions in this link

Follow the recommendations in that post, and you should be good to go.

Please let us (though probably only me, see above) know how you get on.
 
Old 11-01-2012, 04:52 PM   #23
SF1979
LQ Newbie
 
Registered: Oct 2012
Posts: 4

Rep: Reputation: Disabled
Hello tredegar,

Thank you for your help.

I tried the additional suggestion on that forum regarding altering:
Code:
 options snd-usb-audio index=-2
in:
Code:
 /etc/modprobe.d/alsa-base.conf
I tried a few different values as per suggestions by posters there, but it did not work.
In particular, my alsamixer has a PCM adjuster and a Loudness adjuster, with no bar and values 00.

One thing perhaps, I can only reload/restart by using:
Code:
 sudo /sbin/alsa force-reload
or:
Code:
 sudo /sbin/alsa reload
rather than:
Code:
 /etc/init.d/alsa-utils restart
and so on, as these do not work for me.

Thanks a million!
 
Old 11-02-2012, 06:04 PM   #24
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
One thing perhaps, I can only reload/restart by using:
Code:

sudo /sbin/alsa force-reload

or:
Code:

sudo /sbin/alsa reload

rather than:
Code:

/etc/init.d/alsa-utils restart

and so on, as these do not work for me.

alsa
does not seem to feature in recent ubuntu distributions - it's all pulseaudio now, and I do not pretend to understand that, but it seems to work, for me, for now.

Ubuntu seem to be moving to a systemd way of booting, rather than the traditional "system V" /etc/init.d/* scripts way of doing things so /etc/init.d/alsa-utils restart will no longer work.

One of the reasons LQ does not like to resurrect old threads (like this one) is that linux is dynamic, and changes all the time.

This thread is three years old and linux has moved on, fast.

So, please, be bold, and start a new thread here on LQ with your problem. I expect it will be answered by someone more up to date than I am.

Best wishes,
t.
 
Old 11-02-2012, 10:16 PM   #25
SF1979
LQ Newbie
 
Registered: Oct 2012
Posts: 4

Rep: Reputation: Disabled
Hello Tredegar,

I will look into pulseaudio. And thank you for the explanation regarding systemd, and I kind of see your point on linux' development already from a very brief read up.

I had started a new thread, shortly before you got back to me, but I hedged it very much in terms of this one (which as you say was not wise).

I will give pulseaudio a quick go, and then post up an account of my steps, etc., when I almost inevitably get stuck!

Thanks again, and much appreciated,

SF
 
  


Reply

Tags
audio, automount, headphone, ubuntu, usb


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB headphones & xmms zeratul_mdq Linux - Software 2 02-10-2006 04:22 PM
USB mp3 player not recognised, gives 'USB bus 1 deregistered' tkedwards Linux - Hardware 0 02-01-2006 02:47 AM
USB Headphones SentralOrigin Linux - Hardware 3 10-27-2005 02:48 AM
USB headphones / Speakers ShuttleAU Linux - Hardware 1 04-18-2005 02:48 AM
USB headphones on Linux? Azazzello Linux - Hardware 0 12-23-2004 05:35 PM


All times are GMT -5. The time now is 06:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration