LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   My USB headphones not recognised in Ubuntu (http://www.linuxquestions.org/questions/linux-newbie-8/my-usb-headphones-not-recognised-in-ubuntu-759084/)

ikon1 10-01-2009 06:22 PM

My USB headphones not recognised in Ubuntu
 
Hi everyone,

I have an Acer laptop, some time ago the headphone jack broke so I purchased a USB headphone set. The manufacturer is Yoga and the model is EM-178. I think the USB plug itself has a C Media chip inside. I was using Vista originally.

Anyway I recently converted to Ubuntu 9.4 and unfortunately I can't get ubuntu to recognise this device. There is no automounting, it does not even appear in lsusb. I've plugged in other usb devices with no problem, it's just this one I have the problem with.

Sound from the laptop speakers is fine. I have tried looking at sound>preferences but since it doesn't even recognise the usb is there then I can't select it.

I'm currently using OSS for the sound system, but it didn't work with ALSA either.

I've searched numerous forums and google searches on this, tried a few different things and nothing's worked.

Any help on this would be very much appreciated.

somedude 10-01-2009 06:38 PM

If lsusb doesn't show the device, you may want to look at the system logs for error messages.
Try this: open a console, plug in the device, give it a few seconds and listen to the hard disk for activity and then type dmesg in the console. You should see some kernel messages relevant to the usb device. That may help pinpoint the problem.

ikon1 10-01-2009 06:44 PM

Thanks for that. Just tried dmesg. Here's the relevant piece of info:

[ 2458.860093] usb 2-4: new full speed USB device using ohci_hcd and address 3
[ 2459.112626] usb 2-4: configuration #1 chosen from 1 choice
[ 2459.114360] Reinsert of an audioctl device 4/0 - USB sound device
[ 2459.199251] Reinsert of an audio streaming device 4/1 - USB sound device

So it *does* know it's there!

But how do I get it to work???

somedude 10-01-2009 06:54 PM

I'm sure I won't be able to help you get this working, but I will try to suggest a couple of things.
It looks like the device is recognized, so you may want to try lspci to see if the audio devices show up. In which case you will need to find drivers specifically for it.
Second thing is - look through dmesg to check for other clues - the message says 'reinserted' so it 'saw' it before.
Try
dmesg | grep usb

ikon1 10-02-2009 04:11 AM

Thanks somedude. I will try this. I think I might have to resign myself to finding a new pair of headphones that are compatible with linux. However I've not yet found a model that specifically mentions this, most of them mention windows/mac only.

tredegar 10-02-2009 05:58 AM

"USB headphones" are probably no different from "USB Speakers"
See here for how I got some USB speakers working.
I expect you can do something similar.

ikon1 10-02-2009 06:08 AM

Thanks a lot. I will try this tonight. Actually, I was thinking of buying some usb speakers, then simply plugging in a pair of headphones in the relevant speaker socket. It's a real shame these usb audio devices don't work straight away as they do in Windows. I'm really happy with ubuntu except with this problem.

tredegar 10-02-2009 07:22 AM

Quote:

I will try this tonight.
OK, and please let us know how you get on.

ikon1 10-02-2009 06:26 PM

OK I tried the script and despite the logic of it my headphones still don't work. After trying tredegar's suggestion I tried somedude's dmesg and this is what came up:

[ 0.561682] usbcore: registered new interface driver usbfs
[ 0.561697] usbcore: registered new interface driver hub
[ 0.561721] usbcore: registered new device driver usb
[ 4.368081] usb usb1: configuration #1 chosen from 1 choice
[ 4.426052] usb usb2: configuration #1 chosen from 1 choice
[ 4.426240] usbcore: registered new interface driver libusual
[ 4.426270] usbcore: registered new interface driver usbserial
[ 4.426296] usbcore: registered new interface driver usbserial_generic
[ 4.426298] usbserial: USB Serial Driver core
[ 5.000042] usb 2-4: new full speed USB device using ohci_hcd and address 2
[ 5.218016] usb 2-4: configuration #1 chosen from 1 choice
[ 13.893438] usbcore: registered new interface driver snd-usb-audio
[ 1150.557640] usb 2-4: USB disconnect, address 2
[ 1173.084042] usb 2-4: new full speed USB device using ohci_hcd and address 3
[ 1173.314335] usb 2-4: configuration #1 chosen from 1 choice

No obvious errors??

Maybe Acer laptops are just not meant to use linux.

tredegar 10-03-2009 04:41 AM

Quote:

OK I tried the script and despite the logic of it my headphones still don't work.
What "script"? If you used mine, it will not work as it is, because it was written for Bose USB speakers, not your headphones.

Your headphones are being recognised, but not used.

Please plug in your headphones, wait for them to be recognised, then tell us the output of
cat /proc/asound/cards

ikon1 10-03-2009 05:41 AM

0 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xc0000000 irq 17
1 [Audio ]: USB-Audio - USB Audio
C-Media INC. USB Audio at usb-0000:00:0b.0-4, full speed


I changed 'Bose' to USB-Audio using Treadegar's solution for USB speakers.

tredegar 10-03-2009 06:38 AM

OK, that's good.
Now let's try the next bit one step at a time:
As root, make a backup of the original alsa.conf file:
Code:

cp /usr/share/alsa/alsa.conf  /usr/share/alsa/alsa.conf.original
As root, edit the file /usr/share/alsa/alsa.conf and find this bit:
Code:

# defaults

defaults.ctl.card 0
defaults.pcm.card 0

Change the 0's to 1's
Save the file
Still as root, do
Code:

/etc/init.d/alsa-utils restart
Turn up your volume.
Open your mixer panel, and make sure nothing is muted, or turned down.
Are the headphones working?

ikon1 10-03-2009 08:28 AM

I put the code in, changed 0's to 1's and saved. In the mixer it is recognising the USB device, the volumes are all up. Unfortunately, the sound is still coming from the speakers, not the headphones. I've selected Usb in sound>preferences but still no joy.

Addison0 10-03-2009 08:48 AM

Don't you need any software for USB Headphone?

tredegar 10-03-2009 09:26 AM

Quote:

Unfortunately, the sound is still coming from the speakers, not the headphones.
This is very strange.
Did you restart alsa-utils ? Otherwise those changes to the conf file will not be recognised.

Are you using pulseaudio or something strange?

What exactly are your USB headphones - the output of lsusb should tell us, though you said in your first post that they weren't detected, maybe not by name, but the USB IDs should be listed. Please post them.

Quote:

Don't you need any software for USB Headphone?
If they're detected by the kernel, they should "just work" without any additional software.


All times are GMT -5. The time now is 12:41 PM.