LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-23-2009, 03:21 AM   #1
malickhat
Member
 
Registered: Jun 2009
Posts: 106

Rep: Reputation: 15
My Runlevel is in 333


Hi,
I'm a newbie in Linux ,i've installed fedora 10 in my pc and i'm looking to do RHCT ,so for my studies i made a change in differnet run levels from[1-5],unfortunatley instead of typing 3 i mistyped it as 333 without knowing it i saved the inittab and rebooted my system and problem occurs

the error i get is telinit 333 illegal runlevel

and i don't want to format my entire system ,pls help me to get out of this peoblem

Thanks
Linux newbie
 
Old 06-23-2009, 03:40 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
on the grub screen hit e to edit, and add a 1 to the boot options, that'll stick you into runlevel 1 by force and let you change the file.
 
Old 06-23-2009, 03:49 AM   #3
malickhat
Member
 
Registered: Jun 2009
Posts: 106

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by acid_kewpie View Post
on the grub screen hit e to edit, and add a 1 to the boot options, that'll stick you into runlevel 1 by force and let you change the file.
So you want me to boot in rescue mode with a linux boot cd right.
But can't i do it with some other command line technique
 
Old 06-23-2009, 03:57 AM   #4
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
Quote:
Originally Posted by malickhat View Post
So you want me to boot in rescue mode with a linux boot cd right.
But can't i do it with some other command line technique
No. He want you to boot in single user mode and modify /etc/inittab from the command line. He never spoke about a boot cd.
 
Old 06-23-2009, 03:59 AM   #5
kirukan
Senior Member
 
Registered: Jun 2008
Location: Eelam
Distribution: Redhat, Solaris, Suse
Posts: 1,274

Rep: Reputation: 148Reputation: 148
Quote:
Originally Posted by acid_kewpie View Post
on the grub screen hit e to edit, and add a 1 to the boot options, that'll stick you into runlevel 1 by force and let you change the file.
It means single user mode not a rescue mode, instead of 1 you can type the word "single"

Last edited by kirukan; 06-23-2009 at 04:00 AM.
 
Old 06-23-2009, 04:06 AM   #6
malickhat
Member
 
Registered: Jun 2009
Posts: 106

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by kirukan View Post
It means single user mode not a rescue mode, instead of 1 you can type the word "single"
Still i can't figure it out ,in my Pc all i get is a fedora Loading screen ,and i don't know how to go in a single user mode with this ,please assist me with this .
 
Old 06-23-2009, 04:19 AM   #7
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
When you power on the PC, the first screen (it should have a blue background in Fedora) is the GRUB screen, which let you choose between two or more different kernels. At that point (and you have a few seconds to do this) press the key "E". This will stop the automatic boot process and let you edit the kernel options. Add "1" at the end of the line containing the default kernel parameters ad the system will boot in single user mode.
 
Old 06-23-2009, 04:22 AM   #8
kirukan
Senior Member
 
Registered: Jun 2008
Location: Eelam
Distribution: Redhat, Solaris, Suse
Posts: 1,274

Rep: Reputation: 148Reputation: 148
While you are at grub screen press "e". Look for line with kernel parameters and then edit the line and at the end of it put word "single" or ("1" numeric) and press Enter then at this line press "b" to boot into single user mode.
 
Old 06-23-2009, 04:43 AM   #9
malickhat
Member
 
Registered: Jun 2009
Posts: 106

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by colucix View Post
When you power on the PC, the first screen (it should have a blue background in Fedora) is the GRUB screen, which let you choose between two or more different kernels. At that point (and you have a few seconds to do this) press the key "E". This will stop the automatic boot process and let you edit the kernel options. Add "1" at the end of the line containing the default kernel parameters ad the system will boot in single user mode.
Thanks it works now,thanks all
 
Old 06-23-2009, 05:52 AM   #10
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
meh, how come I get no thanks clicky thing but the guy that repeats exactly what I said does? no fair! Boo hoo...
 
Old 06-23-2009, 05:57 AM   #11
colucix
LQ Guru
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
Quote:
Originally Posted by acid_kewpie View Post
meh, how come I get no thanks clicky thing but the guy that repeats exactly what I said does? no fair! Boo hoo...
Uh... you're absolutely right! I feel as I had stolen one thank from you. I can ask Jeremy to transfer one of mine to you...!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
New Install of PCLinuxOS boots into runlevel 3. Should be runlevel 5 MonctonJohn Linux - General 4 02-01-2008 05:38 PM
Which version for a PII 333, 128ram jonabyte Slackware 11 09-21-2006 02:03 PM
Soun Mixer absent in Runlevel 3 but present in Runlevel 5 debloxie SUSE / openSUSE 1 01-18-2006 10:15 AM
Linux on Imac 333 mhz juankasalas Linux - Distributions 9 01-03-2006 12:56 AM
400fsb running @ 333 jagster Linux - Hardware 1 09-22-2005 02:05 PM


All times are GMT -5. The time now is 04:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration