LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-08-2011, 10:59 PM   #1
noncomputergeek
Member
 
Registered: Oct 2009
Distribution: ubuntu
Posts: 108

Rep: Reputation: 17
My numberpad moves my cursor instead of typing numbers


I'm running ubuntu 11.10 beta.

My keyboard was working just fine, then out of nowhere (sometime yesterday) my numberpad stopped working. (I never mess with keyboard settings btw)
It kinda annoyed me, but I didnt think much of it.
A couple of minutes ago, i held down one of the numbers and my cursor started moving,


How can i get it to stop that and go back to typing numbers (yes, i have num lock on, and it does the cursor thing regardless of num lock being on or not)
 
Old 10-08-2011, 11:13 PM   #2
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Hello,

Prior to this happening, did you install any system updates? Also, I would open your keyboard preferences, and make sure that "Mouse Keys" is not enabled. If not, I would enable and then disable to see if it goes away, before you dig any further down into this problem.

Cheers,

Josh
 
Old 10-08-2011, 11:24 PM   #3
noncomputergeek
Member
 
Registered: Oct 2009
Distribution: ubuntu
Posts: 108

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by corp769 View Post
Hello,

Prior to this happening, did you install any system updates? Also, I would open your keyboard preferences, and make sure that "Mouse Keys" is not enabled. If not, I would enable and then disable to see if it goes away, before you dig any further down into this problem.

Cheers,

Josh
I update my system once a day, so yes, I had updated, but if the updated affected it I wouldn't have noticed because I don't use my numberpad that often.


How do I do the mouse keys thing?
 
Old 10-08-2011, 11:25 PM   #4
noncomputergeek
Member
 
Registered: Oct 2009
Distribution: ubuntu
Posts: 108

Original Poster
Rep: Reputation: 17
I found the mouse key option.
Thanks for the help, it was enabled for some reason.
I appreciate your help, once again.
 
Old 10-08-2011, 11:40 PM   #5
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959Reputation: 1959
X has a built-in feature for controlling the cursor with the numberpad. shift+numlock toggles it.

http://www.tuxfiles.org/linuxhelp/movecursor.html
 
1 members found this post helpful.
Old 10-08-2011, 11:41 PM   #6
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Quote:
Originally Posted by noncomputergeek View Post
I found the mouse key option.
Thanks for the help, it was enabled for some reason.
I appreciate your help, once again.
LOL.... The simple things will get you sometimes
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mouse cursor jumps while typing subetai Slackware 3 07-16-2008 07:24 AM
typing on keyboard jumps to mouse cursor position iomari Linux - General 5 07-26-2007 03:03 AM
SUSE 10 keyboard and X freeze, mouse cursor still moves theboomboomcars Linux - Software 2 03-02-2006 11:33 AM
left numeric keyboard is typing numbers (problem with NumLock on/off) zstingx Linux - General 0 11-10-2003 09:59 AM
Optical mouse's cursor moves jerky Oxyd Linux - Hardware 1 11-02-2003 03:07 PM


All times are GMT -5. The time now is 01:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration