LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-23-2010, 04:57 PM   #1
Thelionroars
LQ Newbie
 
Registered: Aug 2009
Location: Melbourne, Australia
Distribution: Ubuntu
Posts: 19

Rep: Reputation: 1
My keyboard won't pipe


I'm on the command line, as the install for the proprietary ATI driver has failed. I'm following the instructions for troubleshooting here but the pipe "|" key is not working - a tilda "~" shows up when I press it.

I'm wondering if this is because of the keyboard being set as UK instead of US? I did have to change this setting at the graphical login initally, whether from choosing this setting by mistake or the installer choosing it automatically when I chose English UK for the language.

Anyone know what I should do?

I'm using OpenSUSE Edu-li-f-e current (11.3?)
 
Old 12-23-2010, 05:11 PM   #2
Disillusionist
Senior Member
 
Registered: Aug 2004
Location: England
Distribution: Ubuntu
Posts: 1,036

Rep: Reputation: 96
Pipe symbol on UK keyboard is [Shift] plus the bottom left most key (next to the shift)

or [Ctrl]+[Alt] plus the key to the left of [1]

but you should really change the keyboard layout through yast

http://www.howtoforge.com/changing-l...-distributions
 
Old 12-23-2010, 05:14 PM   #3
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
I'm wondering if this is because of the keyboard being set as UK instead of US? I did have to change this setting at the graphical login initally, whether from choosing this setting by mistake or the installer choosing it automatically when I chose English UK for the language.
That's certainly the problem.

In Slackware I'd do
loadkeys /usr/share/kbd/keymaps/i386/qwerty/us.map.gz



The dir structure in Suse may vary.


Cheers,
Tink
 
Old 12-24-2010, 01:48 AM   #4
Thelionroars
LQ Newbie
 
Registered: Aug 2009
Location: Melbourne, Australia
Distribution: Ubuntu
Posts: 19

Original Poster
Rep: Reputation: 1
I managed to get it with the right alt key (which is marked Alt Gr) and the tilda symbol. Thanks for the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
new 12.1 - no pipe key - change 20 times keyboard. how do I edit it to have it again? everal Slackware 3 11-11-2008 04:41 PM
How do I get the pipe symbol on a uk keyboard? markhod Linux - General 4 11-03-2004 03:09 PM
Pipe character ('|') on keyboard. caesius_01 Linux - General 5 10-18-2003 03:12 AM


All times are GMT -5. The time now is 09:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration