LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   my gui linux start automatically but resolution isn't supported (http://www.linuxquestions.org/questions/linux-newbie-8/my-gui-linux-start-automatically-but-resolution-isnt-supported-732921/)

nethol 06-14-2009 07:32 PM

my gui linux start automatically but resolution isn't supported
 
Hi everyone, I just installed centos 4 with a big wide monitor and I do with auto start gui but when I move that machine to another network I can't acces by putty or any other remote control so I connect a different monitor but it doesn support the resolution that my centos has, so I been pressing Ctrl+f1 or f2 but it doesn't get me a shell I just see some proceses that are starting and when I try to see something in the grub I don't know what edit or what combo keys to use for dissabling the gui or to get a shell and try to change the resolution of gui. suggestions? Thanks

sycamorex 06-14-2009 07:42 PM

When you are in grub:
1. press 'e' - it will let you edit grub entries
2. Go to the second line and type the word 'single' at the end of it.
3. type enter (I think it's enter)
4. type 'b' to boot this particular system in a single-user mode. It will not start gui so that you can modify
xorg.conf

Alternatively, you could boot from a live CD, mount your centos partition and modify the file.

hth

Lee_Ball 06-14-2009 07:52 PM

Also, you know CentOS is upto version 5.3 now right?

natte 06-15-2009 05:44 AM

xorg.conf
 
you can go to /etc/X11 folder
edit xorg.conf file:
go to Section "screen"
on Subsection "display"
add# modes 800x600 #or you can change with resolution you like

AncientBrit 06-15-2009 11:43 AM

Hi nethol

I don't have experience of CentOS but if nothing else works for you, this may be helpful.

I have Debian/Lenny and with the screwy Philips tv/monitor I use, Debian always boots up with the display halfway over to the left, losing the login dialog. It's almost certainly not Debian's fault - the Philips HD monitor adjusts itself to what it thinks is the correct sync (and most times it's way off the mark).

I discovered by chance that Ctrl-Alt-NumkeypadPlus or ...NumkeypadMinus rotates through the set of resolutions available with my elderly ATI 3D RAGE PRO AGP 2X video card, and usually one step forwards followed by one step back brings everything into alignment.

I don't claim that this will work for you - I just offer it as a last resort if nothing else works. Others may know whether such a feature exists under CentOS and whether my suggestion is a bunch of aardvark's kidneys.

nethol 06-15-2009 07:45 PM

Thanks every one specially sycamorex the first option worked, for your information yes I know that there is a new version of centos and in the second try about starting with a live cd I just download the live cd for the new version Centos 5 and it doesn't works, I'm using 4 cause we got another linux server with version 4 and they share a lot of things like WINs service, replication in MySQL and is more easy install the second one in the same version. I'll attach the output that gave me with the live CD of CENTOS 5. About your option with CTRL+ALT and minus or plus it doesn't work with my Centos and hardware thanks anyway.

best regards


OUTPUT IN LIVE CD:

Memory for crash kernel (0x0 to 0x0) notwithin permisible range

--------------
WARNING: Cannot find root file system!
--------------

Create symlynk /dev/root and then exit this shell to continue the boot sequence.

bash: no job control in this shell
bash-3.2#


All times are GMT -5. The time now is 02:34 AM.