LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-14-2009, 06:32 PM   #1
nethol
LQ Newbie
 
Registered: Jun 2009
Posts: 2

Rep: Reputation: 0
Question my gui linux start automatically but resolution isn't supported


Hi everyone, I just installed centos 4 with a big wide monitor and I do with auto start gui but when I move that machine to another network I can't acces by putty or any other remote control so I connect a different monitor but it doesn support the resolution that my centos has, so I been pressing Ctrl+f1 or f2 but it doesn't get me a shell I just see some proceses that are starting and when I try to see something in the grub I don't know what edit or what combo keys to use for dissabling the gui or to get a shell and try to change the resolution of gui. suggestions? Thanks
 
Old 06-14-2009, 06:42 PM   #2
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,819
Blog Entries: 1

Rep: Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209Reputation: 1209
When you are in grub:
1. press 'e' - it will let you edit grub entries
2. Go to the second line and type the word 'single' at the end of it.
3. type enter (I think it's enter)
4. type 'b' to boot this particular system in a single-user mode. It will not start gui so that you can modify
xorg.conf

Alternatively, you could boot from a live CD, mount your centos partition and modify the file.

hth
 
Old 06-14-2009, 06:52 PM   #3
Lee_Ball
Member
 
Registered: Jul 2005
Location: Manchester (UK)
Distribution: Fedora CentOS
Posts: 132

Rep: Reputation: 18
Also, you know CentOS is upto version 5.3 now right?
 
Old 06-15-2009, 04:44 AM   #4
natte
LQ Newbie
 
Registered: Aug 2007
Posts: 1

Rep: Reputation: 0
Smile xorg.conf

you can go to /etc/X11 folder
edit xorg.conf file:
go to Section "screen"
on Subsection "display"
add# modes 800x600 #or you can change with resolution you like
 
Old 06-15-2009, 10:43 AM   #5
AncientBrit
LQ Newbie
 
Registered: Apr 2009
Location: Los Angeles
Distribution: Debian Lenny (for now)
Posts: 5

Rep: Reputation: 0
Hi nethol

I don't have experience of CentOS but if nothing else works for you, this may be helpful.

I have Debian/Lenny and with the screwy Philips tv/monitor I use, Debian always boots up with the display halfway over to the left, losing the login dialog. It's almost certainly not Debian's fault - the Philips HD monitor adjusts itself to what it thinks is the correct sync (and most times it's way off the mark).

I discovered by chance that Ctrl-Alt-NumkeypadPlus or ...NumkeypadMinus rotates through the set of resolutions available with my elderly ATI 3D RAGE PRO AGP 2X video card, and usually one step forwards followed by one step back brings everything into alignment.

I don't claim that this will work for you - I just offer it as a last resort if nothing else works. Others may know whether such a feature exists under CentOS and whether my suggestion is a bunch of aardvark's kidneys.

Last edited by AncientBrit; 06-15-2009 at 10:50 AM. Reason: Fix typos
 
Old 06-15-2009, 06:45 PM   #6
nethol
LQ Newbie
 
Registered: Jun 2009
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks every one specially sycamorex the first option worked, for your information yes I know that there is a new version of centos and in the second try about starting with a live cd I just download the live cd for the new version Centos 5 and it doesn't works, I'm using 4 cause we got another linux server with version 4 and they share a lot of things like WINs service, replication in MySQL and is more easy install the second one in the same version. I'll attach the output that gave me with the live CD of CENTOS 5. About your option with CTRL+ALT and minus or plus it doesn't work with my Centos and hardware thanks anyway.

best regards


OUTPUT IN LIVE CD:

Memory for crash kernel (0x0 to 0x0) notwithin permisible range

--------------
WARNING: Cannot find root file system!
--------------

Create symlynk /dev/root and then exit this shell to continue the boot sequence.

bash: no job control in this shell
bash-3.2#
 
  


Reply

Tags
centos, display, gui, resolution, shell, start


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to start bash commands automatically every time I start the computer brgsousa Linux - Software 2 10-18-2007 11:26 AM
Booting linux without having X start automatically Vulnix Linux - Hardware 4 12-15-2005 05:10 PM
GUI automatically answer tools on linux billzhu123 Linux - Enterprise 2 05-05-2005 06:44 AM
Linux 9 GUI doesn't start... krishnanbalak Linux - Software 4 02-25-2004 12:23 PM


All times are GMT -5. The time now is 01:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration