LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-26-2007, 12:48 AM   #1
deyash
LQ Newbie
 
Registered: Mar 2007
Posts: 29

Rep: Reputation: 15
Unhappy my fc6 just got damn slow


hi everybody!

well i have fedora core 6 on my asus P5RD2-VM board based PC and had problems with my ethernet driver.....however the rest of the things were fine ......

yesterday i got that prob fixed by your help.....anyways the newest thing is that now after the ethernet card problem is solved and i used the network well, after rebooting the system i found that the system hangs too long ...

i mean i had to wait more than 30 min.(believe me!) for fedora startup.....and everything runs slow....
the login screen is damn slow...and the gnome session responds very slowly....though kde is faster but i am not able to do anything...

even the network has got down and none of the NIS servers are pinging...

i checked that during boot there is a message

error inserting acpi_cpufreqsomething more which i dont remember)..device not found

also the booting pauses during starting sendmail and cups

now what should i do to get back the original speed

plz suggest something...

PS:the system is perfect with win-XP even now!!
 
Old 03-26-2007, 01:09 AM   #2
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
Have you fully updated Fedora yet, because on a fresh install with discs I got last November, I have the error "inserting acpi_cpufreq" which is taken care of after updating.
Also after a fresh install from those discs I have had sendmail errors showing up in the boot process and in log files, again, that does not happen after next boot-up and/or updates.

Did you use ndiswrapper to get the network card working?
I have run into threads in the past where there were IRQ conflicts after installing ndiswrapper or just using Linux network drivers that had similar "Turtle" effects on the system. Just shuffling pci cards in different pci slots did the trick, which can also work for on-board network adapter. If you do put your hands in the box to shuffle pci cards, make sure to grab the box with one hand first to equalize yourself with it, as ESD (electric static discharge) can render your circuits dead, and try not working in there standing on carpet or linoleum, stand on a concrete floor if you can.
 
Old 03-26-2007, 02:57 AM   #3
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
I had the very same problem.

It took a full system update and then all was fixed.
 
Old 03-26-2007, 10:30 AM   #4
deyash
LQ Newbie
 
Registered: Mar 2007
Posts: 29

Original Poster
Rep: Reputation: 15
hey Jay!!

i stopped the services cups and sendmail as i thought they were of no or little use to me and the speed is better but the network prob is still hovering around..

i have a 100 Mbps lan connection
the servers simply dont ping....instead they show the message host unreachable....i am not able to update the kernel

i am unable to figure out the fault in the settings because as i had mentioned earlier that the network had worked properly on the first occassion....


plz suggest!!
 
Old 03-26-2007, 12:20 PM   #5
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
Check /var/log/messages

Yesterday my laptop seemed to be very unresponsive, and (when I did a <Ctrl-Alt-F1> to get to a terminal session) I found lots of messages like this:
Code:
hdc: drive not ready for command
hdc: status timeout: status=0xd0 { Busy }
which was the kernel trying to access my (empty) DVD drive and getting nothing in response. So it retried after a couple seconds, etc.

A reboot fixed the problem for me, but -- if you've got a flaky hard disk, or even a loose drive connector -- you may be stuck in the same kind of disk access/timeout/retry loop which can really use up CPU cycles.

Re the apci_cpufreq problem, check that you have the i686 kernel version installed. Sometimes the i586 version is installed in error.
 
Old 03-26-2007, 01:19 PM   #6
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
cpufreq can be disabled too; I think you can just uncheck the item by going to "Add/Remove software" and bringing up the list of packages.

Disabling CUPS is helpful too to get some speed but it's not something you'd want to do if you need to use a printer. Even so, better leave it disabled until everything is sorted out.

Now for the NIC. Can you verify whether the module is still loaded? Launch a terminal and type:
su -
root password
lsmod

If there isn't any trace of r1000 on the list, you've lost it. In that case, you can do:
modprobe r1000

And if you still can't get any connection, you will have to reinstall it. It's really exceptional but sometimes that driver does disappear for no apparent reason.

You may also want to do this:
ifconfig -a
That will show more information about your network interface(s). That should show straightaway whether your eth0 is still up or not.

And do the update as soon as your connection is up again. Wait for a box to pop-up that says you've got quite a few updates and just kill it (I haven't got the best experiences with the autoupdater and large updates); instead, in a terminal become root=
su -
root password
and type:
yum check update
that will present you with a long long list of updates (hundreds of MBs by now!). If you're ready, just type y at the end (or n if you don't feel like doing the update right now; you can always rerun yum check update whenever you like; if you choose n, I recommend updating the kernel alone, like this:
yum update kernel kernel-devel kernel-headers.

Last edited by jay73; 03-26-2007 at 01:21 PM.
 
Old 03-26-2007, 04:57 PM   #7
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
The best way I have found is to disable auto update via main menu/system/services and remove the check next to "yum updatesd" at the bottom of the list, with it highlighted, click on "Stop" at the top. To disable it permanently so it does not start up upon re-boot, click "Save" at top left.
Then go to main menu/system/software_updater and wait till it produces a list of updates, remove check marks for three quarters of the list and hit enter to do the updates in one quarter batches (best), or do the works in one shot but most people prefer in batches, that's up to you. I usually leave the kernel packages till last because you need to re-boot for it and re-compile modem/network modules. The GUI software updater is yum also and will take care of dependencies, if you get errors, click on the "Details" link and find which update package has conflicts and remove the check mark next to it to apply the rest of the updates. You can skip any recommended re-boots, only after the kernel packages do you need to re-boot.
If you want to keep all downloaded packages to avoid re-downloading for another possible re-installation, change the value of "keepcache=0" to "keepcache=1" in /etc/yum.conf. The cached packages will be in /var/cache/yum.
 
Old 03-27-2007, 10:29 AM   #8
deyash
LQ Newbie
 
Registered: Mar 2007
Posts: 29

Original Poster
Rep: Reputation: 15
hi

i checked the lsmod and r1000 is appearing in the list ...also in the ifconfig -a gives eth0 UP status.....

one new prob. is that on starting gnome it gives error

what should i do ....should i re install my linux as i am seriously considering this option

plz suggest!!!!
 
Old 03-27-2007, 11:55 AM   #9
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Reinstalling may be helpful and maybe not at all. I think it is essential that we find out what is going wrong before you do a fresh install: maybe there is just something else that needs to be configured or at least a bit tweaked.

Could you be more specific (always do!) about that "error" you're now receiving when using Gnome? From the little you gave us, it could be anything: not being able to log in, freezes, crashes, etc etc
 
Old 03-28-2007, 12:49 PM   #10
deyash
LQ Newbie
 
Registered: Mar 2007
Posts: 29

Original Poster
Rep: Reputation: 15
Red face

hi

well the error was of lib/modules

but what i wanted to convey is that yesterday the system out of nothing just booted in regular fashion and the network worked as well....

however when i tried yum updates it did not show up.....

the important thing is that after rebooting the system the same problem occurred again..... is it that there may b some problem with my hardware as i have noticed that during boot if it detects ethernet device quickly the system runs fine however when it is detected after some delay of say 30 sec. the all sorts of problem come up.....

how should i check if my hardware is fine....
what should i do

plz suggest....
 
Old 03-28-2007, 01:24 PM   #11
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
That sounds perfectly like the kind of issues several of us were experiencing before doing a full system update. I say you have patience and wait until the system boots in a more or less acceptable way, then go for the massive update.

Also, yum not doing anything may be because you try to use it too fast. The thing is that Fedora comes with an autoupdater enabled and while it is scanning (which tends to take quite some time the first times) yum is automatically blocked (just so you don't double-update). You need to let it go ahead until it pops up a box saying you've got well over a hundred updates; then you can kill that box and start using yum. The autoupdater can also be turned off but I like to keep it, it gets much faster after the first update.

Last edited by jay73; 03-28-2007 at 01:26 PM.
 
Old 03-28-2007, 04:43 PM   #12
deyash
LQ Newbie
 
Registered: Mar 2007
Posts: 29

Original Poster
Rep: Reputation: 15
Smile

well that sounds promising......

think i must have patience for sometime

neways thanks for the help !!!!!!
 
Old 04-01-2007, 12:26 AM   #13
deyash
LQ Newbie
 
Registered: Mar 2007
Posts: 29

Original Poster
Rep: Reputation: 15
hi everybody!!

well i am back with my problem......the last 2 days i spent trying all sorts of things but nothing worked exactly......thats the reason i re installed the fedora(2.6.18-1.2798.fc6)......

this time is installed without any error..i installed my network driver again ....but the problem still is valid...

though the system boots perfectly, network does not respond after 5 min. of booting....

i checked ifconfig -a and it gave UP status.....also while trying to update using yum it gave error....
the following is the errors:-

[root@localhost ~]# yum update kernel kernel-devel
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
Could not retrieve mirrorlist http://mirrors.fedoraproject.org/mir...re-6&arch=i386 error was
[Errno 4] IOError: <urlopen error (-3, 'Temporary failure in name resolution')>
Error: Cannot find a valid baseurl for repo: core


[root@localhost ~]# ifconfig -a
eth0 Link encap:Ethernet :17:HWaddr mac id
inet addr:my ip Bcast:???.??.255.255 Mask:255.255.0.0
inet6 addr: the id Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:55 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:7162 (6.9 KiB)
Interrupt:193 Base address:0xe800

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1860 errors:0 dropped:0 overruns:0 frame:0
TX packets:1860 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3467624 (3.3 MiB) TX bytes:3467624 (3.3 MiB)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

plz help me figure out the prob...

Last edited by deyash; 04-01-2007 at 10:21 PM.
 
Old 04-01-2007, 01:03 AM   #14
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
It looks as if your repositories are not set up properly. Anyway, considering the other problems, it may be worthwhile getting a new kernel before looking into that - without using yum.

There is a trick you can apply to install a newer kernel from XP. Well, no, not exactly from XP but it does involve using it.

You can use XP to download kernel kernel-headers and kernel-devel packages from one one of the fedora mirrors (you'll have to download manually, of course). Then switch to fedora and boot into runlevel three by adding 3 to the vmlinuz line from GRUB (select your fedora bootline, then press e, then select vmlinuz, e again, etc).

You'll boot into a terminal; sign in as root with root password. Mount your ntfs partition:

mkdir /mnt/windows
mount -t ntfs /dev/???? /mnt/windows (???? refers to the partition number/letter; to find out what that could be, use
fdisk -l
as a command, which will show all your partitions; it it is the first partition on your first disk, it will probably be hda1 or sda1).

Then do:
cp /mnt/windows/kernel* /home/(username)/ (=copying the kernel files to your fedora)

Next you install the packages with:
cd /home/(username)
rpm -ivh kernel*

After which you unmount your ntfs partition:
umount /dev/????

On next reboot you should be able to select the new kernel from GRUB.

Last edited by jay73; 04-01-2007 at 01:48 AM.
 
Old 04-01-2007, 02:20 AM   #15
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
How about I add to that jay73

I have the 64bit Fedora 6

I could not get my modem/drivers to work with the fresh install of the OS, I struggled for two weeks re-installing many many times (100+ with images and without). I was finally able to connect only after upgrading a few packages. For my modem, irqbalance is a critical package to which there was an update, I downloaded and upgraded these packages:

Quote:
kernel-2.6.18-1.2869
kernel-devel-2.6.18-2869
kernel-headers-2.6.18-2869
ppp
iproute
irqbalance
kudzu
Might have done the traceroute package also
These packages had updates and I could not get the modem to successfully connect without them, to upgrade the kernel packages to a 2.6.19 or 2.6.20 version requires also upgrading nash and mkinitrd packages, and they also have a long list of dependencies which have more dependencies. So it is better to just upgrade to the 2.6.18-1.2869 kernel and not have to spend a day or so trying to satisfy dependencies, then update to latest if you can get the net card happening.
The packages can be downloaded onto a USB pen drive that will automatically be mounted upon boot-up in Fedora and can/may be installed/upgraded from the pen drive.
To upgrade packages use the upgrade option in your install command as such because you'll get errors trying to install. Using the newer package's full name:

Quote:
rpm -Uvh packagename.rpm
This may not resolve your issues, but worth a try.

Last edited by Junior Hacker; 04-01-2007 at 03:30 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FC6 is running slow in my PC arindom Linux - Desktop 3 12-23-2006 03:43 AM
vesafb on 2.6.15+ uses 100% cpu and is damn slow MuLaZ Linux - Hardware 2 03-29-2006 12:34 PM
Fast with DSL Modem but Damn Slow to WinXP schu-r Linux - Networking 0 07-22-2004 01:11 AM
Mozilla is so damn slow DLing stuff? BajaNick Linux - Software 3 06-21-2004 05:45 PM
Mandrake 8.2 damn slow? noname Linux - Distributions 2 05-11-2002 01:23 PM


All times are GMT -5. The time now is 05:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration