LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-03-2012, 08:18 AM   #1
Micky12345
Member
 
Registered: Feb 2012
Posts: 58

Rep: Reputation: Disabled
mutt command


by default mails received using mutt will be saved inside
/var/spool/mail/$user

if i want to change that
that means i want to save the receiving messages in other file then how can i do that
 
Old 03-03-2012, 08:41 AM   #2
lucmove
Member
 
Registered: Aug 2005
Location: Brazil
Distribution: Debian Jessie
Posts: 715

Rep: Reputation: 72
Open your ~/.mutt/muttrc file and add this line:

set spoolfile="$HOME/Mail/inbox"

That's just an example, of course. Everything past the 'equals' symbol can be any file or directory you want.
 
Old 03-03-2012, 09:10 AM   #3
Micky12345
Member
 
Registered: Feb 2012
Posts: 58

Original Poster
Rep: Reputation: Disabled
how to open ~/.mutt/muttrc file

is it using cat
 
Old 03-03-2012, 09:16 AM   #4
lucmove
Member
 
Registered: Aug 2005
Location: Brazil
Distribution: Debian Jessie
Posts: 715

Rep: Reputation: 72
No, 'cat' just shows you the content of the file. You will need a text editor. You should probably use pico, nano or mcedit. Those are command-line based editors. You can also use any other GUI-based editor, like Leafpad, Kate, Kedit, Gedit, you name it.
 
Old 03-03-2012, 03:55 PM   #5
Micky12345
Member
 
Registered: Feb 2012
Posts: 58

Original Poster
Rep: Reputation: Disabled
if u don't mind can u be more specific

how to write it on the command line

thnx in advance
 
Old 03-03-2012, 04:02 PM   #6
lucmove
Member
 
Registered: Aug 2005
Location: Brazil
Distribution: Debian Jessie
Posts: 715

Rep: Reputation: 72
Code:
$ pico ~/.mutt/muttrc
OR

Code:
$ nano ~/.mutt/muttrc
Write, save, close, and run mutt again.
 
Old 03-07-2012, 08:09 PM   #7
Micky12345
Member
 
Registered: Feb 2012
Posts: 58

Original Poster
Rep: Reputation: Disabled
but when i opened mutt using nano and wrote set spoolfile then i got an error that

[Error writting /home/ADMIN/.mutt/muttrc:No such file or directory ]

Last edited by Micky12345; 03-07-2012 at 08:25 PM.
 
Old 03-10-2012, 04:59 AM   #8
Micky12345
Member
 
Registered: Feb 2012
Posts: 58

Original Poster
Rep: Reputation: Disabled
plz.......... anyone plz help
very urgent
 
Old 03-10-2012, 09:58 AM   #9
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,954

Rep: Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693
Quote:
Originally Posted by Micky12345 View Post
plz.......... anyone plz help
very urgent
Spell out your words. And we volunteer our time here, so don't tell us to hurry up...this isn't urgent for anyone here.

You were given the solution above. What part did you not understand?

You saw an error message that said the file didn't exist. Now, think about it for a second: mutt won't work, because the file was missing. You are CREATING the file, and adding the line you were told to add in the VERY FIRST REPLY. Once you do that, and save your work, you will have CREATED the missing file.
 
Old 03-10-2012, 12:25 PM   #10
lucmove
Member
 
Registered: Aug 2005
Location: Brazil
Distribution: Debian Jessie
Posts: 715

Rep: Reputation: 72
Quote:
Originally Posted by Micky12345 View Post
but when i opened mutt using nano and wrote set spoolfile then i got an error that

[Error writting /home/ADMIN/.mutt/muttrc:No such file or directory ]
Are you sure you know how to use nano? You need to open the file with it, even if the file doesn't exist. If the file doesn't exist, it will be created when you issue the command to save it. You can either issue the command to save it or the command to exit nano. If you choose to exit nano, it will ask you if you want to save the file, and if you say YES, the file will be created.

If that's too difficult to you, try it with another text editor.
 
Old 03-11-2012, 09:16 PM   #11
Micky12345
Member
 
Registered: Feb 2012
Posts: 58

Original Poster
Rep: Reputation: Disabled
sorry for the trouble

i did in the following way....
on the command prompt i type
Code:
nano ~/.mutt/muttrc
then i got another window where i typed

Code:
set spoolfile="$HOME/Mail/inbox"
then i did ctrl + X to exit so asked for saving

i said yes

so i got a mesg saying
File Name t oWrite : /home/ADMIN/.mutt/muttrc

i pressed enter
so i got an error saying

[Error writting /home/ADMIN/.mutt/muttrc:No such file or directory ]


if u don't mind plz help
 
Old 03-12-2012, 10:41 AM   #12
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,954

Rep: Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693Reputation: 3693
Quote:
Originally Posted by Micky12345 View Post
sorry for the trouble
i did in the following way....on the command prompt i type
Code:
nano ~/.mutt/muttrc
then i got another window where i typed
Code:
set spoolfile="$HOME/Mail/inbox"
then i did ctrl + X to exit so asked for saving i said yes so i got a mesg saying
File Name t oWrite : /home/ADMIN/.mutt/muttrc

i pressed enter so i got an error saying
[Error writting /home/ADMIN/.mutt/muttrc:No such file or directory ]

if u don't mind plz help
Again, you need to SPELL OUT YOUR WORDS. It's "you" not "u", "please" not "plz".

Is your user ID ADMIN? Are you running that command as root? If not, you are only going to be able to write to your own home directory, and also be aware that Linux is case sensitive..."/home/admin" is NOT the same as "/home/ADMIN", so if you entered that manually, check the case.

If you want to get even simpler, since this seems a bit much for you, try:
Code:
echo "set spoolfile=\"$HOME/Mail/inbox\"" > ~/.mutt/muttrc
Which will do nothing but put that ONE LINE into the muttrc file, creating it in the process
 
Old 03-14-2012, 02:07 PM   #13
lucmove
Member
 
Registered: Aug 2005
Location: Brazil
Distribution: Debian Jessie
Posts: 715

Rep: Reputation: 72
Maybe you don't have the .mutt directory. Create it:

# mkdir -p /home/ADMIN/.mutt

Then try again.

Note that Linux is a case-sensitive operating system. You could have /home/ADMIN and /home/admin at the same time, and they would be completely different, unrelated items. You probably just have one, and most people use lowercase, so check if your home directory is indeed /home/ADMIN and not /home/admin.

Last edited by lucmove; 03-14-2012 at 02:11 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can not send email in command line with mutt golden_boy615 Linux - Networking 6 12-31-2011 02:12 PM
Mutt experts - Mutt won't use the Maildir I specify in .muttrc moistTowelette Debian 2 08-24-2009 09:04 AM
LXer: A month on the command line, Day 15: I get POP into mutt LXer Syndicated Linux News 0 05-18-2007 07:47 AM
LXer: A month on the command line, Day 12: Mutt barks! LXer Syndicated Linux News 1 05-15-2007 08:39 AM
send email with mutt on command line naijaguy Linux - General 1 12-29-2004 07:33 PM


All times are GMT -5. The time now is 09:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration