LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-16-2002, 11:55 AM   #1
magis
Member
 
Registered: Oct 2001
Distribution: Mandrake 9.0
Posts: 65

Rep: Reputation: 15
Mutex destroy failure?? What the


Having gone through a few nightmares, trying to setup my adsl speedtouch usb modem, i eventually succeeded. See post below.
(thanks to this forum)

This internet connection, is now configured to start on boot. Now when i was on the internet, i dowloaded quiet a few update packages and configured the shorewall firewall. Everything worked perferctly.

My kmail worked, i received and sent emails without a problem. I was able to surf and even dowloaded and installed yahoo messenger. Which also worked.

When i decided to reboot to go back to windows for something else, on returning to Mandrake, i saw the modem go through its sequence and i assumed i was connected.

I checked ifconfig in the terminal and i had the ppp0 connection but was unable to surf, send mail or do anything. Then the terminal window stated the following:

Mutex destroy failure. Device or resource busy.
deinit: Fatal IO error: client killed.
deinit: sending SIGHUP to children
deinit: sending SIGTERM to children
deinit: Exit

I have checked all the files i did for the speedtouch modem and all are as they were when i was able to connect.

Not sure what this error message means and would be grateful for any help on it.

I am using Mandrake 9.0

Many thanks............

Last edited by magis; 12-16-2002 at 05:05 PM.
 
Old 12-16-2002, 04:20 PM   #2
isajera
Senior Member
 
Registered: Jun 2001
Posts: 1,635

Rep: Reputation: 45
muted or mutex? mutex probably means a driver problem, or maybe, but less likely, a kernel issue. what driver are you using?
 
Old 12-16-2002, 05:09 PM   #3
magis
Member
 
Registered: Oct 2001
Distribution: Mandrake 9.0
Posts: 65

Original Poster
Rep: Reputation: 15
Not sure i understand, i installed the speedtouch/mgmt.o and edited all the files as per the instructions.

The only thing i installed was the one above, the rest was editing certain files and running the modem, which first off worked great.

Sorry if i am a little vague but i am soooo new to this.

Many thanks though
 
Old 04-25-2003, 12:18 PM   #4
mjolnir
Member
 
Registered: Apr 2003
Posts: 748

Rep: Reputation: 82
I have a dual boot xp/mdk9.1 sys. Xp is fat32 and I am using a
"root" terminal to rw to the windows files. So far I have used vi
and kwrite successfully. When I use kwrite the terminal prints
kbuildsycoca and then opens kwrite with the file loaded. After I
edit,save and exit the terminal prints "mutex destroy failure:device or resource busy". I hit enter and go back to the prompt. My question is am I harming the sys in some way and how do I avoid that?
 
Old 08-22-2003, 01:23 PM   #5
braziland
LQ Newbie
 
Registered: Aug 2003
Location: twin falls
Distribution: Mandrake 9.1
Posts: 1

Rep: Reputation: 0
What happened on this thread?
I am having the same problem.
The following message (Mutex destroy failure: Device or resource busy) shows up only after you save and exit Kwrite.

Thoughts?
 
Old 08-27-2003, 01:12 PM   #6
hexx
Member
 
Registered: Aug 2003
Location: Canada
Distribution: Mandrake
Posts: 91

Rep: Reputation: 15
same here after i dont do anything in xterm for long time i get that msg:

mutex destroy failure:device or resource busy
 
Old 11-12-2003, 05:31 AM   #7
ademalet
LQ Newbie
 
Registered: May 2003
Location: Sydney, Australia (at this point in time!)
Distribution: Fedora Core 1 (RedHat)
Posts: 20

Rep: Reputation: 0
anyone solved this problem yet?

I have it after logging in as root and using kedit in Fedora Core 1. Does not seem to be affecting anything, however it is annoying.

Ideas??
 
Old 11-13-2003, 04:55 PM   #8
zippercow
LQ Newbie
 
Registered: Nov 2003
Location: inside
Distribution: PCLinuxOS .93a, SUSE 10.1, Mandriva 2007
Posts: 23

Rep: Reputation: 15
Alright, I'm having a similar error message:

Mutex destroy failure: Device or resource busy

It only seems to happen to me when exiting a program, and hasn't really been anything other than a mild annoyance as of yet, but I would like to figure out what the hell is causing it. If it helps at all, I'm using a fairly clean install of mandrake 9.2, and this did not initially happen.
 
Old 11-14-2003, 08:37 AM   #9
toastermaker
Member
 
Registered: Oct 2003
Location: coastal alabama, united states
Distribution: Mandrake 10.0 official, slackware 9.1
Posts: 219

Rep: Reputation: 30
To add to the pandemonium,
I get the mutex destroy failure while using ssh over my lan. I had thought (and still do in my case) that it was because I'm learning ssh and networking and am just screwing up.
I've subscribed to this thread though, just in case.
 
Old 11-14-2003, 11:21 PM   #10
hexx
Member
 
Registered: Aug 2003
Location: Canada
Distribution: Mandrake
Posts: 91

Rep: Reputation: 15
when ever i use konqueror from terminal then close konqueror its give me that msg..so its konqueror for me..
 
Old 11-15-2003, 06:42 AM   #11
toastermaker
Member
 
Registered: Oct 2003
Location: coastal alabama, united states
Distribution: Mandrake 10.0 official, slackware 9.1
Posts: 219

Rep: Reputation: 30
I googled for about 45 min. This so far was the only thing I found that says it understands and can fix what causes the "mutex destroy failure" error
Note:
Every thing I found about the error so far said it wasnt harmful. But this link seems to say the error is caused by the same problem that causes some apps to not open after certain upgrades etc...
I dont yet have the skill to know if the fix this link I posted applys to magis (or my or anyone elses) situation or not.

Plese post back as you further understand or resolve or find better links to this problem

http://bugs.kde.org/show_bug.cgi?id=41867

Continued gratitude to all those who help us newbies.

Last edited by toastermaker; 11-15-2003 at 06:53 AM.
 
Old 12-23-2003, 07:10 PM   #12
linuxfond
Member
 
Registered: Jan 2003
Location: Belgium
Distribution: Mandrake 9.2
Posts: 475

Rep: Reputation: 30
Mutex destruction failed! That sounds like good news, as long as Devices and Resources are busy doing what they should do. Good! Guys, I am using mdk since July 2001, and since than I see that nothing can destroy the Mutex. Yeah! I know the msg doesn't look innocent but its okay.

N.B. Next month I plan to say farewell M$ Windzoo. Why to dual boot and upgrade-upgrade-upgrade the Norton?
 
Old 04-02-2004, 06:02 PM   #13
hooya27
Member
 
Registered: Aug 2003
Location: In a van down by the river
Distribution: Mandrake
Posts: 48

Rep: Reputation: 15
Mutex destruction failed! All your base are belong to us. Make your time.

I wish it said that instead.

Yeah, as far as I can see it is when running kde/x apps from a console, usually as root. But apparently it does nnnnnnnnnnoooooooooo hhhhhhhhhhhaaaaaaarmrrrrrrrrmrmrm.

later
 
Old 04-02-2004, 06:25 PM   #14
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
Its a KDE thing. Happens to me too if I run any KDE application from a terminal. Its annoying but harmless.
 
Old 03-04-2005, 02:38 AM   #15
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
Same problem [edit add: usually use terminal as root]
Mandy 10.1 CE / kernel 2.6.8.1
konqueror versino and kde version (do not remember)

mutex error very very often, harmless but ennoying when it comes
in the middle of what you are typing in the command line

Happen every time I am in terminal window lauching kwrite /somefile &

or konqueror &

No clue about what to do...

Last edited by Emmanuel_uk; 03-04-2005 at 03:16 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mutex Destroy Failure / ICE default IO error SirSlappy Linux - General 0 02-01-2005 08:55 PM
Will it destroy my Monitor? chinaundead Linux - Hardware 9 04-01-2004 09:56 PM
problem installing KDE themes-"Mutex destroy failure:Devise or resource busy" kpachopoulos Linux - Newbie 2 02-28-2004 04:18 PM
problem installing KDE themes-"Mutex destroy failure:Devise or resource busy" kpachopoulos Linux - Software 0 02-28-2004 09:45 AM
I will destroy QT and all who follow it!!!! ciphercam Linux - Software 4 07-17-2003 01:33 AM


All times are GMT -5. The time now is 02:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration