LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-30-2003, 03:37 PM   #1
mvega
LQ Newbie
 
Registered: Jul 2003
Posts: 5

Rep: Reputation: 0
Question Multiple LUN support & need scsi inquiry command...


Hi:

I just compiled and installed the Qlogic qla2x00 module on RH8.
I also edited the /etc/modules.conf file and added the following
lines:
alias scsi_hostadapter0 qla2200
options scsi_mod max_scsi_luns=128

A subsequent "modprobe qla2200" installed the module
without compaint. The problem is that I only see one of
three drives/luns as shown here (luns 1 & 2 are missing):

=====================================
cat /proc/scsi/scsi

Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
Vendor: HITACHI Model: OPEN-9 Rev: 0118
Type: Direct-Access ANSI SCSI revision: 02
=====================================

Here are my 3 questions

(1) How can I tell if my kernel has Multiple LUN Support
built in? (other than modprobe not compaining above).

(2) What command can I use to perform an inquiry on
available scsi disks (similar to the format command in
Solaris)? I tried scsidev 1.5-3 but it fails as follows:

root# scsidev
Found scsi device /dev/scsi/s
h0-0c0i0l0 QLogic QLA2200 PCI to Fibre Channel Host Adapter:
bus 3 device 6
mknod (/dev/scsi/s
h0-0c0i0l0) failed

Is there a better command (or am I doing something wrong
with scsidev). BTW... fdisk is not quite doing it for me.

(3) Why might I not be seeing the other two LUNs (located at
lun 1 & lun 2)?

Thanks In Advance.
Milton
 
Old 09-23-2003, 11:10 AM   #2
niverson
Member
 
Registered: Jun 2003
Location: Colorado
Distribution: Fedora Core 4
Posts: 128

Rep: Reputation: 15
Have you gone to /usr/src/linux-2.x and done a 'make xconfig' to create a kernel configurator xwindow. Inside xconfig load the config file from /boot. You can then see what options are selected in the various kernel fields.


Enabling multiple LUNs is an option in the SCSI submenu.
Nate
 
Old 09-23-2003, 06:48 PM   #3
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Debian + Ubuntu
Posts: 4,358

Rep: Reputation: 57
Or, for a quick check, go into your Linux source directory (/usr/src/linux-X.X.X) and type cat .config | grep -i "lun". If you see a line like this: CONFIG_SCSI_MULTI_LUN=y, then you do (at least in your .config file - so presumably in your running kernel it compiliing went OK). If not, then possibly not.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiple LUN Issue Crazy Joe Davol Linux - Hardware 2 11-03-2004 12:16 PM
RedHat 9.0, QLA2342, SCSI Generic, Inquiry issues niverson Red Hat 0 10-22-2003 03:19 PM
How to set multi LUN for scsi CloudBuilder Red Hat 0 10-13-2003 06:51 PM
enable multi LUN support @ boot? ewto Linux - Newbie 0 10-13-2003 10:05 AM
Multi-LUN SCSI support? mattcole Linux - Hardware 3 02-17-2003 12:52 AM


All times are GMT -5. The time now is 08:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration