LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-02-2002, 03:47 AM   #1
shusseina
Member
 
Registered: Jan 2002
Location: Auckland, New Zealand
Distribution: Mandrake 8.1 on me server, Mac OS X on me Desktop
Posts: 41

Rep: Reputation: 15
Question MS Natural Keyboard


I use a MS Natural keyboard with my Mandrake 8.1 PC. I notice on powering up my PC, num lock is always off and I have to press num lock to use the numeric key pad.

How do I enable num lock on startup?

Thanks in advance!

Last edited by shusseina; 10-02-2002 at 03:51 AM.
 
Old 10-02-2002, 07:37 AM   #2
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Rep: Reputation: 30
Is it that much of a hassle turning it on all the time
other than that i am not too sure...could be just how the keyboard is...
 
Old 10-02-2002, 08:00 AM   #3
shusseina
Member
 
Registered: Jan 2002
Location: Auckland, New Zealand
Distribution: Mandrake 8.1 on me server, Mac OS X on me Desktop
Posts: 41

Original Poster
Rep: Reputation: 15
Thanks for the help!

It would be nice if the numeric key pad was enabled automatically, as I keep typing in numbers only to find the key pad disabled.

If they can do it on Windows, we can do it BETTER on Linux!

There must be some sort of keyboard configuration/setup file somewhere???

Last edited by shusseina; 10-02-2002 at 08:36 AM.
 
Old 10-02-2002, 08:20 AM   #4
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Rep: Reputation: 30
yes there should be, but if the memory of the keyboard turns off the num lock when you shut down, and STAYS off when you turn on, it could be just the limitations of the keyboard...

have you tried this keyboard in windows ?
 
Old 10-02-2002, 08:37 AM   #5
shusseina
Member
 
Registered: Jan 2002
Location: Auckland, New Zealand
Distribution: Mandrake 8.1 on me server, Mac OS X on me Desktop
Posts: 41

Original Poster
Rep: Reputation: 15
I've never ever had this problem in Windows, which suggests it is possible in Linux surely!
 
Old 10-02-2002, 09:12 AM   #6
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Rep: Reputation: 30
It could be your keyboard layout...are you using KDE ?
 
Old 10-02-2002, 09:24 AM   #7
shusseina
Member
 
Registered: Jan 2002
Location: Auckland, New Zealand
Distribution: Mandrake 8.1 on me server, Mac OS X on me Desktop
Posts: 41

Original Poster
Rep: Reputation: 15
Yes I'm using KDE 2 under Mandrake 8.1.

There doesn't seem to be many keyboard options in Mandrake Control Centre. The keyboard is set to 'US keyboard'. The other options are US (International), UK keyboard or various language/regional keyboards (e.g. Spanish, Ukrainian, etc).
 
Old 10-02-2002, 09:38 AM   #8
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Rep: Reputation: 30
Ok i have found it shusseina, go to your KDE CONTROL PANEL, not your Mandrake one, then go to peripherals, then go to keyboard, then to the 'Advanced' tab, and there SHOULD be an option like this:
NumLock on KDE startup
Turn On
Turn Off
Leave Unchanged


well turn it on ....if it is on......select leave unchanged...and see what happens!!

Garry
 
Old 10-02-2002, 09:41 AM   #9
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 56
And here is the direct answer
http://archive.linuxfromscratch.org/...2/05/0094.html
but beware, on some setups it can screw up your X session
http://www.linuxgazette.com/issue34/tag/numlock.html
 
Old 10-02-2002, 09:53 AM   #10
GT I.N.C
Member
 
Registered: May 2002
Location: Australia, Sydney, St.Clair
Distribution: Rh 7.3
Posts: 836

Rep: Reputation: 30
sorry mines not good enough neo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Natural painting for Linux auricle Linux - Software 2 11-06-2005 06:55 PM
M$ Natural Keyboard TotalLinuxNoob Linux - Software 8 09-05-2005 05:38 PM
M$ natural keyboard pro problems fiikske Linux - Newbie 1 08-02-2004 05:21 AM
Program MS Natural Keyboard mooreted Linux - Hardware 4 03-12-2004 03:24 PM
natural selection on linux Independence Linux - General 0 11-02-2002 06:29 PM


All times are GMT -5. The time now is 09:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration