LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-01-2004, 01:01 AM   #1
jeffxor
LQ Newbie
 
Registered: Feb 2004
Location: Sydney, Austalia
Posts: 15

Rep: Reputation: 0
Mplayer XFree86 4.3 Geforce FX 5200


XFree86 Version 4.3.0
Slackware v9.1
MPlayer-1.0pre3 (Installed from Source)

I have download and followed the instructions to install the latest Nvidia driver (NVIDIA-Linux-x86-1.0-5336-pkg1.run) for my Geforce FX 5200 and also updated my Xfree86Config file as stated in the README file.

When I attempt to start Mplayer mplayer -vo x11 /mnt/dvd/EW-aliens-1of2.avi

Starting playback...
VDec: vo config request - 640 x 480 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [x11] 640x480 => 640x480 Planar YV12
No accelerated colorspace conversion found
SwScaler: using unscaled Planar YV12 -> BGR 8-bit special converter
BGR not supported, please contact the developers
FATAL: Cannot initialize video driver.

FATAL: Could not initialize video filters (-vf) or video output (-vo).


I also checked xvinfo and got the following:-

X-Video Extension version 2.2
screen #0
no adaptors present

and glxgears returns the following:
Error: couldn't get an RGB, Double-buffered visual

Quite clearly I have done something wrong can anyone shed some light

Thanks
 
Old 02-01-2004, 04:01 AM   #2
crashmeister
Senior Member
 
Registered: Feb 2002
Distribution: t2 - trying to anyway
Posts: 2,541

Rep: Reputation: 47
That doesn't look like the nvidia drivers get loaded.Check with the Xfree.log what driver it loads.
 
Old 02-01-2004, 10:29 AM   #3
tricky_linux
Member
 
Registered: Jul 2003
Distribution: Red Hat Linux 9.0; Old and Solid
Posts: 674

Rep: Reputation: 30
what fps are u getting using glxgears?
 
Old 02-06-2004, 06:25 PM   #4
jeffxor
LQ Newbie
 
Registered: Feb 2004
Location: Sydney, Austalia
Posts: 15

Original Poster
Rep: Reputation: 0
crashmeister yes you where right thanks I googled around a bit and found that slackware 9.1 has sometrouble with the new Nvidia installation pakage. I was able to find a website that i followed exactly to get everytyhing up and running.

http://www.linuxquestions.org/questi...003/09/3/64133

For those that have the same problem my solution was:

Uninstall the package using the --unistall option
Download versiion .4496 tar.gz drivers
make
make install

I also then had a prolem with my XFree86 config
So I also had to run Xfree86Config and make the approriate changes to my config file to get X windows up again. Everything is covered much better in the post at the above URL.

Cheers thanks for the help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GeForce FX 5200 Question gibran Linux - Hardware 5 08-05-2005 01:36 PM
GeForce FX 5200 and Redhat 9 Dyne Linux - Hardware 27 12-26-2004 07:20 PM
driver for Geforce Fx 5200 zexter Linux - Games 8 11-05-2004 01:29 PM
Mouse pointer distorted on XFree86 4.3 with Geforce FX 5200 EnigmaX Linux - General 1 06-06-2004 10:51 PM
Debian Woody Xfree86 abit Geforce 4 FX 5200 (EE) No devices detected ---> no screens /su Debian 9 07-21-2003 03:19 PM


All times are GMT -5. The time now is 09:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration